WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] Secure Page Redirects Back and Forth Between Protocols (6 posts)

  1. TonyTheJet
    Member
    Posted 1 year ago #

    One issue I am experiencing with a single page that has SSL enabled is that if I type in the secure link, it will redirect to HTTP, and if I type in the non-secure version, it will redirect to HTTPS. So the page can be viewed in HTTP by typing in the HTTPS URL, and the page can be viewed in HTTPS by typing in the HTTP URL.

    Here are the two URLs to see for yourself:

    HTTPS: https://secure.bluehost.com/~carmell7/?page_id=51
    HTTP: http://www.carmellascuisine.com/?page_id=51

    Whichever one you browse to, it will take you to the opposite. This is problematic for two reasons:

    1. I don't want anyone getting to the page without SSL
    2. I can't post any of the data on that page, because a redirect occurs before the data can be processed.

    Thanks!

    http://wordpress.org/extend/plugins/wordpress-https/

  2. BH_WP_Guru
    Member
    Posted 1 year ago #

    When I try each of those links, it does not redirect at all, but goes directly to the same URL that I clicked on. Make sure you clear your browser cache to make sure old redirects are not saved inside your computer.
    I did notice that if I click any link on the page, after going to either of those links, then it will take me to the non-secure version of the next pages. That has to do with your wordpress settings. You have to set both the Site URL and Home URL to the secure.bluehost.com URL inside your Dashboard.

  3. TonyTheJet
    Member
    Posted 1 year ago #

    Thanks for your response, BH_WP_Guru.

    I guess it must be a caching issue. I thought of that initially, but I tried it on two separate machines with the same result, so I discarded that thought and forgot to trying clearing cache first.

    I'll give it a shot.

    Thanks,

    Tony

  4. TonyTheJet
    Member
    Posted 1 year ago #

    Hmmm...after clearing my cache, I still see the same behavior.

    Actually, after reading your post, it appears that you were experiencing the same problem, but I probably did not word my question correctly. Both of the links I posted should go to the HTTPS version. It should not be possible at all to access the HTTP version.

    The switching back and forth occurs if you go, say, to the HTTPS version, and then try to go to it again from there (for example, you click in the address bar and hit "ENTER"). Then, it switches protocols for no reason.

    I have verified this behavior on two machines with different ISPs, in browsers that have never visited the site, as well as on my Droid phone.

  5. bhpress
    Member
    Posted 1 year ago #

    Ok if you want to use those you actually need to change your wp-urls.

    You will want to change the default URL for the website when using WordPress's script.  This is configured when WordPress is installed. You can change this configuration in the database what the default URL is for your WordPress site.

      1)  In the cPanel, choose phpMyAdmin icon and, in left column, choose your WordPress *database.
      2)  Select the wp_options table on the left column.
      3)  Along the top, click the Browse tab.
      4)  There are two records to modify.  Record #1 (siteurl) and #39 (home) (these can vary, but unlikely).  For each, click the pencil icon to edit and change the option value to read the URL that you intend your links to display, such as http://domain.com.

    You can find the database name, if you dont' know it, in the wp-config.php file.

  6. TonyTheJet
    Member
    Posted 1 year ago #

    That's what I was afraid of. I think I'll just hard-code a script to force SSL on that checkout page, no matter what, and then I'll post to a secure script outside of WP that pulls in my theme's functions and classes. I didn't want to have to play hard-ball, but that's looking like the best option, at this point.

    I think native SSL support is something that needs to happen in order for WP to be viewed as more than just a blogging engine. Maybe it's already in the works!

    Thanks for taking the time to respond!

    Tony

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic