WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] Redirect loop after upgrading (18 posts)

  1. Keith
    Member
    Posted 2 years ago #

    After installing this program the admin area goes into an infinite loop trying to redirect to wp-admin/edit.php

    version 3.0.3 did not contain this problem.

    http://wordpress.org/extend/plugins/wordpress-https/

  2. practicallydutch
    Member
    Posted 2 years ago #

    Same issue here.

  3. xiongeek
    Member
    Posted 2 years ago #

    Having the same issue. Any page with force SSL on will do endless redirects ending in error 310: Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects. in Chrome. Need this fixed soon! Everything was fine with version 3.0.3

  4. gowrann
    Member
    Posted 2 years ago #

    Same issue here

  5. wssit
    Member
    Posted 2 years ago #

    I'm having the same issue as the others. I'm using a shared SSL an this is the secure path to my site: https://secure.netsolhost.com/035903d.netsolhost.com/wordpress1. The site pages will show but after activating the plugin wp-admin/edit.php is in an infinite redirect loop. I'm not using custom permalinks - I'm using the postname permalinks. I tried the fix you listed about uncommenting //define('WPHTTPS_RESET', true); but it didn't work. Any help would be appreciated.

  6. gowrann
    Member
    Posted 2 years ago #

    I reinstalled the older one - after deleting the newer version - you can download from...

    http://downloads.wordpress.org/plugin/wordpress-https.3.0.3.zip

  7. Keith
    Member
    Posted 2 years ago #

    I also reinstalled the 3.0.3 version of the plugin which is working properly.

  8. WendellH
    Member
    Posted 2 years ago #

    I tried that, and while I don't get the 310 error in the admin area, it still occurs on SSL-enabled pages.

  9. paulroberts
    Member
    Posted 2 years ago #

    I'm getting a white page with "Unknown action" for all admin pages on a multi-site install with the plug-in active, the Network Admin page is unaffected.

    I've reverted to the 3.0.3 version

  10. monkseo
    Member
    Posted 2 years ago #

    I get the same problem with 3.0.3 and .4 when I select only force on pages with force enabled and when I goto the checkout page it goes to https then http and back and forth a bunch till the page crashes.

  11. jessemeyers
    Member
    Posted 2 years ago #

    Installation details:
    Wordpress 3.3.2
    Plugins:
    WP e-Commerce 3.8.8.1
    Gold Cart for WP e-Commerce 2.9.7
    Twitter for WordPress 1.9.7
    Cimy Swift SMTP 2.1.3
    WordPress HTTPS 3.0.4

    Permalinks structure: /%category%/

    Issue: With WP e-Commerce, Gold Cart, and WordPress HTTPS plugins active I am unable to access certain pages in the admin panel, specifically Products, Dashboard, Media, Categories (under Products).

    If I disable Gold Cart and WP e-Commerce I am still unable to access Dashboard.

    Everything was working before updating to WordPress 3.3.2 but rolling back is not an option at this time.

  12. jessemeyers
    Member
    Posted 2 years ago #

    Forgot to add that if I disable WordPress HTTPS then everything works fine except the Checkout page doesn't show the Lock icon for customers which is kinda important. Thanks for all your help in making this plugin to begin with!!

  13. Diana Ross
    Member
    Posted 2 years ago #

    same issue here. For some reason, the loop is also preventing me from logging into my dashboard. I've emailed my tech-support guy to see if my website can be accessed at the server site.

  14. Diana Ross
    Member
    Posted 2 years ago #

    I managed to get into the dashboard after manually typing in the "https" version of the log-in address, deactivated/deleted the 3.0.4 and installed 3.0.3 from that link posted above (THANKYOU THANKYOU!) and all is working as intended.

  15. jessemeyers
    Member
    Posted 2 years ago #

    Downgraded to 3.0.3 and issue persists.

    Downgraded to 2.0.4 and issue is resolved. I'll wait to upgrade for now I guess.

  16. adamjsmith
    Member
    Posted 2 years ago #

    Also had to downgrade due to the redirect loop, anyone here find a fix? (other than the downgrade!)

  17. Diana Ross
    Member
    Posted 2 years ago #

    I am still having the redirect issue after rolling back to 3.0.3
    "This webpage has a redirect loop
    The webpage at https://www.wbjc.com/pledge-now/confirm-order/ has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.
    Here are some suggestions:
    Reload this webpage later.
    Learn more about this problem.
    Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects."

    Could someone please provide the link to download 2.0.4? Thank you!

  18. Diana Ross
    Member
    Posted 2 years ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic