WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
Redirect Loop (4 posts)

  1. berchman
    Member
    Posted 2 years ago #

    Hi Mike,
    You helped me a few years back with this same website. A few recent updates to software and things are not working entirely right.

    WordPress 3.3.1
    using Version 2.0.4 of WordPress HTTPS.
    Along with Shopp 1.2.1

    When WordPress HTTPS is deactivated, the page I want to load, does indeed load, but with with the following "caution" being issued by the browser:

    Your connection to http://www.thesymphony.org is encrypted with 256-bit encryption. However, this page includes other resources which are not secure. These resources can be viewed by others while in transit, and can be modified by an attacker to change the behavior of the page.

    The connection uses TLS 1.0.

    The connection is encrypted using AES_256_CBC, with SHA1 for message authentication and DHE_RSA as the key exchange mechanism.

    The connection is compressed with DEFLATE.

    When the plugin is activated the checkout page results in a redirect loop.

    How can I resolve?

    Let me know if you have any questions.
    Thanks,
    Bert

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Bert,

    I just pushed out 3.0. Try updating and see if anything changes. Let me know.

    Thanks,
    Mike

  3. berchman
    Member
    Posted 2 years ago #

    Hi Mike,
    No luck. I had larger issues with Shopp and have moved to Cart66.
    However, the update to 3.0 still not resolved things.

    Browser says pages are encrypted except for a few elements (off-site scripts, etc.)

    Let me know what you think.
    Thanks,
    Bert

  4. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Bert,

    Are they things you can remove? I think the plugin is strict on certs, so if the cert isn't valid, it won't load it over HTTPS. Maybe that's what it is? Can you give me some specific links. Maybe turn on the debug mode on the plugin?

    Thanks,
    Mike

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic