WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
Preview Broken (13 posts)

  1. jspurling
    Member
    Posted 2 years ago #

    The preview button on posts and pages breaks whenever I activate the WordPress HTTPS plugin. It works again on deactivating. The error received is:

    "You do not have permission to preview drafts."

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey jspurling,

    That makes no sense at all. If you'd like I can take a look at it. You can create an admin user for mike[at]mvied[dot]com and I'll take a look at it.

    Thanks,
    Mike

  3. jspurling
    Member
    Posted 2 years ago #

    Hi Mike,

    I'd rather not create other admin accounts to be honest as it is a client site. The url is: http://pancreaticcanceraction.org/ I've gone as far as disabling all plugins only to enable your plugin and have confirmed the issue is definitely with the plugin.

    Is there any particular information about the server or WordPress configuration you need to know?

  4. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey jspurling,

    I'm thinking that you're logged into HTTP in your admin panel, and your preview link is going to HTTPS where you are not logged in. See if that's the problem.

    Thanks,
    Mike

  5. jspurling
    Member
    Posted 2 years ago #

    Hi Mike,

    Almost right... I'm using HTTPS throughout admin but only on a few pages on the frontend. Preview works fine for those pages which also use HTTPS on frontend. Does this help with working out a solution?

    Thanks for your quick responses!

  6. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey jspurling,

    Yes, in 1.9.2 when you log into HTTPS, you are not logged into HTTP at the same time. This is fixed in 2.0. If you happened to be logged in through HTTP, the preview would most likely work.

    If you'd like, you can try the development version here http://downloads.wordpress.org/plugin/wordpress-https.2.0.zip.

    Thanks,
    Mike

  7. jspurling
    Member
    Posted 2 years ago #

    On first attempt this does not appear to have fixed the problem. Although the 'Force SSL Administration' box is unchecked in settings and when I try and check it I receive the following message:

    SSL Admin - FORCE_SSL_ADMIN and FORCE_SSL_LOGIN can not be set to true in your wp-config.php

    When I look into wp-config I can see:
    define('FORCE_SSL_ADMIN', true);
    define('FORCE_SSL_LOGIN', true);

    I think I perhaps set these manually a while back. Any more ideas? Thanks again for your help.

  8. jspurling
    Member
    Posted 2 years ago #

    I solved the SSL admin error by removing the rules from wp-config manually and then enabling through the plugin settings. However, the original problem still exists where previewing non-secure pages through a secure admin brings up ""You do not have permission to preview drafts.".

  9. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey jspurling,

    Yes, like I said before, in 1.9.2 when you log into HTTPS, you are not logged into HTTP at the same time. This is fixed in 2.0, which will be released shortly.

    Thanks,
    Mike

  10. jspurling
    Member
    Posted 2 years ago #

    Hi Mike, Sorry I didn't mention that since you gave me the link I have been using 2.0 dev but with no luck I'm afraid. Is there any more information I can provide you with?

  11. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey jspurling,

    When you log in via HTTPS, do you get the admin bar on HTTP pages on the public portion of your site?

    Thanks,
    Mike

  12. jspurling
    Member
    Posted 2 years ago #

    Hi Mike, I do not.

  13. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey jspurling,

    In that case, I can't really know what's wrong without looking at it myself. That functionality works in my development environment as well as the few sites I've tested the plugin on.

    Thanks,
    Mike

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic