WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] Plugin broke my Admin Area (37 posts)

  1. Sulaiman
    Member
    Posted 2 years ago #

    Hi There,

    I have recently updated the WordPress SSL plugin from 2.0.4 to 3.0 and then i returned to my dashboard lately it took me out of the dashboard also i have tried to insert my correct login details it didn't let me in!

    It seems like this plugin lastest version has bugs with cookies or something like that... Please fix this issue as i have several authors who are contributed on our website they would complaint the login is not working :-( Please help!!!

    http://wordpress.org/extend/plugins/wordpress-https/

  2. imatt.au
    Member
    Posted 2 years ago #

    Hi,
    Same problem as above. After upgrade to 3.0.0, the webserver stopped serving pages, and the admin area was barely accessible. Downgrade to 2.0.4 was necessary.

  3. Sulaiman
    Member
    Posted 2 years ago #

    Yep, Downgrading to 2.0.4 helps but upgrade to 3.0 will throw you out of Dashboard :-( and never let you in...

  4. Andyt8
    Member
    Posted 2 years ago #

    Same problem: Dashboard not accessable

    ...and some other: after upgrade to 3.0 the URL for the front page use https and not http. There is no ssl force for front page - it seems to me it use only https for the front page, if I open a side with forced ssl.
    Also some Webbrowser (like IE9) shows now the "mixed content" error.

    Therefore downgrade to 2.0.4 an all errors fixed ;-)

    Why use the WordPress SSL plugin Ver. 3.0 an extra setting position? I prefer the old position.

  5. kpawson
    Member
    Posted 2 years ago #

    I upgraded the plugin from the notification pop-up and it broke my site and admin area's as described above.

    However, I've now got V3.0 running fine, and the fix was pretty easy for me. All I did was first deactivate the plugin and then Delete the plugin including the https plugin folder. Confirmed my site and admin area was working fine and then went to plugins and installed V3 of the plugin, and after activating it works fine.

    In my case and perhaps many others here the issue seemed to be with the upgrade from 2.0.4 up to 3.0 from the actual WP Admin section. Perhaps upgrading by downloading the zip manually and ftp the contents may have had a different result?

    Sorry Mike, I don't have any logs to show what might have caused the issue, hopefully this will give something to work with and hope others can get v3 working with this method.

  6. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey all,

    It's possible the upgrade process isn't working correctly. It would be great if those having issues could set up a test site and see if they can reproduce the issues. I never had any problems, or I wouldn't have pushed up 3.0. The more feedback I get, the faster I'll get it fixed.

    Thanks,
    Mike

  7. Sulaiman
    Member
    Posted 2 years ago #

    Hi Mike,

    I could do test site unfortunately my SSL is only for single domain i cannot try to use in subdomain because it redirect me to the main site... :-(

  8. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    You could install wordpress in a subfolder with a different database. :)

  9. Sulaiman
    Member
    Posted 2 years ago #

    Alright let me try and tell you what's going on...

  10. Sulaiman
    Member
    Posted 2 years ago #

    I have tried the test version seems fine... only the issue when you install the plugin it gets you out of dashboard and sometimes it will not letting user in... but it will only affect users who are upgrading from 2.0.4 to 3.0 they've need to uninstall the remove the plugin from the wordpress directory then manually upload it to the http://FTP...

    Other thing is... The “HTTPS” is labelled on sidebar please revert it back to the under Settings like the one on 2.0.4 because i have different types of customs post so it takes more spaces if one item added and it's very difficult to navigator for an admin... So please revert it back thanks...

  11. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Sulaiman,

    Thanks for the feedback, I'll look into the issue with upgrading.

    I'll be sure to make it a setting just for you in the next version. I wanted to put it over there to make it more obvious. :)

    Thanks,
    Mike

  12. Sulaiman
    Member
    Posted 2 years ago #

    Alright, I will look forward on the next update :-)

  13. Daedalon
    Member
    Posted 2 years ago #

    My upgrade on the test environment worked with one strange problem. The steps done:

    1. Test environment is on a subdomain. On plugin page the SSL host was set to be the subdomain, Force SSL Administration was checked and everything else was unchecked or empty.
    2. On page /wp-admin/plugins.php?plugin_status=upgrade, clicked the Upgrade automatically text link to upgrade from 2.0.4 to 3.0
    3. On admin pages: no problems.
    4. On the public website, the top of every page is now a jumble of URLs:

    http://[TESTSITE]/2012/04/http://[TESTSITE]/2012/03/http://[TESTSITE]/2012/02/http://[TESTSITE]/2012/01/http://[TESTSITE]/2011/12/

    ...and so forth for each month the site has been online. Instead of [TESTSITE] is the site domain. The public website is viewed over http, which makes this even more strange, since this occurred only after this plugin update. The problem in HTML:

    <link rel="pingback" href="http://[TESTSITE]/xmlrpc.php" />
    http://[TESTSITE]/2012/04/http://[TESTSITE]/2012/03/http://[TESTSITE]/2012/02/http://[TESTSITE]/2012/01/http://[TESTSITE]/2011/12/http://[TESTSITE]/2011/11/
    <!-- This site is optimized with the Yoast WordPress SEO plugin v1.1.5 - http://yoast.com/wordpress/seo/ -->
  14. Daedalon
    Member
    Posted 2 years ago #

    Deactivating WordPress HTTPS removed the problem, reactivating returned it. Deleting and reinstalling the plugin through the admin screen didn't solve the problem.

  15. tetoonline
    Member
    Posted 2 years ago #

    Is simples

    I have this problem

    Sorry I speak very low english.

    backup your wp-config.php
    edit wp-config.php and put in line 2 this text:
    define('WPHTTPS_RESET', true);
    Now open the url just the url like: wordpress.com
    re-edit the file wp-config and remove the line!
    Now works fine.

    This line reset the plugin.

    Sorry my english.

    This solution works for me!

  16. wakingmedia
    Member
    Posted 2 years ago #

    The update broke my admin too. Yesterday I just deleted the files and reinstalled from the plugins admin panel and that fixed it. But today, I was prompted for another update, which again broke the admin. I uninstalled, then re-installed through the plugins admin and now it seems to be fine.

  17. Daedalon
    Member
    Posted 2 years ago #

    I assume Tetoonline's fix is for other 3.0 issue. Didn't fix mine.

    I also wanted to ask why does 3.0 clutter the admin sidebar with its own major HTTPS section? These settings need to be revised so seldomly that the old placement as a subsection of Settings is more appropriate.

    Apart from these two issues, thanks for the work on the plugin. Enjoyed it up to 2.0.4 so much that I wanted to contribute with testing and feedback of the freshly-released 3.0 instead of waiting for bugfix releases.

  18. Daedalon
    Member
    Posted 2 years ago #

    3.0 also broke the functionality of plugin Search Autocomplete in my test environment. With 3.0 enabled, the search autocomplete works until you click the suggested post. You're then redirected to an URL that is the current URL + [object Object], instead of the suggested post's URL.

  19. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Daedalon,

    Saying that his fix is "for another issue" doesn't really make sense. I didn't push out a plugin that's just flat out broken. It's broken due to something in your configuration that I had no way to test. The only way I can fix it is if you provide more information on what your settings look like, what kind of server configuration you have, etc.

    I can't think of a single line of code in the plugin that would produce this kind of problem. Have you tried deactivating other plugins? It may be worth setting up a new WordPress install in a subfolder and see if you can reproduce the issue. Any information would help greatly.

    Settings are on the sidebar because I want it to be easy to find and if I ever add more sections to the plugin, I will actually have a place for them. With popout menus, it's not as big of a deal as it used to be. I will be making it a configurable setting, though.

    I'll have to test compatibility with Search Autocomplete.

    Thanks,
    Mike

  20. 26thandmane
    Member
    Posted 2 years ago #

    im having the same problem as everyone else is. i can not access my site nor my wp admin area. i didnt have the previous version of this plug in so how do i remove the plugin if i cant even log in to my wp admin area???????????

  21. Sulaiman
    Member
    Posted 2 years ago #

    Placing HTTPS label on Sidebar that increase amount of item on the dashboard sidebar... using HTTPS on Settings as subsection is much better that reduces the items on Sidebar that's the differences :) but users would love to have the option under settings that would make them easier...

  22. aglakimsmith
    Member
    Posted 2 years ago #

    I had the same problem with a plug-in that I installed. I had to go into the actual applications upload page through my host provider and delete the plug-in on the backside. Then I was able to sign into my wordpress account and everything came up right.

  23. Daedalon
    Member
    Posted 2 years ago #

    Mvied, different problems have been discussed in this thread. My post was to clarify whether the reported fix works for the one I reported, or is probably for a different one. Perhaps something in the way I wrote it made it seem like something else, but my intention was indeed to clarify, whether a problem was solved or not.

    The problem with the URLs appearing at the top of the page, right before the adminbar, occurs even after disabling all other plugins. I could delete widgets only after disabling the plugin.

    After erasing all the widget settings and trying out also the themes TwentyEleven and TwentyTen, I found that now, despite all widgets disabled and regardless of WordPress HTTPS being activated or not, there are three widgets visible: Search, Archives and Meta. If WordPress HTTPS is active, Archives displays only the archives links - the URL jumble mentioned before that with another theme went into the top of the page. If WordPress HTTPS is deactivated, Archives links appear and function correctly. With TwentyTen and TwentyEleven, these are shown in the secondary widget area and only if there are no other widgets active. With TwentyTen, after disabling other widgets, enabling them had no effect - only those three were shown.

    Tried also on the live site on which the test site is based. Updating WordPress HTTPS caused the same URL jumble, which was solved by reverting back to 2.0.4. The theme in both cases is Photog with, you guessed it, lots of self-made modifications, none of which should cause the issue.

    I then set up a different test site based on another live blog on the same server. There, roughly the same happened. Using ChocoTheme, no effects visible after updating to 3.0. With TwentyEleven and TwentyTen, the same. Troubles started when tried to alter or delete widgets. That didn't produce any effect while WordPress HTTPS was on. After deactivating it, deleting all widgets and then reactivating, TwentyTen and TwentyEleven now behave in the same way as with the other site. Activating ChocoTheme enabled two of the previously disabled widgets. After deactivating WordPress HTTPS and deleting those plugins the sidebar now shows these, presumably theme default, widgets:

    Search
    Pages
    Archives
    Categories
    Friends (which is Blogroll/Links renamed)
    Meta

    With WordPress HTTPS deactivated all those work as expected. With WordPress HTTPS activated, Archives creates the same URL jumble as in the other blog.

  24. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Daedalon,

    Well, if I can reproduce the problem, I can work on a fix. I'm certainly not experiencing anything like that on any of my test sites, so if you can let me on your server, I can certainly fix it. That's generally the only way I can fix these kinds of bugs that only occur for certain people. Sometimes things can't be fixed, it just depends. This plugin has gotten a lot more complicated than I ever thought it would, haha.

    I need FTP or SSH access to a site that is experiencing the issue that I can mess with to try and work on a fix. You can email me at mike@mvied.com.

    Thanks,
    Mike

  25. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    It seems like the upgrade process needs some work. I wish there were a forum were all the people who it worked for could go to tell me how great my plugin is, lol. No worries, this new version didn't take me months or anything. Haha.

    I'll be fixing bugs as fast as I can reproduce them. I'll have a bug fix version out soon.

    Thanks,
    Mike

  26. Sulaiman
    Member
    Posted 2 years ago #

    Plugin is great on 2.0.4 but not on 3.0 :-( because there is so much of modified files that isn't correctly fixed and affected the MOST of this plugin users... Also please fix the placement under “Settings” because users only configures the settings for HTTPS one time not several... I hope you get it as well i could see Daedalon has different type of issues on the latest version...

  27. Daedalon
    Member
    Posted 2 years ago #

    At the moment I cannot give FTP/SSH access to any of the servers. I'd be happy to help any other way, for example by giving you in private more detailed information about the servers and installs you deem might be useful. I'll email you about this.

    I have one more blog where I can try the upgrade to 3.0. Some time in the near future there I'll also be dealing with a new install on the same server where I could try installing WordPress HTTPS 3.0 as the first thing.

    Thanks for the relentless work for the WordPress community!

  28. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Daedalon,

    Without access to the server, I simply can't fix it. There's no information you can give me that I can debug the code with. I've seen one other user with this problem, so maybe they will let me fix it on their srver. Until then, there's nothing I can do.

    Thanks,
    Mike

  29. Daedalon
    Member
    Posted 2 years ago #

    Just for the record, the same happened with the third site on the same server. The difference is that this time I first enabled the Archives widget to be used alongside the regular ones. Other than that, everything was the same: with WordPress HTTPS 3.0 active, Archives widget printed out URL jumble instead of the properly formatted hyperlinks to archives.

    Hopefully the other affected user can help you with the fix. If you want to use some server information for comparison to find possible similarities, please let me know.

  30. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks. I'll be sure to update the topic if I make any progress.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic