WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] Not working for Shared SSL on Bluehost (32 posts)

  1. dgebel
    Member
    Posted 2 years ago #

    I'm having a lot of trouble getting this to work. I have installed and removed it a couple times, including going into the database and cleaning out the entries, creating new sites, etc.

    - I set up a clean site with SimpleScripts
    - My WP testing site is: http://example.com/testsite
    - I deactivated and deleted all other plugins, then installed WordPress-https
    - I set the secure host as per BH documentation to: secure.bluehost.com/~example <--- actually it's ~username
    - left the port field blank - that uses the default 443 right?
    - saved
    (the first time I installed it, the page never finished saving, but it has done so ever since.)

    - logged out
    - went to secure.bluehost.com/~example/testsite/wp-admin
    --> it went to http://example.com/testsite/wp-login.php?redirect_to=http%3A%2F%2Fexample.com%2Ftestsite%2Fwp-admin%2F&reauth=1
    -- I logged back in fine.

    - when I check the Force SSL Administration page and save, I get sent to:
    http://example.com/testsite/wp-admin/options-general.php?page=wordpress-https
    and am told "Internet Explorer cannot display the webpage"

    - I get the same message when I go to http://example.com/testsite/wp-admin

    - when I go to https://example.com/testsite/wp-admin or https://secure.bluehost.com/~examples/testsite/wp-admin I just get 404s.

    - the weirdest thing is, I think I was getting that redirect loop people have mentioned instead of being able to log in initially. When I first installed it, I was getting the SSL site with a lovely bright red address bar in IE due to the shared address (which is fine for my use) and it just redisplayed the login screen.

    I deleted the plugin & database contents and tried again, and got the above results. Then I completely deleted the site and all folders and database, and reinstalled WP from scratch and still got the above results. I suspected something is still being retained by bluehost, somewhere, but I created another new site in a different folder and still get the same results. I'm baffled now.

    Help???

    ** The plugin REALLY should clean out the database entries when deleting itself! Reinstalling, it grabbed all the entries from the first time and locked me out again. Blech.

    http://wordpress.org/extend/plugins/wordpress-https/

  2. bh_WP_fan
    Member
    Posted 2 years ago #

    If you are using secure.bluehost.com as your URL, then you need to set that up in your Settings > General area.

    If you want to use the Shared SSL, see the following: http://wordpress.org/support/topic/using-shared-ssl-w-a-subdirectory-install?replies=10

    If you are using https://yourdomain.com as your URL, then you need to make sure that you have your own SSL certificate installed on your domain.

  3. dgebel
    Member
    Posted 2 years ago #

    Yes, I'm using the Shared SSL.

    Sorry, the point in my list above where I mention the secured host is starting to refer to entering items on the WordPress-SSL settings panel.

    I.e., I put "secure.bluehost.com/~example" into the "SSL Host" field on the WordPress-SSL settings panel.

    bh_WP_fan, do you mean I have to change the Site URL to "secure.bluehost.com/~example/testsite" ? I believe I saw something about that setting somewhere, but... that would use SSL for the whole site, right? I just want to secure a few pages, particularly the login although all of admin is ok.

    It looks like this plugin is supposed to allow one to secure all pages or just pages you force to use SSL (the exclusive checkbox), and separately secure (or not) the admin area. I don't want visitors to use SSL. (I wish BH let us get certs for addon domains for a store, though).

    Incidentally, as per another thread, I tried setting permalinks to default. It didn't make any difference.

    WP really should be renamed that option, because "Default" was not the default!

    I looked at the other post, but he just says it started to work with v1.92 - which I can't seem to find anywhere.
    When I got to https://secure.bluehost.com/~example/testsite the pages are displayed that same as if it was http - nothing has been secured anyway. If I try to log in, I get a red address bar and nothing happens, ie login doesn't work - there's no error message or anything, the form just clears.

  4. dgebel
    Member
    Posted 2 years ago #

    By the way, about my last comment. That's if all the Force SSL options are off. If I switch any of them on, I get 404s when I try to go to the page.

  5. dgebel
    Member
    Posted 2 years ago #

    I finally found version 1.92 - it seems to work fine. Better than I expected actually, since it does a redirect and thus no red address bar to scare someone.

    I am willing to be a test site for version 2.0 updates.

  6. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    I just pushed out version 2.0.1. Let me know if it fixes your issue.

    Thanks,
    Mike

  7. Bozz
    Member
    Posted 2 years ago #

    Thanks for the great plugin!

    I also cannot get it to work on a bluehost wordpress install.

    I receive a nested 404 error message loop when I attempt to view the page in which I have selected 'Force SSL'.

    I have tried the following:

    and have not met with success. I am using WP 3.2.1 and WordPress HTTPS 2.0.2. Thanks for any help you can provide!

  8. Bozz
    Member
    Posted 2 years ago #

    Interesting, when my browser stopped the loop, this is the URL it provided in the address bar:

    https://secure.bluehost.com/~example/instrument/~example/instrument/~example/instrument/secure.bluehost.com/~example/instrument/?page_id=95

    (I have changed the actual account name to example for privacy purposes)

    Seems like it may be a redirection issue?

    I am using exactly this in the HTTPS settings page:

    SSL Host: secure.bluehost.com/~myusername/mysitepath

    (port setting is blank) Hope this helps troubleshoot.

  9. Bozz
    Member
    Posted 2 years ago #

    Interesting, when my browser stopped the loop, this is the URL it provided in the address bar:

    https://secure.bluehost.com/~example/instrument/~example/instrument/~example/instrument/secure.bluehost.com/~example/instrument/?page_id=95

    (I have changed the actual account name to example for privacy purposes)

    Seems like it may be a redirection issue?

    I am using exactly this in the HTTPS settings page:

    SSL Host: secure.bluehost.com/~myusername/mysitepath

    (port setting is blank) Hope this helps troubleshoot.

  10. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Bozz,

    Try setting your SSL Host to just secure.bluehost.com/~myusername/. The path to your WordPress installation does not need to be included there. Let me know if that works.

    Thanks,
    Mike

  11. Bozz
    Member
    Posted 2 years ago #

    Mike,

    Thanks for the prompt reply.

    When I switched it as you suggested, here is the new URL it attempts to access (again with the 404 loop effect):

    https://secure.bluehost.com/~example/~example/~example/secure.bluehost.com/~example/?page_id=95

    I tried using both secure.bluehost.com/~example and secure.bluehost.com/~example/ with trailing slash, same effect.

    This was by clicking 'View Page' from the Edit Page screen.

    I went to the site and clicked the navigation item for the test page and was more succesful (maybe there is a bug specific to the view page link within the admin?) however it did not load the proper wordpress site. This is an addon domain so that is why I was thinking it needs to be pointed further in the server setting.

    This is what is says for Permalink on my edit post screen:

    Permalink: http:/~example//~example/secure.bluehost.com/~example/?page_id=95

    (My permalinks are setup as default option)

    I can manually visit

    https://secure.bluehost.com/~example/instrument/?page_id=35

    and it works! but this is not where the links are directed from Force SSL. I appreciate your help!

  12. dgebel
    Member
    Posted 2 years ago #

    I can confirm the results Bozz is getting, same on mine, but I'm not using an add-on domain (yet), just a folder in my main directory.
    Not sure about individual pages yet.

    Works as long as you don't Force SSL in admin. Then you get the odd doubled account name/redirection effect.

  13. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey dgebel,

    Was that with 2.0.2? I know you said that you went back to 1.9.2 in your previous post.

    If you can shoot me an admin login, I can see what's going on with it. My email is mike[at]mvied[dot]com. I'd like to get a new bug fix version out today.

    Thanks,
    Mike

  14. Bozz
    Member
    Posted 2 years ago #

    Mvied, thank you for being so responsive on this issue. Please let me know if I can be useful with testing or troubleshooting. You rock!

  15. dgebel
    Member
    Posted 2 years ago #

    Mike, yes it was 2.02 - I created an id for you and you should have received the welcome email. Let me know if not.

  16. Bozz
    Member
    Posted 2 years ago #

    Hi all -- checking in to see if you've had any success with a fix ? thanks again for the awesome plugin!

  17. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Bozz,

    I just pushed out 2.0.3. Update and see if it works. I believe I found where the bug was.

    Thanks,
    Mike

  18. Bozz
    Member
    Posted 2 years ago #

    Great news! I will check it out and report back, thank you

  19. Bozz
    Member
    Posted 2 years ago #

    Here's what I'm getting with 2.0.3:

    1. Permalinks on Edit Page are looking good now, sweet!

    2. It doesn't like me using a subdirectory in the settings (which is necessary if your wordpress blog is not hosted in the main public html directory of your account), when I do that it goes into some sort of loop.

    I can get the plugin to give me this:

    https://secure.bluehost.com/~example/?page_id=35

    But, I need a URL that looks like this, which if I put it into my browser works well:

    https://secure.bluehost.com/~example/instrument/?page_id=35

    Is there a way to accommodate such a need without producing a double down of the directories? This is the URL I'm getting with the subdirectory in the settings (secure.bluehost.com/~example/instrument/)

    https://secure.bluehost.com/~example/instrument/~example/instrument/?page_id=35

    It's sticking an extra "~example/instrument/" in there. Hopefully it's a quick fix.. what do you think Mike? Thanks!

  20. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Bozz,

    If your WordPress installation is located in a subfolder, you don't need to add it to your SSL Host. The plugin takes care of that automatically. I'm not sure if that will fix anything, but give it a shot and let me know.

    Thanks,
    Mike

  21. Bozz
    Member
    Posted 2 years ago #

    if I set it to just secure.bluehost.com/~example then it is directed to a different site completely.

    How is the plugin passing on the subdirectory info? My site is using its own domain and my General settings are:

    WordPress address (URL) http://www.mydomainname.com
    Site address (URL) http://www.mydomainname.com

    This is an addon domain which then points to a subdirectory on another domain. I don't think WordPress knows that, it just knows to go to the domain name.

  22. dgebel
    Member
    Posted 2 years ago #

    I haven't had time to test the 3.3 version yet but...

    Ya, I would need to specify the individual subdirectory too, because I have multiple add-on domains pointing to the subdirectory sites. And possibly another in my userid root directory.

    Sounds like this indicates the source of the problem, that the plugin is assuming a root directory.

  23. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Bozz,

    Well, in a normal setup, it takes the path info off the Home URL and appends it to the SSL Host. It doesn't assume the public directory, there's just an issue when it's building the secure URL.

    This just a guess since I can't easily test this scenario, but, replace this block at line 504:

    if ( strpos($url_parts['path'], $https_url_path) === false ) {
    	if ( $url_parts['path'] == '/' ) {
    		$url = rtrim('/', $url) . $https_url_path;
    	} else {
    		$url = str_replace($url_parts['path'], $https_url_path . $url_parts['path'], $url);
    	}
    }

    With this:

    if ( $url_parts['path'] == '/' ) {
    	$url = rtrim('/', $url) . $https_url_path;
    } else if ( strpos($url_parts['path'], $https_url_path) === false ) {
    	$url = str_replace($url_parts['path'], $https_url_path . $url_parts['path'], $url);
    }

    Let me know.

    Thanks,
    Mike

  24. Bozz
    Member
    Posted 2 years ago #

    I tried the replacement but unfortunately got the same results with the double directories (https://secure.bluehost.com/~example/instrument/~example/instrument/?page_id=35). Let me know if I can test anything else, thanks for being so responsive.

  25. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Bozz,

    It would be easier if I could just log in and fix it. It's hard to guess what code isn't working right, lol. If you can, set me up a user that can edit plugins. My email is mike[at]mvied[dot]com.

    Thanks,
    Mike

  26. dgebel
    Member
    Posted 2 years ago #

    Mike, did you get the "join" email I sent you as administrator?

  27. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey dgebel,

    I remember seeing it, but I can't find it. Not sure what to search for in my email. If you can send it again or tell me the email it came from, I'll take a look at your site. Sorry. :P

    Thanks,
    Mike

  28. Bozz
    Member
    Posted 2 years ago #

    For those coming to this thread later, Mike fixed a couple bugs in 2.0.4 and it's working great with default permalinks! Thanks Mike!

    I'm curious if anyone has managed to make their HTTPS configuration work with pretty permalinks using Shared SSL?

  29. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Bozz,

    I've seen this issue many times and as far as I know you can't use anything but the default permalinks.

    The only thing I seem to remember someone mentioning was adding this to the .htaccess: ErrorDocument 404 /index.php But I have no idea if that works.

    Thanks,
    Mike

  30. dgebel
    Member
    Posted 2 years ago #

    Mike,
    I'm still not working with 2.04
    I've sent you the details with the subject "login credentials".

    I thought is was working with 2.02 as long as I didn't force admin. I managed to get in at once point, but then the admin gave me only a 404 error.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic