WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
Non-SSL pages redirect to /index.php after upgrade to 3.1.2 (12 posts)

  1. jetlej
    Member
    Posted 2 years ago #

    I have the Force SSL Exclusively option ON. Any page that does not have the 'SSL Page' option checked no redirects to /index.php.

    I tried reverting back to your plugin version 3.0.4 but now those same pages give me a redirect loop.

    SSL pages work fine.

    Any ideas? Looks like you're slammed with questions right now, sorry about that!

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Be careful that you're not experiencing issues due to browser caching. Always open a new tab or close your browser when testing the site out after making a change.

    What permalink structure are you using?

  3. jetlej
    Member
    Posted 2 years ago #

    I've checked in different browsers and cleared the caches.

    I'm using a custom structure: /blogs/%postname%

  4. andrej1c
    Member
    Posted 2 years ago #

    I'm getting the same issue so I had to do SSL on all pages for now.

    I'm using custom structure of /blog/%author%/$postname%/

    WP MultiSite 3.4.1
    Wordpres HTTPS 3.1.2

  5. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    I don't understand why you'd alter your permalinks like that. If you want to use /blog/, then put /blog/ on your Site URL. I doubt I'll have this fixed anytime soon unless someone can convince me that changing your permalink structure in this manner is a good idea.

  6. jetlej
    Member
    Posted 2 years ago #

    Because my homepage is not /blogs. The entire site is built using WordPress, including the homepage.

  7. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Alrighty, well I've tried my best to reproduce it. Is there any way I could get admin access and FTP access to take a look? My email is mike[at]mvied[dot]com.

  8. jetlej
    Member
    Posted 2 years ago #

    @andrej1c might want to give you his. I already went through and made the other pages SSL-compatible so this would no longer be an issue. Thanks though!

  9. andrej1c
    Member
    Posted 2 years ago #

    I just hired a contractor today to help me with this and we spent last 10 hours dealing with redirect issues. In the end we put everything on https.

  10. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    I'm a contractor and I wrote the plugin. You would have been better off hiring me. At least you got it working.

  11. andrej1c
    Member
    Posted 2 years ago #

    @Mvide I didn't realize you were available as a contractor. You would have probably fixed the issue the right way too. I'll keep that mind if anything else comes up. Thank you!

  12. jetlej
    Member
    Posted 1 year ago #

    @Mvied - Have you by chance run into this issue since last month? I didn't realize that taking the whole blog to HTTPS would destroy backlink juice, even with 301 redirects.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.