WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] Mixed content - one error remaining (3 posts)

  1. johndove523
    Member
    Posted 1 year ago #

    Hi,

    I love your plugin and it fixed nearly all my mixed content/encryption errors. However there is one remaining issue that still issues a warning in Chrome (and Opera too I think). Before I get to it, let me give you my https plugin configuration. Please correct me on anything I may have set wrong:

    SETTINGS:
    host:caspca.org
    port: 443
    Force SSL exclusively: checked

    On the PAGE (it is a page, not a post) in question, I have checked the "Secure Post" checkbox.

    The problem page (please view in Chrome):

    https://caspca.org/wordpress/give/donate-now/

    Following your FAQ instructions for mixed results, your plugin solved all but one issue. It's telling me that the error is generated from https://caspca.org/wordpress/wp-content/themes/gravy/style.css?ver=1.0 ; which I believe needed to be hard coded as HTTPS instead of http. I did this. Here's where I'm confused -

    That image is not referenced AT ALL in the theme (gravy) styles.css as indicated. The reference actually lives in /wp-content/plugins/gravityforms/css/forms.css:

    .gform_wrapper ul.gform_fields {
         overflow: visible;
         background:#b7e1f8 url(https://www.caspca.org/wordpress/wp-content/themes/gravy/images/form_logo_bkgrnd.png);
         -moz-border-radius: 5px;
         border-radius: 5px;
    }

    I can't figure out why it's pointing to the gravy (theme) styles.css file. I even copied and pasted into the styles.css and it still doesn't recognize it.

    Any idea what's going on with this?

    Also, the thing that failed to load (url "static.ak...facebook link" - I have no idea what that is.

    Any help would be greatly appreciated to get this fixed once and for all. Thank you.

    John

    http://wordpress.org/extend/plugins/wordpress-https/

  2. johndove523
    Member
    Posted 1 year ago #

    I think I got it fixed. For whatever unknown reason, the background .png file in question:

    background:#b7e1f8 url(https://www.caspca.org/wordpress/wp-content/themes/gravy/images/form_logo_bkgrnd.png);

    ...I set and re-set that URL to "https" a half dozen times still resulting in an unsecure error. Finally, I commented it out, and the error was gone, but so was my form background. Then I removed the comment (so that the path was live again, with the 'https:') and voila. Suddenly I had a completely secure connection. This makes no sense to me, but it worked. Also, as for the "static.ak...facebook link", that was coming from another social media sharing plugin, which I removed.

  3. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Really, it should be changed to /wordpress/wp-content/themes/gravy/images/form_logo_bkgrnd.png so that it loads over HTTP or HTTPS appropriately.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic