WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] making form action insecure (18 posts)

  1. Daniel Watrous
    Member
    Posted 2 years ago #

    I just noticed that this plugin is changing the URL for my form action from https to http.

    Why is that? I need to post to a secure page...

    http://wordpress.org/extend/plugins/wordpress-https/

  2. jadenblack
    Member
    Posted 2 years ago #

    I'm getting the same behavior, I'm using site_url('','https') to create actions for forms and redirects. When WP-HTTPS is activated, it converts everything to http, which breaks most of the forms. Then when I deactivate WP-HTTPS, all the links go back to https and work as intended, but then I get insecure errors.

    Using latest releases of WP 3.4 and WP-HTTPS 3.0.4, on PHP 5.2.17

    Please help!

  3. Daniel Watrous
    Member
    Posted 2 years ago #

    I've found that the issue comes from a normalization function the plugin performs. There are a couple of ways around this.

    1) The easiest way to get around it is to change your Site Address value on your main settings page in WordPress so that it is https. That will circumvent the part of the plugin that is changing them back to http.

    2) The other way is to open the file "/lib/WordPressHTTPS/Module/Parser.php" and comment out the second conditional in the function normalizeElements(). That will prevent the normalization from happening at all.

    I've emailed the plugin author, but no response, so I'm not sure when a fix might make it into the plugin.

  4. tedam
    Member
    Posted 1 year ago #

    sorry that I'm writing in this post
    I have the same problem:
    http://wordpress.org/support/topic/logged-in-cookies-expire-1-year-ago?replies=1
    this post is closed for replies, so I'm writing here.
    dwatrous, did You resolved that problem? If yes - how?
    Thanks

  5. Daniel Watrous
    Member
    Posted 1 year ago #

    I did resolve it using either of the two methods you read in this post.

    I have marked the post as not resolved to hopefully get some attention from the plugin developer.

  6. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    This was a bug in 3.0.4 that was fixed already. If it doesn't work in the current version, I'm releasing my development version soon, so test that. If the problem persists in the development version, I'll look into it.

  7. Daniel Watrous
    Member
    Posted 1 year ago #

    I just verified that it works as expected in 3.1.2.

    Thanks Mike

  8. tedam
    Member
    Posted 1 year ago #

    I use 3.4.1
    which methods?

  9. Daniel Watrous
    Member
    Posted 1 year ago #

    Just read above in this thread.

    You can also download the latest version and I have confirmed that it works for me.

  10. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Daniel, could you test the development version and confirm that it also works as intended? I'd hate to push it out and have this issue reappear. I only mention it because I've specifically worked on that part of the code.

  11. tedam
    Member
    Posted 1 year ago #

    Daniel can You share jmx that you use for login? May be I made something wrong in my jmx...

  12. Daniel Watrous
    Member
    Posted 1 year ago #

    I have just confirmed that this is working as expected in 3.2rc1

  13. Matthew Nelson
    Member
    Posted 1 year ago #

    I am running version 3.3 and I am having the same issues as other people above my actual form post submissions are being set back to http from https....it would be great if the plugin author could correct this...

  14. Daniel Watrous
    Member
    Posted 1 year ago #

    Hi Matthew, I found that this plugin was getting too complicated. I coded up a replacement that is simple and works great. I've been using it on my own sites and will probably release it through the wordpress directory soon.

    If you want to give it a try, you can get it here:
    http://www.danielwatrous.com/https-0.0.1.zip

  15. Matthew Nelson
    Member
    Posted 1 year ago #

    Ok Daniel. I will give it a whirl...thanks.

  16. Matthew Nelson
    Member
    Posted 1 year ago #

    Holy crap it works now! Thanks so much for that Daniel! Hope your plugin gets released soon....because it actually works, what a concept! Nice work sir.

  17. Daniel Watrous
    Member
    Posted 1 year ago #

    That's great news. It's a very simple plugin, so it should be very stable.

    I'll get it released to the plugin directory soon.

  18. greatkingrat
    Member
    Posted 1 year ago #

    Hi, I'm having this same issue using HTTPS 3.3.0 and WordPress 3.4.2.

    When I use the_permalink() on an HTTPS enabled custom post type, it returns the HTTP version of the URL.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags