WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] links to the front page are set to HTTPS regardless of settings (3 posts)

  1. zemog
    Member
    Posted 2 years ago #

    Hi, great plugin!

    I'm testing it on a fresh WP (Twenty eleven & no other active plugins) installation hosted on host gator. Everything seems fine but if I'm on a secure page, the Home link and the the site name header link always have an HTTPS URL.

    On the settings I do have the "Force SSL Exclusively" setting checked and the "Secure Front Page" unchecked.

    I've even tried to set the frontpage to a static, non secured page and the results are the same.

    The expected behavior is that on a secure page the header link and the home link should have a HTTP url instead of the HTTPS url, or maybe I'm misunderstanding something.

    On the readme file you have the following note under the 3.0.2 changelog:

    * Bug Fix - If Force SSL Exclusively is enabled and Secure Front Page is not (or the front page is not secured), links to the front page will be set to HTTP.

    Which is not happening to me, and I'm on Version 3.0.3

    Any thoughts? thank you in advance!

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    This is a long shot, but I had a typo in the code that may be the reason this is a problem. Try uninstalling the plugin and reinstalling. I hotfixed the typo in the current version. If not, let me know and we'll figure it out.

  3. zemog
    Member
    Posted 2 years ago #

    Great! that did the trick, it now works as supposed to.

    Thank you very much!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic