WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
IP Not Matching Host Name SSL Error (6 posts)

  1. gerryl
    Member
    Posted 1 year ago #

    Hi-
    There appears to be a problem with the rewrite of the links for "pagination" in the Admin area. Enable the plugin, check "Force SSL for Admin" and then go to, for example, the Comment section.

    The page presented has links for advancing to the next page of comments. (Or previous or navigating directly to a section of the comments). These are the arrow buttons on the right side of the the page.

    If you hover over these buttons and look at the link in the browser's status bar, the address link is presented with an IP in place of the shared SSL site name like "secure.domain.com".

    Clicking on the link then causes an SSL error because the IP in the link doesn't match the hostname in the SSL certificate. I'm then logged out of the admin area.

    If I disable the plugin and go to the same spot and hover over the link, the site name is displayed rather than an IP address, thus why I think it's something in the plugin.

    If you need more info or this isn't clear, let me know.

    Regards-
    Gerry

    http://wordpress.org/extend/plugins/wordpress-https/

  2. gerryl
    Member
    Posted 1 year ago #

    I've installed the latest version and this problem still exists.

  3. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Did you enter an IP address into the SSL Host setting? That's the only way it would do something like that. Leave the host setting to its default unless you use a separate subdomain, Shared SSL or something where your HTTPS URL is not the same as your WordPress URL.

  4. gerryl
    Member
    Posted 1 year ago #

    > Did you enter an IP address into the SSL Host setting?

    No. I should have mentioned my settings and usage. It's a shared SSL usage of the plugin. So the SSL Host setting is of the form "secure.webhost.com/~username/blog." I'm using the plugin to secure my Admin sessions, so the "Force SSL Administration" is checked as well. Proxy is set to "No" and no domain mapping or filters setup either. Pretty vanilla setup.

    As I said, everything else works as expected.

    I could provide you with a login if that would help.

    Thanks for getting back to me. It's not a killer, as I can access the pages by modifying the address in the address bar. But it is a usability issue.

  5. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    I'm leaning toward a conflict with another plugin, or some odd server configuration. Nowhere in my code do I look for an IP address. I'll take a look. My email is mike[at]mvied[dot]com.

  6. gerryl
    Member
    Posted 1 year ago #

    I've sent you an email with the info.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.