WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] Insecure in Google Chrome using Google Font and when Woocommerce &qu (6 posts)

  1. pmbrentals
    Member
    Posted 1 year ago #

    Hi Mvied,

    I get the insecure error in Google Chrome on the checkout page of my Woocommerce driven e-commerce site. Everything is in test mode at the moment but I would not want to see this issue on a live site.

    I can only see this insecure prompt on Chrome, ok on Firefox and IE.

    Also, I am using Authorize.net (AMI).

    Here's the code from Dev.tools on Google Chrome.

    [blocked] The page at https://www.mysite.com/checkout/ ran insecure content from http://fonts.googleapis.com/css?family=Francois+One.
    Viewport argument value "device-width;" for key "width" not recognized. Content ignored. /checkout/:95
    Viewport argument value "1;" for key "initial-scale" was truncated to its numeric prefix. /checkout/:95
    [blocked] The page at https://www.mysite.com/checkout/ ran insecure content from http://www.mysite.com/wp-content/plugins/woocommerce/assets/js/chosen.jquery.min.js?ver=1.0.
    Uncaught TypeError: Object [object Object] has no method 'chosen' chosen-frontend.min.js:1

    Can you please help?

    P.S. I am using your Development Version that I download in a link that you have provided in another thread. (version 3.2).

    Thank you!

    http://wordpress.org/extend/plugins/wordpress-https/

  2. pmbrentals
    Member
    Posted 1 year ago #

    Hi,

    I'm going to update my help request with the website link:

    http://www.shopcruzinchrome.com/

    I am still having an issue with insecure contents showing in Google Chrome. Firefox seems ok?

    Any help is much appreciated.

  3. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Did you ever close Chrome and try it in a new tab? Chrome is pretty bad about caching. I don't see any problems in Chrome on https://www.shopcruzinchrome.com/checkout/.

  4. pmbrentals
    Member
    Posted 1 year ago #

    Hi Mvied,

    I had the issue but fixed it. The chosen.jquery.min.js was in the wrong folder. I just copied the file and place in the correct location as stated /assets/js/ and it resolve the "insecure content" prompt in Chrome.

    Thank you for your prompt response and getting back with me.

    I believe this issue is resolved.

  5. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Well, that doesn't make any sense. Lol.

    If the element is hosted locally and you're on a secure page, they should always be changed to HTTPS, no exceptions. The folder it's in doesn't matter.

  6. pmbrentals
    Member
    Posted 1 year ago #

    LOL I know it didn't make sense :) but that's exactly how I troubleshoot this issue and all is well now. ha

    Also I'm using your dev. 3.2 version and it's working very well in the site I'm current working on.

    Once we go live and no issues, I'll make sure to buy you a beer for the plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic