WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] HTTPS update broke my site (37 posts)

  1. whaus
    Member
    Posted 2 years ago #

    my php-version is 5.2.17 and this file does exist:
    /var/www/domains//var/www/domains/XXXXXXXX/blog/wp-content/plugins/wordpress-https/lib/WordPressHTTPS/blog/wp-content/plugins/wordpress-https/lib/WordPressHTTPS/Url.php

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey whaus,

    I really have no idea why it's not working. Include paths are pretty basic. Do you mind if I take a look at it?

    Thanks,
    Mike

  3. whaus
    Member
    Posted 2 years ago #

    I got it. I had exactly this issue: http://blog.calevans.com/2008/02/14/set_include_path-failing/

    in the apache virtualhost config file I used this:
    php_admin_value include_path ".:/usr/share/php5:/usr/share/php5/PEAR:/usr/share/php5/Zend"

    the problem ist the 'php_admin_value' therein. after changing it to
    php_value include_path ".:/usr/share/php5:/usr/share/php5/PEAR:/usr/share/php5/Zend"

    all works fine.

  4. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    So was it missing .: for the current directory?

  5. whaus
    Member
    Posted 2 years ago #

    no, ".:" was there. your code was ok, the path variables were ok, but the php_admin_value setting prevented the setting of the include-path in the php-script. set_include_path always returned false and no new path could be set at all.

    after changing it to php_value (without the "admin_") it worked.

  6. Sam_a
    Member
    Posted 2 years ago #

    I'm seeing similar errors right after activating the plugin.

    Mvied, have you tried using plugin_basename( __FILE__ ) instead of setting include_path?

    WARNING: wp-content/plugins/wordpress-https/wordpress-https.php:37 - include(Jetpack.php) [function.include]: failed to open stream: No such file or directory
    WARNING: wp-content/plugins/wordpress-https/wordpress-https.php:37 - include() [function.include]: Failed opening 'Jetpack.php' for inclusion (include_path='.:/usr/local/php-5.3.13/share/pear:/home/example.com/html/wp-content/plugins/wordpress-https:/home/example.com/html/wp-content/plugins/wordpress-https/lib')
    […]
  7. Sam_a
    Member
    Posted 2 years ago #

    I tried downgrading to plugin 2.0.4 but got (in WordPress 3.3.2)

    Catchable fatal error: Object of class __PHP_Incomplete_Class could not be converted to string in […]/wordpress-https/wordpress-https.php on line 187

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic