WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] HTTPS update broke my site (37 posts)

  1. rabbitshavefangs
    Member
    Posted 2 years ago #

    I updated this plugin and my entire site went down. Been trying to fix everything for HOURS! I HIGHLY SUGGEST NOT UPDATING THIS PLUGIN!

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    If the plugin isn't working as intended, then how about posting some information that would actually help me fix the bug? This topic is not helpful.

  3. rabbitshavefangs
    Member
    Posted 2 years ago #

    Wow, thanks for the fast response.

    The page does not load. Source code shows NOTHING. Everything is blank.

    Sorry for the last post. I am just very frustrated as my paying subscribers are contacting me saying they cannot log in now.

  4. rabbitshavefangs
    Member
    Posted 2 years ago #

    Everything was working PERFECTLY prior to the update. I'm not sure what other info I can give. Questions for me?

  5. rabbitshavefangs
    Member
    Posted 2 years ago #

    Now my admin has locked me out. I can't access my site at all, neither can my subscribers. Very sad. :(

  6. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Well, I did just push the update out about an hour ago, so I'm trying to keep an eye on the forum (Although it's late, I'm heading to bed).

    I understand your frustration. Trust me, I've spend more time writing and testing this plugin than I care to think about. I would never recommend updating a point release on a production site. I try to work all the bugs out of this thing, but it's pretty much impossible.

    Do you have any way to view your Apache error logs? It sounds like there's a PHP error or something. I'll be back in here tomorrow after some much-needed sleep.

    Thanks,
    Mike

  7. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Oh, add define('WPHTTPS_RESET', true); to your wp-config.php. That should wipe any settings. If that doesn't do it, you'll have to delete the wordpress-https folder. Let me know what it takes. I've certainly never had the plugin act that way in testing.

    Thanks,
    Mike

  8. rabbitshavefangs
    Member
    Posted 2 years ago #

    I had no idea this was an untested update. No WAY would I have done this... I want to go to bed too. I work 3 jobs and have a new baby. I sleep 4 hours a night... tonight I'll sleep 1 hour. I'll disable this plugin and try to recover. thanks.

  9. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    By no means is it untested. I spent about 20 hours on it this weekend, mostly testing. It's a very complex beast and I'm only one guy, haha. Sorry for the trouble.

    Oh, it's also worth noting that it will work for 90% of people out of the box. It's generally the odd server setups that cause issues. I don't have test environments for every permutation of server configuration, so it's pretty much impossible to catch all the bugs, especially in a re-write.

  10. rabbitshavefangs
    Member
    Posted 2 years ago #

    OK, thanks. I'll try that now. I appreciate you working on this plug-in. Please accept my apology for being irritated. It's late and I was about to go to bed when I hit UPDATE so I'm just a little perturbed now (site still down and 1.2 hours later... still working with tech support on site...)

  11. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Please try to gather as much information as possible. If anything, I don't mind logging into the site (or a fresh WP install on the same server) and working on a fix there. Often, that's the only way I can come up with a fix since, like I said, there are some many different server configurations that can cause all sorts of different bugs.

  12. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    I've had a few other concerning bug reports, so I'm going to revert the stable version back to 2.0.4. Hopefully those who have experienced issues will help me work on bug fixes. :)

  13. rabbitshavefangs
    Member
    Posted 2 years ago #

    Yeah, I just deleted the new version. Downloaded 2.0.4 and installed it. Everything is back to normal thank god. I'm going to sleep now...

  14. rabbitshavefangs
    Member
    Posted 2 years ago #

    Thanks for a great plugin. 2.0.4 works great. I would just stick with that. Why fix what isn't broken? :P

  15. wpcdn
    Member
    Posted 2 years ago #

    >> Why fix what isn't broken?

    There were issues with the previous version for some people. For example, on our servers there is an endless redirect loop that makes the previous version unusable. So I applaud Mike's efforts.

    Mark

  16. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Mark,

    Thanks for the backup! Haha. Yes, often times bugs are caused for users with configurations I could not test, and previous bugs are fixed for others. I'm hoping to finally get the plugin to that 100% satisfaction mark, but for that I need the feedback of my lovely user base to work out any bugs. :)

    I had to rollback to 2.0.4, but will hopefully be working out a couple of bugs in 3.0 and pushing it out tonight. I realized that rabbitshavefangs' problem is most likely an incompatibility with PHP 5.2.4.

    Thanks,
    Mike

  17. whaus
    Member
    Posted 2 years ago #

    I'm on php 5.2.17 and after the upgrade, which resultet in blank pages due to php fatal errors, had these messages in the error log:

    PHP Warning: require_once(WordPressHTTPS.php): failed to open stream: No such file or directory in /var/www/domains/XXXXXXX/blog/wp-content/plugins/wordpress-https/wordpress-https.php on line 22, referer: http://XXXXXXX/blog/wp-admin/update-core.php?action=do-plugin-upgrade

    PHP Fatal error: require_once(): Failed opening required 'WordPressHTTPS.php' (include_path='.:/usr/share/php5:/usr/share/php5/PEAR:/usr/share/php5/Zend') in /var/www/domains/XXXXXXX/blog/wp-content/plugins/wordpress-https/wordpress-https.php on line 22, referer: http://XXXXXXX/blog/wp-admin/update-core.php?action=do-plugin-upgrade

    so it seems to have to do with the correct include paths not being set.

  18. BeautyPirate
    Member
    Posted 2 years ago #

    I´m happy with how it works right now. (2.0.4) Not going to update any further. To everyone having trouble:

    It´s perhaps better to delete the old plugin completely and then make
    a new installation with ver 3.0 This CAN help however it´s untested.

  19. LGraen
    Member
    Posted 2 years ago #

    Hi,
    I was experiencing a similar problem on our page http://www.unfairtobacco.org. After updating the plugin, the login page and all other HTTPS pages were not available anymore. I did not get any error messages, only the pages didn't load.
    Deactivating the plugin via FTP and downgrading to 2.0.4 fixed the problem.
    It's a pity because I thought the update may fix another problem that I got with the page: HTTPS protected pages are not available in English (our page is in German and English). The HTTPS plugin seems to have a conflict with qtranslate or the other way around.
    Laura

  20. Robert
    Member
    Posted 2 years ago #

    First, great plugin - thanks for making this. Unfortunately, this update took down our entire network (WPMU) too, admin and frontend. Here's part of the error log - it generated so many errors that it broke our php error reporting script so our server team is working on pulling them out manually (this is what they have sent me so far):

    Occurred 38 times
    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/WordPressHTTPS/Module/Parser.php on line 138

    Occurred 8 times
    Warning: require_once(Zend/Exception.php) [function.require-once]: failed to open stream: No such file or directory in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/Zend/Loader.php on line 98

    Occurred 8 times
    Fatal error: require_once() [function.require]: Failed opening required 'Zend/Exception.php' (include_path='.:/usr/local/lib/php:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib') in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/Zend/Loader.php on line 98

    Occurred 7 times
    Warning: include_once() [function.include]: Failed opening '/www/htdocs/web/..removed../wp-content/plugins/wordpress-https/wordpress-https.php' for inclusion (include_path='.:/usr/local/lib/php') in /www/htdocs/web/..removed../wp-settings.php on line 167

    Occurred 7 times
    Warning: include_once(/www/htdocs/web/..removed../wp-content/plugins/wordpress-https/wordpress-https.php) [function.include-once]: failed to open stream: No such file or directory in /www/htdocs/web/..removed../wp-settings.php on line 167

    Occurred 6 times
    Warning: include_once() [function.include-once]: Unable to access /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/wordpress-https.php in /www/htdocs/web/..removed../wp-settings.php on line 167

    Occurred 3 times
    Warning: include_once(WordPressHTTPS/Module/Hooks.php) [function.include-once]: failed to open stream: No such file or directory in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/Zend/Loader.php on line 146

    Occurred 3 times
    Warning: include_once() [function.include]: Failed opening 'WordPressHTTPS/Module/Hooks.php' for inclusion (include_path='.:/usr/local/lib/php:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib') in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/Zend/Loader.php on line 146

    Occurred 2 times
    Warning: require_once(Zend/Loader/Autoloader.php) [function.require-once]: failed to open stream: No such file or directory in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/wordpress-https.php on line 18

    Occurred 2 times
    Warning: opendir(/www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/WordPressHTTPS/Module/Admin) [function.opendir]: failed to open dir: No such file or directory in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/WordPressHTTPS/Plugin.php on line 127

    Occurred 2 times
    Warning: opendir() [function.opendir]: Unable to access /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/WordPressHTTPS/Module/Admin in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/WordPressHTTPS/Plugin.php on line 127

    Occurred 2 times
    Fatal error: require_once() [function.require]: Failed opening required 'Zend/Loader/Autoloader.php' (include_path='.:/usr/local/lib/php:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib') in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/wordpress-https.php on line 18

    Occurred 1 times
    Warning: require_once(WordPressHTTPS.php) [function.require-once]: failed to open stream: No such file or directory in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/wordpress-https.php on line 22

    Occurred 1 times
    Warning: include_once(WordPressHTTPS/Url.php) [function.include-once]: failed to open stream: No such file or directory in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/Zend/Loader.php on line 146

    Occurred 1 times
    Warning: include_once(WordPressHTTPS/Module/Parser.php) [function.include-once]: failed to open stream: No such file or directory in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/Zend/Loader.php on line 146

    Occurred 1 times
    Warning: include_once(WordPressHTTPS/Module/Admin.php) [function.include-once]: failed to open stream: No such file or directory in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/Zend/Loader.php on line 146

    Occurred 1 times
    Warning: include_once(WordPressHTTPS/Logger.php) [function.include-once]: failed to open stream: No such file or directory in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/Zend/Loader.php on line 146

    Occurred 1 times
    Warning: include_once(WordPressHTTPS/Logger/Interface.php) [function.include-once]: failed to open stream: No such file or directory in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/Zend/Loader.php on line 146

    Occurred 1 times
    Warning: include_once() [function.include]: Failed opening 'WordPressHTTPS/Url.php' for inclusion (include_path='.:/usr/local/lib/php:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib') in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/Zend/Loader.php on line 146

    Occurred 1 times
    Warning: include_once() [function.include]: Failed opening 'WordPressHTTPS/Module/Parser.php' for inclusion (include_path='.:/usr/local/lib/php:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib') in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/Zend/Loader.php on line 146

    Occurred 1 times
    Warning: include_once() [function.include]: Failed opening 'WordPressHTTPS/Module/Admin.php' for inclusion (include_path='.:/usr/local/lib/php:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib') in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/Zend/Loader.php on line 146

    Occurred 1 times
    Warning: include_once() [function.include]: Failed opening 'WordPressHTTPS/Logger.php' for inclusion (include_path='.:/usr/local/lib/php:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib') in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/Zend/Loader.php on line 146

    Occurred 1 times
    Warning: include_once() [function.include]: Failed opening 'WordPressHTTPS/Logger/Interface.php' for inclusion (include_path='.:/usr/local/lib/php:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https:/www/htdocs/web/..removed..wp-content/plugins/wordpress-https/lib') in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib/Zend/Loader.php on line 146

    Occurred 1 times
    Fatal error: require_once() [function.require]: Failed opening required 'WordPressHTTPS.php' (include_path='.:/usr/local/lib/php:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https:/www/htdocs/web/..removed../wp-content/plugins/wordpress-https/lib') in /www/htdocs/web/..removed../wp-content/plugins/wordpress-https/wordpress-https.php on line 22

  21. Robert
    Member
    Posted 2 years ago #

    Also, just wanted to add that the errors above were generated yesterday (4/17/2012) and the entire site was down. I just reinstalled the plugin a few mintues ago (assuming there were updates as mentioned above). The new est version allows the admin to continue working, but sends non https pages into an endless reloading loop (not sure what it going on) and it never loads. I unfortunately won't have an error report for this until tomorrow.

  22. Robert
    Member
    Posted 2 years ago #

    In the meantime, how do you download the 2.0.4 version?

  23. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Robert,

    Thanks for the feedback. I think there's something wrong with the plugin loading its resources in older PHP versions. Do you know what version you're running? You can find out at a command line with php -v.

    You can find all other version of the plugin for download here.

    Thanks,
    Mike

  24. Robert
    Member
    Posted 2 years ago #

    Hi Mike,

    Thanks for looking into this. I don't have access to the command line, but I was able to find out that it is 5.0.45

    I'm getting our staging server set back up so that we can test (been needing to do this) 3.0.1

    Thanks again!

  25. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Rob,

    The minimum for WordPress 3.0 is 5.2.4. The plugin also has this minimum requirement. I don't think you're going to be able to get it to work properly.

    Edit: I did want to note that in the next version, I'm removing the autoloader, so it may work for you, but no promises.

    Thanks,
    Mike

  26. Robert
    Member
    Posted 2 years ago #

    Hi Mike!

    My apologies, I gave you the MySQL version!

    I'm trying to find out what our current version of PHP is from our IT server dept and will get back to you.

  27. Robert
    Member
    Posted 2 years ago #

    Okay, PHP is 5.2.17 so we should be good.

  28. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Robert,

    I just pushed out version 3.0.2. Please update and let me know if there are any improvements.

    Thanks,
    Mike

  29. whaus
    Member
    Posted 1 year ago #

    still no luck for me. wordpress tells me it cannot activate the updated (3.0.3) plugin because of this fatal error:

    /plugins/wordpress-https/wordpress-https.php on line 42 Fatal error: require_once(): Failed opening required 'WordPressHTTPS/Url.php' (include_path='.:/usr/share/php5:/usr/share/php5/PEAR:/usr/share/php5/Zend') in /var/www/domains/XXXXXXXXX/blog/wp-content/plugins/wordpress-https/wordpress-https.php on line 42

  30. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Hey whaus,

    Does that file exist in /wp-content/plugins/wordpress-https/lib/?

    The problem is my include paths aren't being used, but I'm defining them in wordpress-https.php.

    $include_paths = array(
    	get_include_path(),
    	dirname(__FILE__),
    	dirname(__FILE__) . '/lib'
    );
    set_include_path(implode(PATH_SEPARATOR, $include_paths));

    The only problem I can think of is you have an old version of PHP that's causing it not to work for some reason.

    Thanks,
    Mike

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic