WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] https not showing up in Chrome, but works in Safari and Firefox (10 posts)

  1. immortalpalace
    Member
    Posted 2 years ago #

    I have installed the plugin and forced SSL on my shopping cart pages on my website:

    https://josiebouchier.com/store/cart/
    https://josiebouchier.com/store/checkout/

    When I open these pages in Safari and Firefox, it seems fine. But when I open these pages in Chrome the "https" is crossed out with a red "X" over it, indicating that the pages are still insecure.

    How do I fix this issue?

    Thanks!
    Josie

    http://wordpress.org/extend/plugins/wordpress-https/

  2. callibeth
    Member
    Posted 2 years ago #

    I'm having the same problem. The https is fine in Safari, Firefox, EI and Opera, but not in Chrome. Windows 7.

  3. HeatherFeuer
    Member
    Posted 2 years ago #

    I'm also having this problem with three pages with forms on them. In my case when opening in IE I have a good padlock on all three pages. In Firefox, I get a good lock on only one of the three and in Chrome, none of the three!

    I checked the pages using the Chrome Developer Tools as recommended but no errors are displayed! I also checked the pages using whynopadlock.com and they passed. I am thoroughly stumped!

    The pages in question are:
    https://www.uniquelyyourshosting.com/about-us/contact-us/ - Works in IE, but shows partial encryption in Firefox and Chrome.

    https://www.uniquelyyourshosting.com/virtual-services/request-for-quote/ - Works in IE and Firefox, but shows partial encryption in Chrome

    https://www.uniquelyyourshosting.com/web-site-design/website-design-quote/
    - Works in IE, but shows partial encryption in Firefox and Chrome.

    Any help in resolving this is appreciated!

  4. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    http://wordpress.org/extend/plugins/wordpress-https/faq/

    "How do I fix partially encrypted/mixed content errors?"

  5. HeatherFeuer
    Member
    Posted 2 years ago #

    Mvied, Chrome developer and whynopadlock.com show no errors or unencrypted external links. The source code shows no unencrypted external links. I have just spent four hours trying to troubleshoot this with no resolution!

  6. HeatherFeuer
    Member
    Posted 2 years ago #

    Okay. I actually called Thawte technical support to see if they could help me figure this out. It seems that Firefox and Chrome have set up their browsers to hiccup if any links on a secure page link to an insecure page. And I mean ANY, especially with Chrome.

    I had already made sure there were NO inbound links that were HTTP -- the biggest culprit being the Google web fonts links. Mvied, I highly recommend suggesting whynopadlock.com as a resource because it is much more user friendly for those not familiar with using Google's developer tools. That left internal links.

    I went into general settings and changed the site URL to httpS. When I did THAT, Firefox stopped hiccuping and showed the proper secured color bar. Chrome, however, is still hiccuping. I suspect it's because the menu links on the rendered page are still showing HTTP. Now I just have to figure out how to get the menus to regenerate as HTTPS links.

    I have always railed against IE and it's inability to play nice with standards but this little "security feature" that FF and Chrome have is a major turnoff!!!

  7. HeatherFeuer
    Member
    Posted 2 years ago #

    This is a follow-up to my previous post and for me resolves this issue.

    My final problems with Chrome apparently stemmed from the cache. When I closed the browser and went back later, I had the proper green lock on those three pages. So. This is my recommendation for the problem of partial encryption:

    Assuming that you have a proper SSL certificate properly installed, in General Settings change your site's URL to https://www.yoursite.tld. In the plugin's settings, tick the option "Force SSL exclusively" and then tick the box on the pages you want secured.

    Go through your templates and stylesheets and make sure external incoming links are set to HTTPS. In my case, since I use Google fonts with the @import in my stylesheet, I had to change the urls to HTTPS. An easy way to double check for stray external links is to use the site I mentioned earlier. Once your page passes on that site, close your browsers then reopen and check again. In some cases you may need to clear your browser cache.

    Mvied, thank you for a really great plugin that simplifies SSL for WordPress!

  8. englund
    Member
    Posted 2 years ago #

    Josie, look at your cart (or checkout) page with a browser and view the source code. (Make sure you're using https when looking.) Take note of any incoming links (normally within your head tags). A quick look at your site shows that the 2 RSS feeds, the "All in One SEO Pack" plugin, and the link to your shortcut icon are all http. Try disabling the SEO plugin and your shortcut icon and see if that solves the problem.

  9. danblu
    Member
    Posted 2 years ago #

    I can see this discussion happened a few months ago but was wondering if it can revisited.

    I'm having the issues as outlined above but the crossing out of the https happens while in the check out of Cart66. I tried following the path outlined above with no success.

    Is anyone familiar with more information on this topic?

    Please let me know.
    Thanks.

  10. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    This is why most users are in the support forum. The reasons are always different per site. You can check the FAQ for how to identify what's causing it. Please start a new support topic.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic