WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
How does the setup look like when with a ssl-proxy? (11 posts)

  1. tonyapril
    Member
    Posted 2 years ago #

    I can access my page via ssl through https://ssl.provider.tld/mydomain.tld.

    My current setup:

    SSL HOST: ssl.probider.tld/mydomain.tld
    Force SSL Administration: checked
    Proxy: Yes (tried also AUTO)

    I get a login screen (https://ssl.provider.tld/mydomain.tld/wp-login.php) , but without css and graphics (tried define('WPHTTPS_RESET', true);). After login i got redirected to https://ssl.provider.tld/mydomain.tld/wp-admin/mydomain.tld/ so i can not access wordpress admin.

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey tonyapril,

    If Force SSL Admin is not enabled, you can still login over HTTP.

    When you're on an HTTPS page and debug mode is enabled, is SSL Yes or No?

    Thanks,
    Mike

  3. tonyapril
    Member
    Posted 2 years ago #

    Thanks for your response.
    I enabled debug and disabled Force SSL Admin. Now i can see that host entered (ssl.provider.tld/mydomain.tld) got replaced by (ssl.providertldmydomain.tld.) without the '/'. There is no debug message about SSL but i think this is because of the replace SSL HOST. On activating i got a a message (SSL Host - Invalid WordPress installation at https://ssl.provider.tldmydomain.tld") but no error if i set the host to the right SSL HOST. Still not working. WordPress Version 3.3.2 & WOrdpress HTTPS Version 3.0.2

  4. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey tonyapril,

    Do you mind if I take a look at it? If you don't want to post the link publicly you can send me an email at mike[at]mvied[dot]com.

    Thanks,
    Mike

  5. tonyapril
    Member
    Posted 2 years ago #

    Thanks Mike, i have sent you an email.

  6. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey tonyapril,

    Is there any way I could get FTP access? I managed to fix some bugs, but not all? It would be helpful to be able to debug in your environment.

    Thanks,
    Mike

  7. tonyapril
    Member
    Posted 2 years ago #

    Sure, i have sent you an email.

  8. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey tonyapril,

    Thank you! I was able to fix a number of bugs. I just hotfixed them into 3.0.2 rather than push out another update. I think you'll find your site in working order. :)

    Thanks,
    Mike

  9. tonyapril
    Member
    Posted 2 years ago #

    Thanks Mike :)

  10. tonyapril
    Member
    Posted 2 years ago #

    What have you changed in the config and will there be a new release of your plugin?

  11. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey tonyapril,

    I didn't change the config, and for now I'm not releasing another version. That's why I hotfixed the changes into 3.0.2. In a few days, if I have bugs to patch, I'll push out another version. Just waiting on people to show me bugs to fix.

    Thanks,
    Mike

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic