WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
Google & IE Displaying Insecure Elements Message (10 posts)

  1. littlesproglets
    Member
    Posted 1 year ago #

    Hi there,

    I am just setting up a new eCommerce word-press site using woo-commerce and a theme called Rustic from Mojo Themes.

    I have a valid SSL certificate across my shopping cart, checkout and checkout payment pages. In Safari I am getting no issues. I am however receiving insecure content messages in IE and Google Chrome.

    I really need to get the site launched and I am struggling to understand how I can get the insecure elements to display properly. I think the main issue is with the CSS file but chrome is also pointing out other elements that I have no idea how to change! If anyone can assist I'd be really grateful.

    http://littlesproglets.co.uk

    Many thanks
    C x

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Roselienjessie
    Member
    Posted 1 year ago #

    Go to /wp-content/plugins/wordpress-https/wordpress-https.php and uncomment (remove the two forward slashes before) the line below, or go to your wp-config.php file and add this line. Hit any page on your site, and then remove it or comment it out again.
    http://wordpress.org/extend/plugins/wordpress-https/faq/
    this will help you out ! [ link removed ] will help you out if you have multiple subdomains.

  3. littlesproglets
    Member
    Posted 1 year ago #

    Hi thanks for the reply, I think what you have described is to reset the plugin?

    Its solving the mystery of the unsecure page elements I really need help with.

    If someone could help I would gladdy donate to the plugin fund.

  4. heathenjimmy
    Member
    Posted 1 year ago #

    It looks like you haven't changed your structure in Settings - General.
    The twitter link you have is https but all the other page links aren't. Facebook link is incorrect. The images are the insecure elements.

    Changing the values via wp-config will hard code the values. All the links will point to https values.

    SSL admin will change your cookie and your password won't work with HTTPS when you try to login after resetting the file structure to HTTPS.

    You can also force https via .htacces with a condition. Backup any file that you want to alter.

    The FAQ for this plugin points to a codex page;
    Changing The Site URL
    http://codex.wordpress.org/Changing_The_Site_URL

  5. littlesproglets
    Member
    Posted 1 year ago #

    Thanks for the assistance so far, so I changed the wp-config file. The style sheet is still being called in via http and it looks like a load of the JS files are as well.

    What is the best way to go about fixing these?

    Thanks so much

  6. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Your site is behind a coming soon page. Are you asking about securing that page or another page? The plugin does not appear to even be enabled as far as I can tell.

    The plugin's primary goal is to fix insecure elements. Changing your Site URL is completely unnecessary. There is no reason that would fix more elements unless you're using a poorly written plugin. If that's the case, it's more worthwhile to remove or replace that plugin rather than securing the whole site. HTTPS makes your site slower due to the encryption/decryption process. If you don't need the whole site to be secure, don't do it.

  7. littlesproglets
    Member
    Posted 1 year ago #

    Hi sorry,

    I put the holding page up over night.

    The site is now active again. There are three pages I wish to secure. Shopping cart, Checkout and checkout pay. All the other pages should be a standard http address.

    If you add a product to the basket, then go through to the shopping basket you'll see the insecure message (in Chrome, Firefox and IE, the site runs fine in Safari).

    Thanks again for the assistance so far. I will now leave the site open with no holding page.

  8. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Same thing, the plugin doesn't appear to be doing anything at all. Can you put it in debug mode?

  9. littlesproglets
    Member
    Posted 1 year ago #

    I've now put the plug-in into debug mode.
    Thanks again for looking...

  10. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    If you look at the debug output, the problem is pretty clear. On an HTTPS page, "SSL: No". So, there is something wrong with your server's configuration. You can get around it by setting Proxy to yes, but it's recommended that you fix your configuration.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic