WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] force SSL (9 posts)

  1. gcall166
    Member
    Posted 2 years ago #

    If 'Force SSL' check box is checked in post, post does not load:
    Secure Connection Failed An error occurred during a connection to srtonlinemedia.com.

    SSL received a record that exceeded the maximum permissible length.

    (Error code: ssl_error_rx_record_too_long)

    the page I am trying to load is https://srtonlinemedia.com/test-https/ and it loads OK as http (SSL box unchecked)

    The page you are trying to view can not be shown because the authenticity of the received data could not be verified.
    Please contact the web site owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey gcall166,

    It seems like there's an error with your SSL Certificate. Try getting in touch with your hosting provider to see if they can fix it for you.

    Thanks,
    Mike

  3. gcall166
    Member
    Posted 2 years ago #

    Hi,
    Many thanks, and I had not set up the shared server settings correctly. I have now set up the shared secure server info that Hostgator supplied, and can access the front end of srtonlinemedia.com via the SSL HOST they gave. BUT when I try it with my post;
    https://secure647.hostgator.com/~gcall166/SRTONLINEMEDIA.COM/test-https/
    I now get Error 404. Any ideas?
    thanks
    Simon

  4. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Simon,

    Some Shared SSL's won't work with custom permalinks. Set your permalink structure to the default and it should work.

    Thanks,
    Mike

  5. gcall166
    Member
    Posted 2 years ago #

    Wow. That did it. thanks Mike!!

  6. dankru
    Member
    Posted 2 years ago #

    Hi folks,

    it took me 2 and a half days to find this enlightening explanation:
    "Some Shared SSL's won't work with custom permalinks."
    Bluehost certainly does not work!
    The permalink trap should be mentioned somewhere on the settings page ...

    Thanks anyway, Mike!

  7. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey dankru,

    In the next version, when the user updates their SSL Host, the plugin is going to try to hit a random post on the site and see if it produces a 404. If so, it will throw a warning to the user that custom permalinks need to be disabled.

    Also, I'm adding this to the FAQ since it comes up so often.

    Thanks,
    Mike

  8. olametro
    Member
    Posted 1 year ago #

    Admin page access is no more possible now with the above error after I tried to change the HTTP to HTTPS in the general settings. When I try to login back, it says:"SSL received a record that exceeded the maximum permissible length.

    (Error code: ssl_error_rx_record_too_long)" Please HELP, HELP, and HELP!
    My url is cccusahq.org.

  9. olametro
    Member
    Posted 1 year ago #

    Hello Mvied, or any other helper,
    Please can you explain how to log in into amy admin when you're logged out. My url is: http://cccusahq.org.
    I tried to changed HTTP to HTTPS in the general settings in the dashboard, and hit save button. That's it, it quickly displaced an error that: "Secure Connection Failed
    An error occurred during a connection to cccusahq.org.
    SSL received a record that exceeded the maximum permissible length.
    (Error code: ssl_error_rx_record_too_long)"

    Pleas help as i can not get to my admin again. Nothing can be accessed at all please.

    Thanks, Ola

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic