WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] Can't get it to work on multisite using Shared SSL (8 posts)

  1. kisshomaru
    Member
    Posted 2 years ago #

    WP multisite 3.2.1
    Trying the WordPress HTTPS plugin 2.0.2 on the main site (so not on subdomain...yet)

    using http://example.com as my site
    using https://secure.justhost.com/~username for the Sahred SSL on 443.

    Tested outside wordpress and pages are loading trough the Sahred SSL.

    I tried setting some post to use force SSL. Permalinks are properly made. However the server will through a 500 internal err (unexpected condition) when trying to browse to that page.

    I think there are more internals to be changed for this to work on a multisite install.
    Has anyone tried to make it work in a multisite with shared ssl?

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey kisshomaru,

    I've tested the plugin out on a couple of multisite installations and haven't had any problems. The plugin itself is relatively simple, so it shouldn't matter if it's installed on a multisite or not.

    Can you look at your apache logs and see what the 500 error is?

    Thanks,
    Mike

  3. kisshomaru
    Member
    Posted 2 years ago #

    I uninstalled the plugin. I'll switch to a private IP and SSL cert in a few weeks as this is clearly not working properly.
    I might use this again though without the shared ssl and let you know then if I encounter any issues.

  4. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey kisshomaru,

    I'm pretty sure the plugin is working fine. It's more likely that the problem is you Shared SSL. Not to try and point the finger somewhere else, but that's generally the case. Shared SSL's are kind of finicky. Getting a 500 error is pretty uncommon, so it's hard telling what's going on without knowing what the error was.

    Can you look at your apache logs and see what the 500 error was?

    Thanks,
    Mike

  5. kisshomaru
    Member
    Posted 2 years ago #

    Ok, installed it again...
    Here is the error log:
    SoftException in Application.cpp:357: UID of script "/usr/local/apache/htdocs/index.php" is smaller than min_uid Premature end of script headers: index.php SoftException in Application.cpp:357: UID of script "/usr/local/apache/htdocs/index.php" is smaller than min_uid, referer: http://secure.justhost.com/~username/14/the-3rd-test-post/
    Premature end of script headers: index.php, referer: http://secure.justhost.com/~username/the-3rd-test-post/
    SoftException in Application.cpp:357: UID of script "/usr/local/apache/htdocs/index.php" is smaller than min_uid Premature end of script headers: index.php SoftException in Application.cpp:357: UID of script "/usr/local/apache/htdocs/index.php" is smaller than min_uid, referer: http://secure.justhost.com/~username/14
    Premature end of script headers: index.php, referer: http://secure.justhost.com/~username/14
    SoftException in Application.cpp:357: UID of script "/usr/local/apache/htdocs/index.php" is smaller than min_uid Premature end of script headers: index.php SoftException in Application.cpp:357: UID of script "/usr/local/apache/htdocs/index.php" is smaller than min_uid, referer: http://secure.justhost.com/~username/14/the-3rd-test-post/
    Premature end of script headers: index.php, referer: http://secure.justhost.com/~username/14/the-3rd-test-post/

    Strange that the log refers to http while I'm trying to access https...

  6. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey kisshomaru,

    I've never seen anything like that before, but the problem is definitely isolated to your server configuration. I did a quick Google search for that error and it appears to be a permissions problem. You'll need to SSH into your server and fix the files to be owned by the proper user and group. It probably wouldn't hurt to check the file permissions as well, but they're probably okay. If you have some kind of control panel for your web hosting, you can probably use that to fix the permissions as well.

    I'm guessing this problem exists even with the plugin disabled when you try to hit https://secure.justhost.com/~username?

    Thanks,
    Mike

  7. kisshomaru
    Member
    Posted 2 years ago #

    There is a problem with that as well.
    If I try to browse https directly to the root of the public where I have the wordpress (so if I hit: https://secure.justhost.com/~username), then wordpress will try to create a new domain and the resulting address will be sent back to http in this form:
    http://domain.com/wp-signup.php?new=secure.justhost.com
    which obviously will get a new error as I don't allow new domains to be created like this.

    You might be right about the permissions, but I couldn't figure it out yet... It definitely seems like the Shared SSL is not going to work for me.
    Thanks anyway, I'll wait until I can setup a proper private SSL.

  8. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Alrighty, just let me know if you have any issues when you get it set up.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic