WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] Cannot activate plugin (14 posts)

  1. bmasllc
    Member
    Posted 2 years ago #

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    I obviously can't see the error without logging in. What is the error?

  3. bmasllc
    Member
    Posted 2 years ago #

    This webpage has a redirect loop
    The webpage at https://www.shopcorps.com/wp-admin/plugins.php?action=activate&plugin=wordpress-https%2Fwordpress-https.php&plugin_status=all&paged=1&s&_wpnonce=e9945bd9b2 has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.
    Here are some suggestions:
    Reload this webpage later.
    Learn more about this problem.
    Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

    When I try to activate the plugin this is what happens. The first time I installed it worked great. I love the plugin. I am not sure what made this happen.

  4. bmasllc
    Member
    Posted 2 years ago #

    Not sure if this makes a difference but when I try to delete and reinstall the plugin I have to remove the folder from my server. It will not delete the files if I try and do it through wordpress.

  5. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey bmasllc,

    You may need to go into your database and delete the options that the plugin creates. All of the options begin with 'wordpress-https'. If you're unsure how to do that, there is another way. You can install 1.9.2, update your SSL Host and then upgrade to 2.0.1.

    If you're having the issue that I think you are, that should fix it. If not, we'll try something else.

    Thanks,
    Mike

  6. bmasllc
    Member
    Posted 2 years ago #

    Mike thank you. It has been a pleasure working with you on this. Your quick response has helped me. I will recommend this plugin and your services to all my clients. If you would like me to advertise your services on my website please send me the content.

    thanks again.

  7. bmasllc
    Member
    Posted 2 years ago #

    Mike,

    So here is what happen. I installed the 1.9.2 version (installed fine). I also wanted to let you know that I started with the 2.0. I tried updating the plugin and I reactivated the plugin and it worked... except when trying to load my site I got the same error. I retraced my steps and problem started when I did the latest update originally.

    I went into my database and there were no records associated with this plugin. I am not sure why because each time I had to remove the files I did so from my ftp client. When I first installed 2.0 it worked amazing so I am not sure what to do at this point. Sorry for the headache.

  8. bmasllc
    Member
    Posted 2 years ago #

    I reinstalled 1.9.2 and in the settings there were these warnings:

    Warning: file_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in /nfs/c09/h03/mnt/136353/domains/shopcorps.com/html/wp-content/plugins/wordpress-https/js/updates.php on line 27

    Warning: file_get_contents(http://mvied.com/wphttps-updates.html) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /nfs/c09/h03/mnt/136353/domains/shopcorps.com/html/wp-content/plugins/wordpress-https/js/updates.php on line 27
    November 24, 2011 - 2.0.1 has been released! This version fixed a few major bugs that made it into 2.0. If you have any issues, head on over to the support forum and I'll see what I can do.

    not sure if this means anything.

  9. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey bmasllc,

    I just pushed up version 2.0.2. After updating, save your WordPress HTTPS settings and it should be fixed. Let me know.

    Thanks,
    Mike

  10. bmasllc
    Member
    Posted 2 years ago #

    Mike,

    when I updated to 2.0.2 it did everything except when it tried reactivating the plugin the same error occurred.

    This webpage has a redirect loop
    The webpage at https://www.shopcorps.com/wp-admin/plugins.php?action=activate&plugin=wordpress-https%2Fwordpress-https.php&plugin_status=all&paged=1&s&_wpnonce=7e1c10e9dd has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.
    Here are some suggestions:
    Reload this webpage later.
    Learn more about this problem.
    Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

    I cannot get past reactivating the plugin after updating it.

  11. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey bmasllc,

    If you delete the options for the wp_options table, there's no way that can happen. Try looking again and see if you can delete the wordpress-https options.

    Thanks,
    Mike

  12. bmasllc
    Member
    Posted 2 years ago #

    I went to my wp_options table but found nothing referencing wordpress-https options. I reinstalled 1.9.2, wich installs fine. I looked at my table again with the old version installed and could not locate any of https options. I went to do an update and it goes through the motions but throws the error when trying to reactivate. Could there be a problems with my tables. I see all the other plugin tables when I am in the database. Just nothing referencing wordpress-https.

  13. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey bmasllc,

    Just execute this query and try again.
    DELETE FROM wp_options WHERE option_name LIKE 'wordpress-https%';

    Thanks,
    Mike

  14. bmasllc
    Member
    Posted 2 years ago #

    Worked perfect thanks for the help and support!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic