WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] Admin Icons and Media Thumbnails disappeared (8 posts)

  1. Julien
    Member
    Posted 2 years ago #

    Hi,

    it's the first time i'm using this plugin. It works correctly when forcing Admin SSL but when you log in, all the icons disappeared. It is because it displays an image url for the admin icons with "https" instead of "http".

    Is it normal or is it a bug ? I cannot let the admin area without the icons...

    I'm using a shared host SSL certificate. I can navigate through the admin pages but it's ugly right now... does someone had this problem ?

    Thanks

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    What icons?

  3. Julien
    Member
    Posted 2 years ago #

    From the left sidebar of the admin. I mean all icons. Icons for "Dashboard", "Posts", "Settings", "Media", .... Everything is missing because the path is modified with https and wordpress cannot find them...

  4. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    If you're using SSL Admin and you're in the Admin panel, all images should be changed to HTTPS.

    But, as far as the images you're talking about, the plugin didn't change them. Those icon image paths are defined in /wp-admin/css/colors-fresh.css as relative paths. They're going to match whatever scheme the current page is using.

    How is it that you can see your admin panel over HTTPS and not the images that exist in the same path?

  5. Julien
    Member
    Posted 2 years ago #

    I don't know... Is there something else that could alter the path ?
    I register my shared host url in the plugin and then all the path changed. Is there a setting/something to add in the wp-config before installing your plugin ?

  6. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Nothing is going to modify that CSS file, no. However, any plugin or theme could override the styles for those icons, but I doubt they are.

    Are you sure the images are being changed to HTTPS and that's why they're not loading, or was that just a guess? Open your browser's console and see if there are any 404 errors in there.

  7. Julien
    Member
    Posted 2 years ago #

    I found the problem.

    When I inserted the host url, I wrote "https://secure.host.com/~name" .
    I took a look back, and just inserted "secure.host.com/~name" and now your plugin works perfectly !

    I thought I needed to write the full url...anyway it works nice!

    Thanks !

  8. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    That doesn't matter. It adds the scheme if you don't type it in, so https:// gets prepended either way. It was probably something else. As long as it works. :P

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic