WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] 410 redirect loop with "Force SSL Exclusively" (4 posts)

  1. Josh S.
    Member
    Posted 1 year ago #

    With new version 3.2,

    enabling "force ssl exclusively" causes the 401 Too Many Redirects when trying to visit any Admin Area. I already had it enabled prior to upgrading this plugin. Upgrade immediately cause redirect loop 410.

    Did a reset of the plugin to get back into admin. Was able to isolate the 410 to enabling Force SSL Exclusively

    Site pages work OK (other than the fact that I want to Force SSL Exclusively)

    This did not occur with previous version of wordpress-https plugin.

    wp-config
    define('FORCE_SSL_ADMIN', true);
    define('FORCE_SSL_LOGIN', true);

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Pepperbase
    Member
    Posted 1 year ago #

    I got an 'error 310 too many redirects' for the admin area after enabling Force SSL Exclusively. I also did a reset of the plugin to get back into the admin. Is there a fix? Thanks.

  3. scott9s
    Member
    Posted 1 year ago #

    I got the same error with the same isolation. too many redirects. Basically, what I gather, wp-config is sending admin/login requests to SSL. However, HTTPS plugin thinks it should force it exclusively and redirects to HTTP which then redirects to HTTPS due to wp-config settings and then the redirect loop begins.

    For now, I was able to change my wp-config settings to false. then I turned on in the HTTPS plugin settings to Force SSL Administration. I'd rather not do that. I'd rather do that setting in the wp-config file. Definitely think this is a bug.

  4. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    I'll have a fix out in the next release. If you'd like, try the development version and let me know if it works for you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.