WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] 3.1.2 causes fatal error: memory exhausted (9 posts)

  1. fwchapman
    Member
    Posted 1 year ago #

    Hi Mike,

    I just completed a lot of updates on one of my sites, and I'm now having a problem with Version 3.1.2 of your plugin. It generates this error message:

    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 372160064 bytes) in Unknown on line 0

    My theme uses the Genesis framework from StudioPress. I disabled all my other plugins (except for WP No Category Base, which breaks my whole site if I stop running it), but the problem remained. I got the same error message with Version 3.0.4, but reverting to Version 2.0.4 eliminated the problem.

    Please let me know if there's any other information you need to resolve the problem.

    Thanks,

    Fred

    http://wordpress.org/extend/plugins/wordpress-https/

  2. fwchapman
    Member
    Posted 1 year ago #

    P.S. My site updates seem to have resolved a longstanding problem I had with the WP No Category Base plugin: disabling the plugin no longer breaks my whole site. That enabled me to test Version 3.1.2 of your plugin after deactivating the WP No Category Base plugin. Unfortunately, I still get the "memory exhausted" error message. At least now we can rule out that it's a plugin conflict!

  3. Anne Hornyak
    Member
    Posted 1 year ago #

    I have a similar issue. My error message:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /data/3/0/18/145/181308/user/[xxxxxx]/htdocs/wp-admin/includes/menu.php on line 126

    I tried to activate Jetpack comments and now I don't have access to my dashboard at all.

    Thanks for any insight!
    Anne

  4. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    This is not a plugin specific problem, my plugin just uses a lot of memory, so it is often the plugin to push people over their limit. You have to increase your memory limit in PHP. Talk to your hosting provider.

  5. fwchapman
    Member
    Posted 1 year ago #

    Mike, thanks very much for your timely reply. I got the same error message even after I disabled all my other plugins, which should minimize the demands on memory. Why is your plugin so memory-intensive? I don't understand why it needs so much memory for the purpose that it serves.

    Is there any way to make the plugin use less memory? If not, I'm thinking seriously of uninstalling the plugin and just updating my wp-config.php file to force admin over SSL. For most of my sites, I just need to ensure that SSL is used for logins and admin. Using such a memory-intensive plugin (even one as wonderful as yours) may be overkill for my purposes.

    Fred

  6. fwchapman
    Member
    Posted 1 year ago #

    P.S. I edited my server's php.ini file to increase the memory limit from 128 MB to 512 MB, but it seems to cap memory usage at 256 MB. I may not be able to solve this problem by throwing more memory at it. :(

  7. fwchapman
    Member
    Posted 1 year ago #

    SUCCESS!

    I was able to raise my memory limit to 512 MB, which made the plugin's error message go away. Here's how I did it.

    In addition to raising the memory limit to 512 MB in php.ini, I had to move the file into the wp-admin directory. In addition to that, I had to add this line to my wp-config.php file:

    define('WP_MEMORY_LIMIT', '512M');

    Only after doing all three steps did WordPress have the memory it needs. I suppose that 512 MB is not a lot of memory for a modern system, but it seemed like a big jump over the 128 MB limit that had been enough until now.

    Long story short... Thank you, Mike! You saved the day again. :)

    Fred

  8. fwchapman
    Member
    Posted 1 year ago #

    I SPOKE TOO SOON!!

    Several different memory monitoring plugins tell me that my WordPress installation now has a memory limit of 512 MB for both WordPress and PHP, but I'm still getting the memory exhausted error message, which shows the memory capped at 256 MB. This doesn't make sense to me. Any thoughts?

  9. fwchapman
    Member
    Posted 1 year ago #

    SUCCESS AT LAST!!!

    I figured out the problem. On my host, the php.ini file is not recursive by default. It applies only to the PHP scripts in the directory where the file resides. Instead of copying it into all subdirectories, I made it recursive by adding this line to my .htaccess file:

    suPHP_ConfigPath /home/USERNAME/public_html

    Now I get no memory exhausted errors whatsoever, and the plugin works better than ever. It turns out that there's no need to change the WP_MEMORY_LIMIT constant in the wp-config.php file after all. Raising the global PHP memory limit to 512 MB is sufficient.

    Mike, thanks for pointing me in the right direction. I really appreciate your help, and I'm glad that I can go back to using your plugin. It's too good to be without!

    Fred

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic