WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
3.1 changes the login link on the home page (6 posts)

  1. fwchapman
    Member
    Posted 2 years ago #

    Hi Mike,

    Thanks for the update to your plugin! I noticed a small problem with Version 3.1: it changes the login link on the home page. With Version 3.0.4, I got the desired behavior, which is that the text for the login link is "Log in." In Version 3.1, the link text is replaced with the actual URL, and the link no longer works; the text is not clickable.

    My WordPress theme uses the Genesis framework from StudioPress. The login link is generated by the Genesis [footer_loginout] shortcode. Here's the PHP code for the shortcode:

    add_shortcode( 'footer_loginout', 'genesis_footer_loginout_shortcode' );
    /**
     * Adds admin login / logout link.
     *
     * Support shortcode attributes are:
     *   after (output after link, default is empty string),
     *   before (output before link, default is empty string),
     *   redirect (path to redirect to on login, default is empty string).
     *
     * Output passes through 'genesis_footer_loginout_shortcode' filter before returning.
     *
     * @since 1.1.0
     *
     * @param array $atts Shortcode attributes
     * @return string Shortcode output
     */
    function genesis_footer_loginout_shortcode( $atts ) {
    
    	$defaults = array(
    		'after'    => '',
    		'before'   => '',
    		'redirect' => '',
    	);
    	$atts = shortcode_atts( $defaults, $atts );
    
    	if ( ! is_user_logged_in() )
    		$link = '<a href="' . esc_url( wp_login_url( $atts['redirect'] ) ) . '">' . __( 'Log in', 'genesis' ) . '</a>';
    	else
    		$link = '<a href="' . esc_url( wp_logout_url( $atts['redirect'] ) ) . '">' . __( 'Log out', 'genesis' ) . '</a>';
    
    	$output = $atts['before'] . apply_filters( 'loginout', $link ) . $atts['after'];
    
    	return apply_filters( 'genesis_footer_loginout_shortcode', $output, $atts );
    
    }

    Thanks for anything you can do to fix this little glitch!

    Fred

    http://wordpress.org/extend/plugins/wordpress-https/

  2. xanaftp
    Member
    Posted 2 years ago #

    I am here to mention that this problem still exists in WordPress HTTPS 3.1.1 with WordPress 3.4.1

  3. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Alrighty, I'll get a fix out soon.

  4. fwchapman
    Member
    Posted 2 years ago #

    Thanks, Mike. Your excellent support of this plugin is much appreciated!

    Fred

  5. Enterpr1se
    Member
    Posted 2 years ago #

    Hi, I face same problem too

  6. hmoore71
    Member
    Posted 2 years ago #

    I too am having this issue. Looks like an issue with the "loginout" filter.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic