WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] 2.02 dumps me out of admin, breaks css on site (3 posts)

  1. justwrapped
    Member
    Posted 2 years ago #

    Hi Mike,

    I started with the most current version of this plugin and had a similar problem as the people with the 403 Forbidden code issues, but I think I set it up incorrectly from the get go.

    I was able to install the plugin then, I believe, I did not set the https address up correctly. As soon as I saved, it bumped me out of admin and then I could not get back to admin because of error codes - I think 404. I tried to remove the S but it obviously kept pushing back to ssl.

    I deleted the plugin from the folder and then tried to reinstall it. As soon as it installs, it immediately pulls me out of the admin section and it gives me the 404 code. I do not even get to change anything in settings now when I reinstall. There has to be something that sticks somewhere after its deleted, probably because I do not properly deactivate it.

    The most current version also makes my css break.

    As soon as I delete the plugin from the plugins folder, css goes back to normal, and I can then get back into the wp-admin section.

    I then deleted the current version and added 1.9.2., which does not bump me out and I can attend to the admin section again. It did not work for me. I tried to follow other topics regarding 1.9.2 and disabled permalinks, something I really didn't want to do but got further than I have in the past. As of right now, I get a 403 with an additional 404 message.

    I have SSL correctly set up in my account (not shared).

    Once I post this, I plan on disabling v-1.9.2 but I would really like to get the most current version currently configured and working. I REALLY would like to get it working.

    Thank you for your time and thank you for continuing to help to the people that are looking for advice on your plugin.

    Thanks!

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey justwrapped,

    Because of the way that 2.0 was coded, you should be able to go into 1.9.2, set up the correct SSL Host, and then upgrade to 2.0.2. The settings from 1.9.2 are migrated to the newest version and will overwrite any existing settings that may have been set in 2.0+.

    In the next version I'm going to be looking into some auto-detection of situations like this so that the plugin can fix itself. I realize it's very frustrating to be locked out of your admin panel.

    I don't think even the most current version is going to work based on what you've told me.

    Can you visit HTTPS pages without the plugin installed?

    Thanks,
    Mike

  3. justwrapped
    Member
    Posted 2 years ago #

    Thanks for messaging me back so quickly. I've been working on this up until about 20 minutes ago. I figured it out.

    I had to check the box in "Direct Admin" that said "Use Symbolic Link from Private to Public".

    I reinstalled 2.0.2

    At that point it immediately logged me out again and this time I got a curl error (3 actually) but the page also showed the login area for wp-admin. I logged in anyway and went to the admin settings.

    At admin I changed the SSL Host to https://www.mysite.com and left the port area blank. I checked the box where it said "Force SSL Exclusively", and left the box at "Force SSL Administration" unchecked and clicked "Save Changes".

    It pushed me out of Admin and pushed me back to the Admin Login page and the curl errors were gone.

    I logged in again, went to the setting page one more time and checked the "Force SSL Administration" box.

    I got pushed out again and was pleasantly surprised that everything was - and still is - working.

    Moral of the story: Make sure that the hosting company has the symbolic links set up correctly. Aaah, I feel so much better and I am so glad I did not give up on this. I wanted to!

    Thank you again for trying to work through this with me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic