WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[Plugin: WordPress HTTPS] Multisite, SSL (wildcard) and forced login (5 posts)

  1. broniors
    Member
    Posted 3 years ago #

    hi,

    I am using WordPress HTTPs with a multisite using subdomains. I want to be able to force SSL for login (and ideally later admin ... but one problem at a time)

    My site/s require the user to login first before they access either the front end or administration.

    I have got the SSL certificate to work when they type in exactly the login url but I am having problems forcing SSL for login. I have edited the wp-config file but I think my problem relates to what I need to do with the .htacces file. I am not sure what I need to do there.

    Or could it be something else?

    Thanks

    Regards
    Bron

  2. broniors
    Member
    Posted 3 years ago #

    This problem seems to be only happening on my subdomains ... I am sure that what I am using for the .htaccess is not working correctly I am just not sure what I need

    Here is what I have from http://codex.wordpress.org/Administration_Over_SSL

    RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /(.*)\ HTTP/ [NC]
    RewriteCond %{HTTPS} !=on [NC]
    RewriteRule ^/?(wp-admin/|wp-login\.php) https://mysite.com%{REQUEST_URI}%{QUERY_STRING} [R=301,QSA,L]

  3. broniors
    Member
    Posted 3 years ago #

    I think I might have a solution ... needs more testing but it works so far

    #Force SSL on my.domain.com
    RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /(.*)\ HTTP/ [NC]
    RewriteCond %{HTTPS} !=on [NC]
    RewriteRule ^/?(wp-admin/|wp-login\.php) https://mysite.com/wp-admin/my-sites.php [NC,L]

  4. Mvied
    Member
    Plugin Author

    Posted 3 years ago #

    Hey broniors,

    The admin SSL portion of the plugin is not 100%. I'm working to get an update to fix this out by next week, or possibly the week after. I'll certainly update this topic when I release it.

    Thanks,
    Mike

  5. seanscullion
    Member
    Posted 3 years ago #

    Hello!

    Is there a published solution to this problem anywhere?

    Here's our setup and what we're trying to achieve:

    * We've got a single installation of WordPress.
    * We run multiple subdomain sites with the single installation
    * We want a single user-registration process (registration for one implies registration for all)
    * Ideally, a single-sign-on - log in to one implies log in for all. We understand this might be a problem due to the cookie being set for the domain of the original sign-in, but if someone has solved this please let me know.
    * We would like the login, registration and all admin pages to be done over SSL.

    Has anyone out there achieved such a set up?

    Many thanks,

    Sean Scullion

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic