WordPress.org

Ready to get started?Download WordPress

Forums

Google Forms
[resolved] [Plugin: WordPress Google Form] Language converts to Chinese (8 posts)

  1. jpantana
    Member
    Posted 1 year ago #

    Mike, I love your google forms plugin, but I've been having some issues with my text being converted to Chinese. There's an example at http://www.JasonPantana.com (top left of left sidebar). It's doing it on most every form, but not all of them. It tends to be the legal disclaimer, the submit button, and the "required" text. I can email you the exact code I'm using if you'd like. Thanks for your thoughts.

    http://wordpress.org/extend/plugins/wpgform/

  2. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    You may add &hl=en to your URL to force it to English. You can see some information on my web site where I show how to display a form in French.

  3. jpantana
    Member
    Posted 1 year ago #

    So I did that, as described on the site you gave me, and it took the whole thing to pure Chinese text. Here's what it says:

    云端硬盘

    抱歉,您请求的页面(或在线文档)不存在。

    请检查地址,然后重试。

    要创建您自己的在线文档吗?

    使用 Google 文档,您可以轻松地创建、存储和共享在线文档、电子表格和演示文稿。

    有关详细信息,请访问

    which translate to:

    Cloud hard drive

    Sorry, the page you requested (or the online documentation) does not exist.

    Please check the address and try again.

    To create your own online documentation?

    With Google Docs, you can easily create, store and share online documents, spreadsheets and presentations.

    For more information, please visit

  4. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    Odd, can you fill out my Help and Support form? It helps if I can see the short code you're using along with the URL for the form. The above error message sounds like a poorly formed short code although it doesn't explain the Chinese characters.

  5. jpantana
    Member
    Posted 1 year ago #

    Well, it suddenly started to work... I didn't change anything and I have no idea why it would have converted from straight Chinese text to the correct English display. Either way, your code appears to have resolved the issue. Thanks so much

  6. jshipman
    Member
    Posted 1 year ago #

    I am running into this same issue. The form I created has a Chinese submit button. I included the &hl=en in the embedded form link as well. It did not make a difference.

  7. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    I had someone else contact me about this yesterday and adding the &hl=en parameter to their form URL solved their problem. If you want, I'd be happy to look at your problem, fill out the information on my Help and Support form and I'll try and look at it as quickly as possible.

    From what I can tell, this is intermittent behavior on the Google side where occasionally Google either thinks your language should be Chinese or their CDN is delivering your form from another part of the planet and the language setting is confused. In two cases adding the &hl=en parameter resolved it and in two other cases it simply stopped happening after several hours.

  8. lucasmullens
    Member
    Posted 9 months ago #

    Needs to be ?hl=en if you don't have any parameters on the URL yet. I had this issue and got the same error as jpantana until I swapped the & for a ?.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.