WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Flash Uploader
[resolved] If you can't edit php.ini, don't use this plugin (6 posts)

  1. maialee
    Member
    Posted 2 years ago #

    This is driving me crazy. I changed hosts and imported my WordPress site. Everything works perfectly except an issue with images that are in the uploads folder, but not in the media library. WP Flash Uploader seemed like the perfect solution. However, when I try to sync the media library, I get an Apache error. No matter what I do, it's an error. Upon researching it, I've found that I need to edit my php.ini file to lengthen the time before it times out, but I didn't have access to it, so I followed instructions and made one. That didn't work. If you're on a cheap server and can't modify things easily, this will just be a pain. If anyone knows of an easy way to get it to work without it timing out, I would be so happy to know about it!

    http://wordpress.org/extend/plugins/wordpress-flash-uploader/

  2. mdempfle
    Member
    Plugin Author

    Posted 2 years ago #

    Does your host allow .htaccess files to edit apache settings?

    The problem you wrote has unfortunately nothing to do with the plugin itself but with the server settings.

    Normally it should be enough to call the synchronize again after it fails because only files that are not processed yet are called again.

    I might think about a solution that measures the used time and before it fails it recalls the plugin or even simpler about an option in the config where you can set after how many images the plugin tries to to a reload of the page.

  3. alanaj7
    Member
    Posted 2 years ago #

    I am having a similar issue. In January I changed my host and imported my WP site. Everything imported except I can't see my images in the Library even though I see them on the server.

    I downloaded and activated the plugin. I tried 7 times to sync the media library but I received these errors:
    Fatal error: Maximum execution time of 30 seconds exceeded in /home/mysite/public_html/wp-content/plugins/wordpress-flash-uploader/inc/wfu-sync.php on line 342
    Fatal error: Maximum execution time of 30 seconds exceeded in /home/mysite/public_html/wp-includes/plugin.php on line 134

    Any help will be greatly appreciated.

  4. alanaj7
    Member
    Posted 2 years ago #

    Cancel my above request. I've resolved the problem.

  5. howardpw
    Member
    Posted 2 years ago #

    I've resolved the problem.

    alanaj7 - I have the same issue.

    Fatal error: Maximum execution time of 30 seconds exceeded in /home/scatteri/public_html/wp-content/plugins/wordpress-flash-uploader/inc/wfu-sync.php on line 374

    Can you please share how you resolved it? Thanks.

  6. howardpw
    Member
    Posted 2 years ago #

    Resolved.

    Added the following to php.ini file

    max_execution_time = 300

    where 300 is in seconds. Default is 30.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic