WordPress.org

Ready to get started?Download WordPress

Forums

WordPress File Monitor Plus
[resolved] Get no information about changes (12 posts)

  1. Nobody15
    Member
    Posted 3 years ago #

    The plugin does not show any changes to the files.
    I get no error message.

  2. Scott Cariss
    Member
    Plugin Author

    Posted 3 years ago #

    Can you please give more information of what system your running on?

    How have you got the cron setup?
    What WordPress version are you running?
    Are you using PHP4 or PHP5?
    Whats you current file check path?

  3. Nobody15
    Member
    Posted 3 years ago #

    Hi Scott,

    i am using the WordPress Cron. But also the manual scan gives no results.
    My WordPress Version is 3.1.1 and the PHP Version is 5.2.8
    The file check path is /home/httpd/docs/mysite/wp which is the default.
    In the options table i have a setting wpfm_listing which contains a filelist.

    regards
    Tom

  4. Scott Cariss
    Member
    Plugin Author

    Posted 3 years ago #

    Hello Tom

    Your setup should work so I wont say its that.

    However you mention wpfm_listing in you options table but that is from the plugin WordPress File Monitor and not mine.

    The three options that you should have for my plugin is sc_wpfmp_settings on install, sc_wpfmp_scan_data on a successful scan and sc_wpfmp_admin_alert_content if file changes have been found.

    Firstly do you have sc_wpfmp_scan_data with any data in it?

    Scott

  5. Nobody15
    Member
    Posted 3 years ago #

    Hi Scott

    Well, so wpfm_listing is from an old WordPress File Monitor installation.

    I can only find sc_wpfmp_settings in the options table.
    sc_wpfmp_scan_data and sc_wpfmp_admin_alert_content is not there.

    Tom

  6. Nobody15
    Member
    Posted 3 years ago #

    Hi Scott

    with WP_DEBUG enabled i got the following error when your plugin try to insert sc_wpfmp_scan_data in the options table
    [Got a packet bigger than 'max_allowed_packet' bytes]

    Tom

  7. Scott Cariss
    Member
    Plugin Author

    Posted 3 years ago #

    I think what is happening here Tom is that you are scanning a lot of files and the data is becoming so big that your reaching the insert limit set on MySQL by your webhost.

    Are you using all three scan methods at once?

    If you are try just using the md5 hash or modified time. This will cut down on the data size to save on scan.

    Its not ideal but I'll look into finding another way to save the scan data.

    To get around this I might have to look at a solution of saving to a file instead.

  8. Nobody15
    Member
    Posted 3 years ago #

    Hi Scott

    Yes, this was the Problem. If i set the file check path to /home/httpd/docs/mysite/wp/wp-content which contains much less files it works.

    Yes, i am using all scan methods.

    I have now contacted the hoster that he raises the 'max_allowed_packet' limit.

    Perhaps it would be possible for you to save in multiple records.

    Tom

  9. Scott Cariss
    Member
    Plugin Author

    Posted 3 years ago #

    Saving to multiple records I don't think is a good idea. Already I'm using 3 options in the DB and the idea is to try and keep that to a minimum.

    Plus I wouldn't know where to split the data? Web hosts can have max_allowed_packet set to any limit. I have even found posts of people saying they have it set as low as 1MB.

    I think I will introduce a method to save to a file as well just in-case others have the same issue.

    Anyway, thank you Tom for taking the time to debug and post on the forum

  10. Nobody15
    Member
    Posted 3 years ago #

    Yes, its true the standard value for max_allowed_packet is 1MB.
    And the size of my packet was 2,1MB.

    No problem. I have to thank you for the great plugin :)

  11. Scott Cariss
    Member
    Plugin Author

    Posted 3 years ago #

    Hello Tom,

    I'd recommend that you set your scan root back one directory. The idea of this plugin is to scan wordpress system files also to tell you if any core files have changed without your knowing.

    I have just tagged a new version of the plugin so you should see version 1.1 soon. This version allows you to save the scan data to file instead of the database. So in theory you shouldn't run into any limit on the amount of scanned files.

    If you feel this fixes the problem then please mark this post as resolved :)

    Scott

  12. Nobody15
    Member
    Posted 3 years ago #

    Thanks Scott

    With the new function (save to file), the problem is solved.

    Tom

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic