WordPress.org

Ready to get started?Download WordPress

Forums

WordPress File Monitor Plus
Filters disappeared after upgrade to 2.1 (10 posts)

  1. itpixie
    Member
    Posted 2 years ago #

    Hello,

    I just upgraded to version 2.1 and noticed that my filters for Files/Directories to Exclude have all disappeared. Not sure if that's a bug or part of the upgrade to 2.1, but it would be nice if the filters would stay in the future upgrades (since without the filters my scans always errors or times out due to the larger number of files/directories I have).

    I love the plugin and it's on my WP essential list. Thank you for your handwork on it!

    Thank you,
    IT Pixie

    http://wordpress.org/extend/plugins/wordpress-file-monitor-plus/

  2. Scott Cariss
    Member
    Plugin Author

    Posted 2 years ago #

    Yes I noticed this happened too... I thought it was just something I did wrong.

    I will look into it

  3. itpixie
    Member
    Posted 2 years ago #

    Thank you Scott!

    Also I am encountering the following warnings after the upgrade, could you shed some light on what they mean, and if they are something I should be concern of?

    Warning: filesize() [function.filesize]: stat failed for {root directory}/stats/logs in {root directory}/wp-content/plugins/wordpress-file-monitor-plus/classes/wpfmp.class.php on line 286

    Warning: filemtime() [function.filemtime]: stat failed for {root directory}/stats/logs in {root directory}/wp-content/plugins/wordpress-file-monitor-plus/classes/wpfmp.class.php on line 289

    Warning: md5_file({root directory}/stats/logs) [function.md5-file]: failed to open stream: No such file or directory in {root directory}/wp-content/plugins/wordpress-file-monitor-plus/classes/wpfmp.class.php on line 292

  4. pmfox
    Member
    Posted 2 years ago #

    I'm also seeing this in the most recent version of the plugin. It's showing up in an error_log file that showed up in the root directory.

    PHP Warning: file_put_contents({root directory}/wp-content/uploads/WPFMP_DATA/.sc_wpfmp_scan_data) [<a href='function.file-put-contents'>function.file-put-contents</a>]: failed to open stream: No such file or directory in {root directory}/wp-content/plugins/wordpress-file-monitor-plus/classes/wpfmp.class.php on line 561

  5. itpixie
    Member
    Posted 2 years ago #

    @pmfox, I think your warning might have something to do with either

    • /wp-content/uploads/WPFMP_DATA/.sc_wpfmp_scan_data didn't exist because this was the first time you ran the plugin after the upgrade; OR
    • You didn't give the plugin sufficient permission to create and write to /wp-content/uploads/WPFMP_DATA/.sc_wpfmp_scan_data

    BTW, I figured out my warnings and what caused them. Basically they are about the plugin trying to compare the one folder {root directory}/stats/logs for changes, but this is kind of a phantom folder, or a system folder that can't be access by anyone except the host company. I don't even see it when logging into the server using Filezilla. The plugin is able to see this folder, but is not able to perform any checks on it or write to it (probably due to permission issue).

    After excluding this folder from being monitored, the warnings went away. I got the notification on what's being removed (from the monitor list), and that's when I finally realize the existence of {root directory}/stats/logs.

    Sorry this totally went off topic (not filters related), but please correct me if my observation about the warnings is wrong.

  6. Dzynit
    Member
    Posted 2 years ago #

    I also saw the excludes disappeared on upgrade. I just upgraded to 2.2 and the same happens, but also the email the report goes to reverts to the wp-admin default email address.

  7. Dzynit
    Member
    Posted 2 years ago #

    I was wrong on the email part - I see it just switched order.

  8. Hendison Scott
    Member
    Posted 2 years ago #

    Seems fixed on the new version - it did not overwrite at a site (which WAS blank when i got there from the last irritating upgrade) - so i added a test line - then upgraded - my line is still there.

    We lost a TON of custom excludes in all of our own and client domains, for everything from cache to Analytics folders and this REALLY sucked. Can anyone confirm this has been resolved?

    (By the way, this plugin is really invaluable - I just sent a donation to the dev and recommend that y'all do too)

  9. Hendison Scott
    Member
    Posted 2 years ago #

    In an effort to be more efficient, I merely SAID that "I just donated" but then when I tried to don ate, I end up at a 404 page at the authors site - http://l3rady.com/donate

    How can we donate to this plugin?

  10. Scott Cariss
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Scott,

    I know that the filters don't get wiped in the latest version any more (from my experience).

    But as for the previous version I cannot see why the filters are getting wiped. I've run through the code many times and cannot see why. I gave up and continued on with the new version which has seemed to have fixed the problem...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic