WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Dashboard Twitter
[resolved] Error 500 after return from Twitter.com (8 posts)

  1. Jorim
    Member
    Posted 1 year ago #

    When I try to authenticate and returning to my site from twitter with the token and verifier in the URL I get an Error 500. Everything else on the site is working just fine...

    Any thoughts on this?

    http://wordpress.org/extend/plugins/wordpress-dashboard-twitter/

  2. Alphawolf
    Member
    Plugin Author

    Posted 1 year ago #

    Sounds like a curl problem. Can you enable the WP_DEBUG mode in your wp-config.php and try to authenticate again? Instead of the 500 error it should be returning an error message.

  3. Jorim
    Member
    Posted 1 year ago #

    Unfortunately I still get the 500 error without messages after I set wp_debug to true. It might be something on the server itself that doesn't allow the execution of some code on that page...

  4. Alphawolf
    Member
    Plugin Author

    Posted 1 year ago #

    Can you link a phpinfo file?

  5. Jorim
    Member
    Posted 1 year ago #

    Here you are: http://www.writteninmusic.com/phpinfo.php

    I'll remove the file later ;-)

  6. Alphawolf
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks, looking all fine. PHP5, CURL enabled. The plugin doesn't actually require anything further.

    Hmmm, would it be possible to give me a temporary admin user for your blog + FTP credentials for the plugin's folder so I can edit my plugin's files to check things? If it's okay for you, please send it to scripts (at) schloebe (dot) de ...

  7. Alphawolf
    Member
    Plugin Author

    Posted 1 year ago #

    Ooookay, thanks for the email! :)

    Quite tricky, and I would have never come up with the reason if I hadn't had the chance to have a look myself.

    The problem is Yoast's Google Analytics for WordPress plugin that's generating a fatal error

    Fatal error: Call to undefined function menu_page_url() in /var/www/vhosts/writteninmusic.com/httpdocs/wp-content/plugins/google-analytics-for-wordpress/googleanalytics.php on line 845

    The reason for getting the error from Yoast's Google Analytics for WordPress plugin is that it redirects to his plugin page after authenticating with Twitter via OAuth. I have created a topic about this already here: http://wordpress.org/support/topic/plugin-google-analytics-for-wordpress-show-stopper-for-other-plugins-using-oauth-authentication?replies=3
    So after authenticating with Twitter, Yoast's plugin hijacks all incoming OAuth authentication responses and ALWAYS redirects to his plugin page which fires the fatal error by his plugin code.

    Can't do much about it until he fixes his plugin.

    For now to get your Twitter authentication done, do the following:
    - Deactivate Yoast's Google Analytics for WordPress plugin
    - Authenticate with Twitter
    - Activate Yoast's Google Analytics for WordPress plugin

    ps. If you want to see the error message yourself, just set
    @ini_set('display_errors', 0);
    to 1 in your wp-config.php (I just added that line).
    pps. You can disable my WP account and FTP credentials. Thank you! :)

  8. Jorim
    Member
    Posted 1 year ago #

    Thanks for looking into this and for finding a workaround to get it working! Very very much appreciated!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.