WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Dashboard Twitter
[resolved] Configured for the wrong Twitter Account (18 posts)

  1. lynclark
    Member
    Posted 3 years ago #

    I think this is a great plugin- minus the fact that I was logged onto my personal Twitter and not my company Twitter when I went to configure it.

    I'd love to fix this- have tried the whole uninstall/re-install routine, revoked access on my personal Twitter through the connections...to no avail.

    Any suggestions? ASAP? Thanks!

  2. Alphawolf
    Member
    Plugin Author

    Posted 3 years ago #

    So what's the problem exactly? Sorry, didn't get it. :)

    You weren't able to logout from the Twitter OAuth Auth?

    ps. The plugin configuration isn't account-specific, btw. The options remain for whatever account you authenticate with.

  3. lynclark
    Member
    Posted 3 years ago #

    So when the widget appears on your dashboard- it asks you to configure it- aka allow the dashboard to gain access to your Twitter...well I forgot I was signed onto my personal Twitter and not my company's Twitter, so it was showing my Twitter account. I tried to revoke access, uninstall, re-install, everything.

    What is the Twitter OAuth Auth?

  4. Alphawolf
    Member
    Plugin Author

    Posted 3 years ago #

    The Twitter OAuth Auth is that thing you do when you sign in when you're being redirected to the Twitter website, and back to your WP Dashboard.

    But you can re-configure everything regardless what account you're authenticated with. The settings arent account-specific.

  5. lynclark
    Member
    Posted 3 years ago #

    How do you reconfigure? I don't see anywhere where it says to change the account

  6. Alphawolf
    Member
    Plugin Author

    Posted 3 years ago #

    You'll find the configure link when you hover over the Widget title. :) That's how you edit any widget's settings, and is WordPress standard.

  7. lynclark
    Member
    Posted 3 years ago #

    Wellll I don't see an option to reconfigure in those options given under the "configure button...

  8. lynclark
    Member
    Posted 3 years ago #

    It's as though it's still reading my account even though I revoked access...

  9. Alphawolf
    Member
    Plugin Author

    Posted 3 years ago #

    You don't see the option "Make the Dashboard Widget accessible for everyone?"? Basically the widget options reside here:

    [your_blog_url]/wp-admin/index.php?edit=wp_dashboard_twitter#wp_dashboard_twitter

  10. Alphawolf
    Member
    Plugin Author

    Posted 3 years ago #

    It's as though it's still reading my account even though I revoked access...

    So you don't see the "Sign in with Twitter" badge even after revoking access/logging out?

    Can you provide me a login? If so, please to scripts AT schloebe DOT de
    Thanks.

  11. lynclark
    Member
    Posted 3 years ago #

    schloebe.de?

  12. lynclark
    Member
    Posted 3 years ago #

    scripts (@) schloebe (.) de?

  13. Alphawolf
    Member
    Plugin Author

    Posted 3 years ago #

    Correct.

  14. Alphawolf
    Member
    Plugin Author

    Posted 3 years ago #

    When I login, I get the on-screen message

    The following directory needs to be writable: wordpress-dashboard-twitter/uploads [Recheck]

    Resolve that first. :)

  15. lynclark
    Member
    Posted 3 years ago #

    This is going to sound dumb...how do I do that? Haha.

  16. Alphawolf
    Member
    Plugin Author

    Posted 3 years ago #

    It doesn't sound dumb at all. :) Just open your FTP client that you uploaded all the WP files with. Then go to wp-content/plugins/wordpress-dashboard-twitter, right-click (depending on your FTP client) on the /uploads/ folder, select "Properties" or "Permissions" (also depending on your FTP client) and set checkboxes for "Write".

    After doing that, you should either see a "Save the plugin options once" message, or the "Sign in with Twitter" badge or the "Logout" link to revoke access.

  17. lynclark
    Member
    Posted 3 years ago #

    Ah! There it is. Beautiful! Thank you so much for all your help!

  18. Alphawolf
    Member
    Plugin Author

    Posted 3 years ago #

    No problem. Don't forget to delete/disable the account you set up for me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic