WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WordPress Beta Tester] PHP error when upgrading plugins (8 posts)

  1. Kim Parsell
    Volunteer Moderator
    Posted 4 years ago #

    I'm using the WordPress Beta Tester plugin on a 2.9-rare install (set to bleeding edge nightlies), and am getting an error whenever I upgrade a plugin:

    PHP Fatal error: Call to undefined function get_preferred_from_update_core() in /home/xxxxxx/public_html/wordpress/wp29/wp-content/plugins/wordpress-beta-tester/wp-beta-tester.php on line 69

    This doesn't show up on the screen at the time, but is showing up in the error logs.

    Just an FYI so it can be fixed for the next release of the plugin.

    http://wordpress.org/extend/plugins/wordpress-beta-tester/

  2. Thanks for the feedback. Unfortunately I can't reproduce this at the moment :-(

    How does the upgrader access your WordPress install - does it use FTP or direct file system access?

  3. Kim Parsell
    Volunteer Moderator
    Posted 4 years ago #

    It uses direct file system access. I don't get these errors when the Beta Tester plugin is disabled.

    I activated the wp_update_plugins debug plugin and here is the feedback that I got from it:

    Available transports: Curl Streams Fopen Fsockopen $raw_response: Array ( [headers] => Array ( [content-type] => text/plain; charset=utf-8 [content-length] => 6 [date] => Fri, 04 Sep 2009 13:42:24 GMT [server] => LiteSpeed [connection] => close ) [body] => a:0:{} [response] => Array ( [code] => 200 [message] => OK ) [cookies] => Array ( ) )

    All plugins are at their current available versions - nothing needed to be upgraded this morning.

    Let me know if there's any other info that I can provide to help you troubleshoot this issue.

  4. Kim Parsell
    Volunteer Moderator
    Posted 4 years ago #

    I've upgraded your plugin to the latest version, then upgraded my 2.9-rare install to the latest nightly build (bleeding edge) and am still getting this error in my logs:

    [18-Oct-2009 05:54:12] PHP Fatal error: Call to undefined function get_preferred_from_update_core() in /home/xxxxxxxx/public_html/wordpress/wp29/wp-content/plugins/wordpress-beta-tester/wp-beta-tester.php on line 69

    I know you said you can't reproduce it, but just wanted to let you know it's still happening for me with the latest version of the plugin.

  5. KirkM
    Member
    Posted 4 years ago #

    Hi Westi - Thanks for the plugin, makes things much easier.

    I've been seeing a PHP error in my main error log regarding this plugin (WordPress Beta Tester 0.6). Happens twice a day while the plugin is activated without any intervention from myself:

    [30-Oct-2009 04:05:49] PHP Fatal error: Call to undefined function get_preferred_from_update_core() in /home3/longmead/public_html/outofdate/wp-content/plugins/wordpress-beta-tester/wp-beta-tester.php on line 84
    [30-Oct-2009 16:07:43] PHP Fatal error: Call to undefined function get_preferred_from_update_core() in /home3/longmead/public_html/outofdate/wp-content/plugins/wordpress-beta-tester/wp-beta-tester.php on line 84
    [31-Oct-2009 04:11:39] PHP Fatal error: Call to undefined function get_preferred_from_update_core() in /home3/longmead/public_html/outofdate/wp-content/plugins/wordpress-beta-tester/wp-beta-tester.php on line 84
    [31-Oct-2009 16:13:53] PHP Fatal error: Call to undefined function get_preferred_from_update_core() in /home3/longmead/public_html/outofdate/wp-content/plugins/wordpress-beta-tester/wp-beta-tester.php on line 84
    [01-Nov-2009 03:15:52] PHP Fatal error: Call to undefined function get_preferred_from_update_core() in /home3/longmead/public_html/outofdate/wp-content/plugins/wordpress-beta-tester/wp-beta-tester.php on line 84
    [01-Nov-2009 15:17:51] PHP Fatal error: Call to undefined function get_preferred_from_update_core() in /home3/longmead/public_html/outofdate/wp-content/plugins/wordpress-beta-tester/wp-beta-tester.php on line 84

    Line 84: $preferred = get_preferred_from_update_core();

    This site is a test site with little or no traffic.

    PHP version 5.2.9
    MySQL version 5.0.81

    Active plugins [besides WordPress Beta Tester]: (The same plugins I use in both my "live" sites running WP 2.8.5)

    Akismet 2.2.6
    All in One SEO Pack 1.6.7
    Clean Options 1.2.3
    Google XML Sitemaps 3.1.7
    Recent Comment Avatars 3.3
    Revision Diet 1.0.1
    Secure WordPress 0.3.9
    Subscribe To Comments 2.1.2
    Woopra 1.4.3.1
    WordPress Mobile Edition 3.1
    WP-DBManager 2.50
    WP Super Cache 0.9.7

    If you need me to do anything for troubleshooting purposes please let me know.

  6. Thank you for the detailed information.

    I will look into fixing this in the next version of the plugin.

  7. I believe I have tracked this issue down now and it is fixed in the new version 0.7 which will be available for you to upgrade too soon.

  8. KirkM
    Member
    Posted 4 years ago #

    Just upgraded my test site using version 0.7. Error log is clear. So far so good. I'll keep an eye on it over the next few days. Thanks Westi.

Topic Closed

This topic has been closed to new replies.

About this Topic