WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Backup to Dropbox
[resolved] file permissions of backups folder (7 posts)

  1. SomeUser2012
    Member
    Posted 1 year ago #

    Hi there,

    I just installed your great plugin today and it works great, except for one thing:

    the plugin needs a file permission of 777 on the backups folder in order to work??!!

    This is what happened:
    After the installation (through plugin page within wordpress, as well as through ftp upload) it asked me to create the "backups"-folder.

    So I created the folder with my ftp programm (filezilla) and reloaded the wpb2d settings page and it asked me to grant wordpress write access to the backups folder.

    Error message: WordPress does not have write access to '/www/htdocs/xxxxxxx/xxxxxxx.xxx/wordpress/wp-content/backups'. Please grant it write privileges before using this plugin.

    So I've tried various combinations from 755 to 775, but only 777 got the plugin to work... (It works like a charm so)

    Is this great plugin supposed to work like this?

    If so, isn't this a security issue?
    See also: http://codex.wordpress.org/Changing_File_Permissions#The_dangers_of_777

    So first off all I assume, that something went wrong with my installation or anything else with my hosting solution or I'm missing out on some additional information.

    So any help is highly appreciated.

    PHP Version : 5.2.12-nmm4

    Thanks

    J

    http://wordpress.org/extend/plugins/wordpress-backup-to-dropbox/

  2. Michael De Wildt
    Member
    Plugin Author

    Posted 1 year ago #

    I would set it to 766 rather then 777 so that only the 'user' can execute from within the backup dir.

  3. SomeUser2012
    Member
    Posted 1 year ago #

    Hi Michael,

    thanks for your quick response, but unfortunately it didn't resolve my problem.

    I've already tried that as well and 766 still throws the above mentioned error message on the "backup settings"-page.

    However with 766 I'm able to see the "backup now"-page and start the backup process manually, by clicking on the "start backup"-button.

    But when doing so, it just shows the message

    "Your backup has been scheduled and is waiting for WordPress to start it. This could take a few minutes, so now is a good time to go and grab a cup of coffee."

    but it doesn't start the process.

    Also, while in this state I click on the Backup settings or premium extensions page and go back to the backup now page and it says:

    "No backup in progess." again.

    Just for the record, when using 777 everything works perfectly fine, it creates a perfect backup in my dropbox folder including the database dump...

    Did anyone else have experienced those problems on WordPress 3.4.1 ?

    Any other ideas?

  4. SomeUser2012
    Member
    Posted 1 year ago #

    Oh and when I change it to 777 again, after trying to start a backup with 766, I can see the backup settings page again and get this error message:

    Backup-Fehler am 2012-06-29 um 08:22:10: Exception - Fehler beim Erzeugen der SQL-Dump-Datei. (ERROR_2)
    Backup gestartet am 2012-06-29 um 08:22:05

    means "error creating the SQL-Dump-file"

  5. Michael De Wildt
    Member
    Plugin Author

    Posted 1 year ago #

    Id say the new issue is to do with PHP file permission caching. So it should fix itself over time.

    I will investigate why you need 777.

  6. SomeUser2012
    Member
    Posted 1 year ago #

    Ok I got it resolved...

    I've spoken to my webhoster and they suggested changing the owner of the folder backups from ftp-user to php-user through their webftp interface (using chown).

    Now it runs like a charm with 755.

  7. SomeUser2012
    Member
    Posted 1 year ago #

    closing topic ;-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic