WordPress.org

Ready to get started?Download WordPress

Forums

WordPress-Amazon-Associate
[resolved] uto-update failure (16 posts)

  1. redcocker
    Member
    Posted 2 years ago #

    Hi,

    After Auto-update to 1.7.0, I got a following error and WordPress-Amazon-Associate can't work.

    Fatal error: Call to undefined function wp_get_current_user() in /home/users/1/xxx.jp-xxx/web/xxxt/blog/wp-includes/capabilities.php on line 1039

    The following messages are errors I got in Dashboard when auto-update.

    Warning: fopen(/home/users/1/xxx.jp-xxx/web/xxxt/blog/wp-content/plugins/wordpress-amazon-associate/wordpress_amazon_associate.php) [function.fopen]: failed to open stream: No such file or directory in /home/users/1/xxx.jp-xxx/web/xxxt/blog/wp-includes/functions.php on line 4339
    Warning: fread(): supplied argument is not a valid stream resource in /home/users/1/xxx.jp-xxx/web/xxxt/blog/wp-includes/functions.php on line 4342
    Warning: fclose(): supplied argument is not a valid stream resource in /home/users/1/xxx.jp-xxx/web/xxxt/blog/wp-includes/functions.php on line 4345

    I re-installed ver. 1.6.1 and tried to auto-update again.
    But I got same errors.

    Without auto-update, After I ftp WordPress-Amazon-Associate's files into my wordpress plugin directory, WordPress-Amazon-Associate can work.

    My wordpress is ver. 3.2

    Thank you.

    http://wordpress.org/extend/plugins/wordpress-amazon-associate/

  2. akinschris
    Member
    Posted 2 years ago #

    Have the same problem on my site as well - acstrategy.com.

  3. Temlakos
    Member
    Posted 2 years ago #

    That's what happened to me. Now where do I go to get Version 1.6.1? My site is totally down.

  4. Matthew Denton
    Member
    Plugin Author

    Posted 2 years ago #

    Hi everyone, Looking at the above error message I'm not sure why the install is failing as it looks like it was not able to download one of the files in the plugin. I re-uploaded the latest file and did the auto-update on a few of my sites all without issue.

  5. Temlakos
    Member
    Posted 2 years ago #

    The resolution:

    require_once('pluggable.php')

    Add this line to the file wp-includes/capabilities.php. Add it directly after the initial comments and before the first class definition.

    WordPress needs to get on this right away. How many other plugins are going to crash WordPress in just that way? This was an accident waiting to happen.

  6. johanhburger
    Member
    Posted 2 years ago #

    Hi there, I have exactly the same problem. To add insult to injury, my site is down and I cannot get access to remove the plugin. Can someone give me a blow by blow process of what to do? Big please!

  7. redcocker
    Member
    Posted 2 years ago #

    Hi johanhburger san,

    Using FTP, Delete "/wp-content/plugins/wordpress-amazon-associate/wordpress_amazon_associate.php" file

    or whole "wordpress-amazon-associate" directory.

    If you change plugin directory, "wordpress_amazon_associate.php" will be found in other directory.

  8. Yudhi Karunia Sutan
    Member
    Posted 2 years ago #

    I tried to restore database from my backup but didn't help at all.
    Then i try to delete the plugin folder under $WP_HOME/wp-content-plugins/wordpress-amazon-associate).
    Now my website is possible to be access again.
    The update is not good.. gladly..

  9. gatorbob
    Member
    Posted 2 years ago #

    Yep, broke my entire site too. Took me a few minutes to figure out after I realized site was down. Geez.

  10. djeyewater
    Member
    Posted 2 years ago #

    I followed Temlakos advice, except rather than edit a core file I edited the plugin file and added:
    require_once(ABSPATH . WPINC . '/pluggable.php');

  11. sojyujai
    Member
    Posted 2 years ago #

    Thanks djeyewater,
    I was about to post that Temlakos solution works if you change the line to:
    require_once('pluggable.php');

    but your method for modifying wordpress_amazon_associate.php instead of a core file seems like a better solution.

  12. parisvega
    Member
    Posted 2 years ago #

    Awesome. Thanks guys. Problem solved after added require_once(ABSPATH . WPINC . '/pluggable.php'); to wordpress_amazon_associate.php

  13. joespake
    Member
    Posted 2 years ago #

    I uninstalled the plugin. How long will it take WP/Amazon to resolve this issue so I can download it safely again?

  14. Matthew Denton
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Everyone, sorry for the problems this caused. It appears that the issue is hit or miss for different users and I can't pin down what is different for everyone's installs.

    I have just released version 1.7.1 in it I do a manual check for if the wp_get_current_user function exists and if not then the Admin Localization (logged in administrators can view site as a selected locale) will not function.

    Again sorry for the issues this caused!

    > Matthew

  15. redcocker
    Member
    Posted 2 years ago #

    Hi mdbitz san,

    Thanks

    When Auto-update to 1.7.1, I got no errors.

  16. pixelnated
    Member
    Posted 2 years ago #

    thanks djeyewater & mdbitz

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic