WordPress.org

Ready to get started?Download WordPress

Forums

WordPress-Amazon-Associate
[resolved] Plugin reporting AWS keys as Invalid? (17 posts)

  1. futurepocket
    Member
    Posted 1 year ago #

    I just recently signed up for an Amazon associates program and an AWS account but when I try to enter my access key and secret key, it gives me this error:

    Code: InternalError
    
    Message:
    We encountered an internal error. Please try again.

    Am I inputting the wrong key ... because I'm putting the ACCESS KEY ID and have to click on SHOW to reveal the SECRET ACCESS KEY. I'm copying and pasting exactly what's there, but still not working. Any ideas please?

    http://wordpress.org/extend/plugins/wordpress-amazon-associate/

  2. hiddentao
    Member
    Posted 1 year ago #

    Yep, I'm having the same problem.

  3. hiddentao
    Member
    Posted 1 year ago #

    This error is coming from Amazon. It might be that the plugin is sending over the credentials incorrectly.

  4. sdeezy
    Member
    Posted 1 year ago #

    same here, glad it's not just me

  5. sophiehinh
    Member
    Posted 1 year ago #

    me too.. tried to authenticate by other plugins, also cant. Can any expert advise?

  6. sophiehinh
    Member
    Posted 1 year ago #

    wow guys, our bad! the plugin as claimed is only compatible up to WP version 3.3.2. I downloaded and tested with 3.3.2 and it works!

    I guess you guys just like me downloaded the latest WP version.

    Cheers!

  7. sophiehinh
    Member
    Posted 1 year ago #

    now everything works, even with the latest version of WP

  8. sdeezy
    Member
    Posted 1 year ago #

    It's working for you with 3.4.1 now too? I'm still getting the error

  9. jazzybeat28
    Member
    Posted 1 year ago #

    I have the same problem. But I also have few other amazon related plugins and the yall not working. I'm 100% its amazon doing simething strange lattely. I contacted amazon customer to see if they can comments on this problem.

  10. binki
    Member
    Posted 1 year ago #

    I am experiencing the same problem. I'm not willing to downgrade from 3.4.1 to see if that will help, so I wonder when this will fix itself or if the plugins will need to be updated....

  11. peter.smith
    Member
    Posted 1 year ago #

    Hi, I finally find a solution for this problem
    Invalid key - how to fix this.

  12. Matthew Denton
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Everyone,

    As an FYI this issue is tied directly to Amazon. Multiple users have had this issue and unfortunately there is no confirmed method of making the issue go away.

    The scratchpad that Amazon has created is definitely a useful too. thanks for that link Peter.

  13. hellrazaa
    Member
    Posted 1 year ago #

    yup that worked flawlessly

  14. binki
    Member
    Posted 1 year ago #

    Even though amazon's error doesn't give much information as to why the user is unable to use the API, maybe the plugin could be updated to suggest to the user that he may need to sign the usage agreement when it gets this "InternalError". That would be awesome.

  15. Matthew Denton
    Member
    Plugin Author

    Posted 1 year ago #

    Hi:

    Thanks for the suggestion. I'm adding an additional message into the to-be-released version that includes a prompt to sign-up for the Amazon Product Advertising API so that the AWS keys validate correctly.

    For anyone who still experiences this issue please visit the Amazon Sign-In Page and follow instructions to enable your account.

  16. jazzybeat28
    Member
    Posted 1 year ago #

    From what I understund only root access key and secret key works with this plugin. If use AWS Management Console to create new users and assign permisions even admin this will not work. Can some one confirm this.

    And yes some kind of notification for login erorr would be great, because there is no way to know if it works or not.

  17. Matthew Denton
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the suggestion. As of version 2.0.0 there additional help text in the error message that directs users on how to resolve.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.