WordPress.org

Ready to get started?Download WordPress

Forums

WordPress-Amazon-Associate
[resolved] Nothing in the content of a post (26 posts)

  1. freemind369
    Member
    Posted 3 years ago #

    Only the textlinks are working with a preview. The other options do not work

  2. Matthew Denton
    Member
    Plugin Author

    Posted 3 years ago #

    Hi, i'm going to need a little more information on what the issue is you are having? Are you saying widgets etc are not working or?

  3. Lumpysimon
    Member
    Posted 3 years ago #

    hi

    i'm having the same issue: i'm inserting a product link into a post (ISBN 000728487X). if i select 'text' as the link type, i get a working link to the correct product on amazon.

    if i select enhanced, i see nothing. my source code shows an iframe containing empty head and body tags.

    the search widget is also returning no results whatever i search for.

    i have a .co.uk associate ID, all other locales deactivated, AWS credentials are valid, product reviews enabled.

    thanks
    simon

  4. chassegnouf
    Member
    Posted 3 years ago #

    It's the same thing for me :/

  5. Matthew Denton
    Member
    Plugin Author

    Posted 3 years ago #

    Simon:

    Can you send me the exact content of your post. I followed the procedure you outlined above and I see the content for "Bad Science". I'll test out some more scenarios in the mean time.

    > Matthew

  6. Lumpysimon
    Member
    Posted 3 years ago #

    hi matthew

    sorry i was being dim and hadn't disabled adblock plus for my development site, it's now showing as expected.

    maybe it's worth putting a note in the FAQ that adblock browser extensions will hide the enhanced links?

    cheers
    simon

  7. Twinkling82
    Member
    Posted 3 years ago #

    Hi Matthew,

    If I chose to show a picture(coverart) with link to the product, it shows this code in my post:

    [amazon_image id="XXXXXXX" link="true" target="_blank" size="medium" ]Name of the game[/amazon_image]

    and in the published post just shows "Name of the game" text.

    What's the issue here? I live in Denmark, and expect it to show for me, taking me tot he UK based site.

    Any help is appreciated. Thanks for a great plugin.

  8. Matthew Denton
    Member
    Plugin Author

    Posted 3 years ago #

    Hi:

    The issue with the above ShortCode is the product id. In the code you have id="XXXXXXX" which is an invalid Product code and why only the text is being displayed. Did a quick search and I'm not sure which exact product you are looking for but possible product id is B00006L9R6.

    Was the above XXXX value generated by the plugin?

  9. Twinkling82
    Member
    Posted 3 years ago #

    I changed the XXXX and the Text shown part for this post. I used the search function to find the right product.

  10. Twinkling82
    Member
    Posted 3 years ago #

    Also, I've doublechecked; Adblock is disabled on my site, and the links only code doesn't work either.

    Maybe I haven't properly installed the plugin?
    Or maybe there's another plugin that interferes?

  11. Twinkling82
    Member
    Posted 3 years ago #

    I think I've found the problem. I need to use the videogames category, and I can add everything else (I tried with a book and that worked splendid) but for the DARN of it, it won't add a videogame (I tried two different games)

    A while back amazon decided to make a videogames category, extract games from music and DVD's.

    The enhanced link shows a banner for the music and dvd's category, btw.

    I've used so many hours with this problem, and it never occurred to me it could be something like this...

  12. Matthew Denton
    Member
    Plugin Author

    Posted 3 years ago #

    HI can you send me the website address and the exact ShortCode that is in the page content currently? You can send it to my email address matt(at)mdbitz.com and i'll run them on my local instance to see if there could be an configuration issues.

    ~ Matthew

  13. Twinkling82
    Member
    Posted 3 years ago #

    I made a whole testpage, just for you my friend ;)

    http://gamingirl.com/testsite-for-amazon-associate-plugin/

    Everything is made with the plugin, but here goes;

    As you'll see, text and image links converts to simple text, no link at all. Enhanced links converts to a banner fpor the old category, music and DVD's.

    Following is text, image and enhanced link for Red Faction: Armageddon, videogame.

    The x360 version;
    [amazon_link id="B003P9C6QY" target="_blank" ]Red Faction Armageddon[/amazon_link]
    [amazon_image id="B003P9C6QY" link="true" target="_blank" size="medium" ]Red Faction Armageddon[/amazon_image]
    [amazon_enhanced asin="B003P9C6QY" /]

    Ps3 version;
    [amazon_link id="B003P9FRGA" target="_blank" ]Red Faction Armageddon[/amazon_link]
    [amazon_image id="B003P9FRGA" link="true" target="_blank" size="medium" ]Red Faction Armageddon[/amazon_image]
    [amazon_enhanced asin="B003P9FRGA" /]

    PC version;
    [amazon_link id="B003P9C6EQ" target="_blank" ]Red Faction Armageddon[/amazon_link]
    [amazon_image id="B003P9C6EQ" link="true" target="_blank" size="medium" ]Red Faction Armageddon[/amazon_image]
    [amazon_enhanced asin="B003P9C6EQ" /]

    Now we try with some other games.

    Batman: Arkham Asylum, image link
    [amazon_image id="B003C1I06U" link="true" target="_blank" size="medium" ]Batman Arkham Asylum: Game of the Year Greatest Hits[/amazon_image]

    Fantastic Pets, link only
    [amazon_link id="B004FEJ8ZA" target="_blank" ]Fantastic Pets[/amazon_link]

    Kinectimals, enhanced link
    [amazon_enhanced asin="B002I0J8RQ" /]

    Now let's try with something from other categories!

    Jean M. Auel, The Valley of Horses, enhanced
    [amazon_enhanced asin="0553381660" /]

    The Mommoth Hunters, link only
    [amazon_link id="0553381644" target="_blank" ]The Mammoth Hunters (Earth's Children, Book Three)[/amazon_link]

    Land of painted caves: A novel, image link
    [amazon_image id="0517580519" link="true" target="_blank" size="medium" ]The Land of Painted Caves: A Novel (Earth's Children)[/amazon_image]

    Automotives category doesn't work either
    A steering wheel cover of some sort, enhanced
    [amazon_enhanced asin="B000IXSF42" /]

    A Chevy key chain, link only
    [amazon_link id="B00029X2N6" target="_blank" ]Pilot KC011 Chrome Key Chain - Chevrolet[/amazon_link]

    Harry Potter DVD's, image link
    [amazon_image id="B001UV4XHY" link="true" target="_blank" size="medium" ]Harry Potter and the Deathly Hallows, Part 1[/amazon_image]
    [amazon_image id="B001UV4XI8" link="true" target="_blank" size="medium" ]Harry Potter and the Deathly Hallows, Part 1 (Three-Disc Blu-ray / DVD Combo + Digital Copy)[/amazon_image]
    [amazon_image id="B002PMV9FG" link="true" target="_blank" size="medium" ]Harry Potter and the Half-Blood Prince (Widescreen Edition)[/amazon_image]

    An LG TV, enhanced link
    [amazon_enhanced asin="B0039RWAVS" /]

  14. Twinkling82
    Member
    Posted 3 years ago #

    Okay so I've discovered something new.

    This plugin interferes with all the fancybox plugins when the "product preview" is enabled. Pictures opens just fine, but doesn't change picture when clicking on previous or next, it just resizes the picture if the other picture is another size. Also can't open up youtube videoes either - both will make and uncloseable overlay.

    And I've noticed that the plugin deletes my amazon names, replacing them with the standard ones. Is this possible to correct once and for all?

  15. Matthew Denton
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,

    1) I accessed he test page and I am seeing the links, images and enhanced ads function as expected with showing the proper Amazon Links, Product Image, and Enhanced Ads.

    What browser are you using to access the sites and what plugins/modifications do you have set on the browser. As I am able to see the correct page output as shown in the below source snipet (I forget if WordPress removes the tags if so I'll update them shortly).

    2) If you go into the WP - Amazon > Settings page you can specify your Amazon Associate Id in the United States input box within the "Amazon Associate Settings edit box. This will make it so the links have your associate id.

    3) From the source page I see you are using the easy-fancybox plugin. I'll take a look at it's setup to make the plugins compatible. In the mean time you can simply disable Product Preview in the WP - Amazon > Settings page.

    [Code moderated as per the Forum Rules. Please use the pastebin]

  16. Matthew Denton
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,

    Reviewed the plugin and Amazon's Product Preview logic is incompatible with the easy-fancybox plugin. The Product Preview code comes directly from Amazon and as such currently you will not be able to use Product Preview on your website.

  17. Twinkling82
    Member
    Posted 3 years ago #

    1) Damn, I didn't think of testing in another browser. When it worked with some, but not all, I expected it to be a problem with the categories. Firefox shows fine, Chrome is fucked with some categories.
    I tried to deactivate all plugins in Chrome, no difference.

    2) I've done this. Now multiple times.I've signed up to all the associate sites, not china and japan though (I don't get readers from there anyway) and I've specified my ID's in each and every single of them, saved the settings, but the plugin keeps deleting what I've saved. I'll try once again.

    3) Yes, I did that in a heartbeat, didn't really need this feature anyway.

  18. Matthew Denton
    Member
    Plugin Author

    Posted 3 years ago #

    Hi:

    I just tested the test page in IE8, Safari, Firefox and Chrome I see the test page rendered correctly in all browsers. Unfortunately you are the only person that has had an issue with the plugin settings not saving, can you let me know what server settings you have as this is not an issue with the plugin code itself. What other plugins are you using.

  19. Twinkling82
    Member
    Posted 3 years ago #

    This is how it shows for me.

    It does it with Videogames and automotives categories. Books works fine. Chrome, tried with all chrome plugins disabled.

    Plugins for wordpress or chrome? :)

  20. Matthew Denton
    Member
    Plugin Author

    Posted 3 years ago #

    Strange, I'm not sure why your instance of chrome would not be showing the links/image/enhanced ads correctly it is HTML and should be rendered correctly.

    As far as why your settings are not being saved to debug I'd need to know what WordPress plugins and Server configuration you have to determine if there is some conflict.

  21. Twinkling82
    Member
    Posted 3 years ago #

    I'm running W3 Total Cache, and this is the only one that I suspect. I'll let you know if it keeps changing the ID's and I will test the different plugins off as well.

    I'm running Chrome 12.0.742.100, did you test with that version? I've had problems with windows live calendar with this version of chrome.

  22. Twinkling82
    Member
    Posted 3 years ago #

    Hi Matthew,

    The problem persists with the links and pictures not showing correctly. How does it shows for you?

  23. Matthew Denton
    Member
    Plugin Author

    Posted 3 years ago #

    Hi, I've done some in depth review and have found the underlying issue. For the majority of the products they don't exist in the UK locale with the given ASIN. To correct you can update the WPAA settings with United States as the Primary locale this will make it so if the products aren't found in the UK locale they will default to the US locale where the products do exist.

    ~ Matthew

  24. Twinkling82
    Member
    Posted 3 years ago #

    I guess it's because the games have different region codes, thus they assigned different ASIN codes.

    I just checked, and the settings say that US is my primary one.

  25. Matthew Denton
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Again:

    I've been working on the next version of the plugin and as part of the updates I've added an option for administrators to view the website as a specified locale. This addition allowed me to view the content as you saw it rendered.

    As it turns out there was a bug in the APaPi library that is used within the plugin. When the plugin checked if the request to amazon was successful it was incorrectly getting success when in fact an error had occurred (e.g. product doesn't exist). I've since made the appropriate changes to fix this and the next version will resolve the issue.

    I'm currently debating if I'll release a bug release for this fix or if I'll wait until I've completed all changes. Either way the next update will resolve the issue.

  26. Twinkling82
    Member
    Posted 3 years ago #

    Thanks! I have time enough on my hands, so don't rush it because of me. :)

    Keep me updated though, as I want to use this plugin when it's solved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic