WordPress.org

Ready to get started?Download WordPress

Forums

Wordfence Security
[resolved] Temporary glitch - notified to developer - Some Host Scanners blocking (7 posts)

  1. goodwisj
    Member
    Posted 1 year ago #

    Doesn't seem to relate to the version of WP however changes in WordFence are being picked up as Malware - in some cases hosting providers have quarantined files and 'broken' the sites and in others they have warned of the perceived problem only.

    The problem has been brought to Mark's attention and is documented on the WordFence forum as well.

    With Feedjit's track record for turning around solutions, this should be a short-lived glitch.

    http://wordpress.org/extend/plugins/wordfence/

  2. goodwisj
    Member
    Posted 1 year ago #

    Contact from the developer confirms that there is action on resolving this issue and that there will shortly be an emergency release to fix this problem.

  3. goodwisj
    Member
    Posted 1 year ago #

  4. goodwisj
    Member
    Posted 1 year ago #

    New release superquick to resolve these issues.... Can be closed soon....

  5. Wordfence
    Member
    Plugin Author

    Posted 1 year ago #

    This is now resolved. Thanks Steve for keeping this forum updated.

    Please upgrade to 3.2.5 which resolves the issue of one of Wordfence's files being detected by some hosts as problematic and quarantined.

    The resolution was as follows:

    lib/wordfenceScanner.php was being detected as containing malicious code and site owners were either being alerted, or in some cases, very aggressive hosting companies would simply delete or quarantine the file which would cause Wordfence to break.

    We have moved anything in Wordfence and in that file that could be detected as a false positive onto our scanning servers and that data is now loaded dynamically at run-time. This prevents our files from being detected as a false positive.

    Please upgrade to 3.2.5 which resolves this issue.

    Thanks,

    Mark.

  6. waynmeyer
    Member
    Posted 1 year ago #

    Hi im unable to get the free plugin api, i have tested the http://example.com/wp-content/plugins/wordfence/wfscan.php link and everything
    works fine. however my error logs say

    [Sep 01 08:12:43] Contacting Wordfence to initiate scan
    [Sep 01 08:12:43] curl_exec() has been disabled for security reasons (2) File: /var/www/vhosts/example.co.za/httpdocs/wp-content/plugins/wordfence/lib/wfAPI.php Line: 58
    [Sep 01 08:12:43] Scan terminated with error: We received an error response when trying to contact the Wordfence scanning servers. The HTTP status code was [0]
    [Sep 01 10:33:20] Contacting Wordfence to initiate scan
    [Sep 01 10:33:20] curl_exec() has been disabled for security reasons (2) File: /var/www/vhosts/example.co.za/httpdocs/wp-content/plugins/wordfence/lib/wfAPI.php Line: 58
    [Sep 01 10:33:20] Scan terminated with error: We received an error response when trying to contact the Wordfence scanning servers. The HTTP status code was [0]

    how could i fix this?

    any help is greatly appreciated. i would also like to know how this differs from the bulletproof plugin? i have tried the bulletproof plugin however i was not impressed with it. On the other hand i see loads of potential in the wordfense.. only problem is dont know if wordfence protects sql injections ect?

  7. Wordfence
    Member
    Plugin Author

    Posted 1 year ago #

    Duplicate post. See my response in the other thread.

    Regards,

    Mark.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.