WordPress.org

Ready to get started?Download WordPress

Forums

Wordfence Security
[resolved] Running out of memory on security scan (14 posts)

  1. houseofstrauss
    Member
    Posted 2 years ago #

    On a test site with shared hosting, the scan is running out of memory and causing a fatal error and not completing. I've set the memory limit to 60mb that's below my servers 67mb limit, but it still fails to complete a scan. No problems on my VPS, or course.

    Is there any way (except increasing allowable memory on server) to resolve This please?

    http://wordpress.org/extend/plugins/wordfence/

  2. Wordfence
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    I've just released 2.1.5 which has a memory fix which may resolve this issue. Please upgrade and let me know if you're still experiencing this problem.

    Thanks,

    Mark.

  3. houseofstrauss
    Member
    Posted 2 years ago #

    Just installed and tried 2.1.5 Unfortunately I still get this error Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 72 bytes) that stops the scan some way through . Ive set the memory limit to 25mb in the options, as my wordpress is using 34mb on a 64mb php memory limit on the server. Any advice?

  4. houseofstrauss
    Member
    Posted 2 years ago #

    Mark, There is a plugin DB error reported after a scan referenced in wflog. I don't want to post it here, as this is a security plugin. Do you have a email address?

  5. Wordfence
    Member
    Plugin Author

    Posted 2 years ago #

    Yes my email is mark@wordfence.com.

    That memory error is something we're working on right now. The next release of WF will be significantly more memory efficient. It will be out very soon.

    Mark.

  6. houseofstrauss
    Member
    Posted 2 years ago #

    Thanks for the latest version. Noticed quite a few changes to tables and processes. Any upgrade instructions please 2.1.5 to latest.

  7. Wordfence
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    Version 3+ of Wordfence is a significant change in the way Wordfence works which makes it extremely memory efficient.

    You should simply be able to upgrade using the usual procedure and Wordfence will update itself.

    Regards,

    Mark.

  8. vishal
    Member
    Posted 1 year ago #

    Hi Mark,

    I am new to wordfence but really liked the kind of job it does. But memory fatal errors are ruining all the fun. Please fix it as soon as possible. It seems to be the only glitch till now.

    KR
    Vishal

  9. pengo
    Member
    Posted 1 year ago #

    I've just installed Wordfence on my hosted WordPress site which has a 64MB memory limit.

    Wordfence scans consistently fail with an "Allowed memory size of 67108864 bytes exhausted" error. If I remove Wordfence options, I can get 1300 files into the scan, but ultimately everything always grinds to a halt with this error.

    This is potentially a great tool and I'd be happy to upgrade to the paid version ... but first it needs to work on my installation. Any advice gratefully received.

  10. TedSwiss
    Member
    Posted 1 year ago #

    Hello,

    Same kind of error with the last version, did the developer found a tweak to avoid such error?

  11. pengo
    Member
    Posted 1 year ago #

    This still doesn't seem to be a plugin that works consistently in a shared hosting environment.

  12. sleeplessinDC
    Member
    Posted 1 year ago #

    I am getting the same problem: "Fatal error: Allowed memory size of 94371840 bytes exhausted (tried to allocate 3320317 bytes) in /home/xxxx/xxxx/xxxx/wp-includes/wp-db.php on line 885"

    I am in a shared hosting environment using Dreamhost so I don't have access to the php.ini file and tried allocating more memory in the wp.config file:

    /** Allow more than default memory allocation: Default is 90. */
    define('WP_MEMORY_LIMIT','128M');

    but this hasn't helped.

    Is there something else we can try or is there a fix for this coming up in the plugin?

  13. dynamitemarketing
    Member
    Posted 1 year ago #

    Im getting the same error. My memory has always been set to 300mb and I get this error.

    Its causing too many problems with my site I have to let it go until the developer fixes the issue. Dam.

  14. aisajib
    Member
    Posted 1 year ago #

    @ dynamitemarketing,

    Good luck letting it go. The plugin author does not seem to be responding to anything and I'm still having issues even after uninstalling it months ago!

    http://wordpress.org/support/topic/getting-db-error-even-after-removing-the-plugin?replies=1

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic