WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
[resolved] [Plugin: WooCommerce] Woocommerce Pretty Permalinks (19 posts)

  1. GoElemental
    Member
    Posted 2 years ago #

    I am hoping to get some help with my permalink setup in woocommerce.

    I typically use the 'pretty' permalink structure of /%postname%/, but this breaks my catalog setup and returns a 404 error. I have even tried combinations such as /%category%/%postname%/, /page/%postname%/etc. but nothing works.

    When i set my permalinks to the WP default, the catalog works perfectly, but my other non-catalog pages, such as 'Company Info' and 'Contact Us' have the crappy permalink [hxxp://mysite.com/?p=123] which looks horrible and is even worse for SEO.

    I would ultimately like my site structure as follows:
    For my catalog: hxxp://mysite.com/mens/pants/bushmaster-cargo-pants (not too picky about this URL structure)
    For my static pages: hxxp://mysite.com/company-profile (MUST have 'pretty' permalink)

    I am using WP 3.2.1 (until the theme dev updates for 3.3 compatibility) and Woocommerce 1.3.2.1

    I also have Yoast WordPress SEO v.1.1.2 and WooCommerce - All in One SEO Pack 1.1 installed.
    Tried the 'Canonical URL' setting under the 'Advanced' tab in Yoast, still no luck.

    Any help would be most appreciated. Have a great day.

    http://wordpress.org/extend/plugins/woocommerce/

  2. owcv
    Member
    Posted 2 years ago #

    I don't know exactly if we have the same issue, but since I upgraded to the new WooCommerce-version my product-category links are broken. I had this error before:
    http://wordpress.org/support/topic/plugin-woocommerce-ecommerce-plugin-for-wordpress-category-view-is-broken

  3. blogtj
    Member
    Posted 2 years ago #

    hi,
    i have the same problem.

    I activate the permalinks from woocomerce, i activate permalinks from wordpress and when i go to a product the url is changed with a nice link, but i get 404 error.

    Everything else from wordpress is working....

    What to do?

    Thank you,
    tj

  4. Ampix0
    Member
    Posted 2 years ago #

    I made a thread about the exact same thing earlier today. I emailed Woocommerce and they.. don't seem incredibly interested to fix the issue. I really need to do this for SEO reasons. I have a blog on my site as well and the url should be "/blog" but I can't obviously.

  5. Ampix0
    Member
    Posted 2 years ago #

    Guys. please comment on vote here. Let woocommerce know we need this.

    http://woo.uservoice.com/forums/133476-woocommerce/suggestions/2560413-we-need-support-for-pretty-permalinks

  6. blogtj
    Member
    Posted 2 years ago #

    Hi guys, i fixed it.
    When you activate permalinks, to work this, you need to be sure that in .htaccess file are these lines:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Good Luck!

  7. Ampix0
    Member
    Posted 2 years ago #

    EDIT: nvm this does not work

  8. Ampix0
    Member
    Posted 2 years ago #

    whoah looks like I lied. my cashe just wasn't updated. Adding that will not fix the issue.

  9. Ampix0
    Member
    Posted 2 years ago #

    The admin of woocommerce just declined the vite saying they do support pretty permalinks.. even though all of us are having the issue

  10. Ampix0
    Member
    Posted 2 years ago #

    I added the modual provided by WordPress to my .htaccess file. It makes no sense.

    The blog and posts show up fine. When you look at products at the shop they 404. and if you go to edit the products, and click "view" it will link you straight to the 404

  11. GoElemental
    Member
    Posted 2 years ago #

    I was able to get it working with the following settings:

    htaccess - I did not modify that file at all.
    Wordpress Permalink Settings - custom structure > /%category%/
    Woocommerce - Settings > Pages Tab > Permalinks > Product base page > Prepend product permalinks with product category *TICKED*

    Currently the site is WP 3.2.1 and Woocommerce 1.3.2.1
    The theme I am using was recently upgraded for WP 3.3.x and Woocommerce has released WooCommerce 1.4
    Not sure if things will go blooey when I upgrade but I will report back once I give it a shot.

    Good luck everyone.

  12. Ampix0
    Member
    Posted 2 years ago #

    Finally a working answer. Fantastic work. Thank you so much.

  13. tabouziane
    Member
    Posted 2 years ago #

    I'm trying to do a eCommerce website using WooCommerce plugin (Version 1.4.2) and WordPress (Version 3.3.1). But my permalinks are not working at all. --> http://www.fillettesetfistons.com/

    If you click on the Categories (sidebar) it gives me a "No products found which match your selection." even if there is a product inside of that category.

    Can someone help me?

    Thanks!

  14. cwendt01
    Member
    Posted 2 years ago #

    I'm having the exact same problem as everyone above and GoElemental's solution didn't work for me either... I've tried updating my htaccess a couple different ways and nothing's helped.

    Using WP 3.3.2, WooCommerce 1.5.4, and Wootique 1.3.1.

  15. designwrench
    Member
    Posted 2 years ago #

    Thank you GoElemental — totally fixed my 404 problem!

  16. Ifraz
    Member
    Posted 1 year ago #

    Another big big Thank you to GoElemental - upgraded Woocommerce and it totally threw out all of the products with a 404 error. The sheer panic was only relieved by following GoElemental's advice step by step.

    Phew, sanity restored!

  17. Murray644
    Member
    Posted 1 year ago #

    Thank you GoElemental worked perfectly!!!!!

  18. alexandrafarmer
    Member
    Posted 1 year ago #

    It worked for me:

    01. WordPress Permalink Settings - custom structure > /%postname%/

    02. Woocommerce - Settings > Pages Tab > Permalinks > Product base page > Prepend product permalinks with product category *CHECKED*

    Thanks GoElemental!

  19. wshunter
    Member
    Posted 1 year ago #

    GoElemental
    Thanks!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic