WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Woocommerce] Tabs Not Working (14 posts)

  1. bolivares
    Member
    Posted 1 year ago #

    So I'm not sure what I did to mess this up because I haven't been able to trace back to the source of this issue that just popped up, but the tabs on the single product page are messing up. Instead of having them actually function like tabs, both the description and reviews panel are visible at once and clicking on the tab only brings you down to the anchor on top of the panel.

    You can view the issue here:
    http://www.coreytegeler.com/bolivares/shop/salvador-crewneck-sweater-copy/

    anyone know how I can resolve this?

  2. websitevala
    Member
    Posted 1 year ago #

    same problem here please found solution for this
    i try all things but can't get success
    please help ASAP

  3. bolivares
    Member
    Posted 1 year ago #

    Have you been able to resolve this yet?

  4. PagePlusCA
    Member
    Posted 1 year ago #

    Very interested in seeing a fix for this. Got the same thing going on past 1.6.6

  5. ridclubmba
    Member
    Posted 1 year ago #

    same problem here... is there a fix?

  6. PagePlusCA
    Member
    Posted 1 year ago #

    Downgraded to 1.6.6 so now it looks fine but it was quite the hassle.

  7. bolivares
    Member
    Posted 1 year ago #

    1.6.6 of WooCommerce? Does that lead to any issues?

  8. murphaluza
    Member
    Posted 1 year ago #

    I also have the same issue, are there any solutions to this yet?

  9. lms528
    Member
    Posted 1 year ago #

    haha so I think I am going to be your new favorite person. Just spent two days on this beast. Not sure this will fix everyone's problem, but is a really silly issue:

    It appears the tabbed content container in newer woocommerce has a class of 'woocommerce-tabs' whereas in older version it was 'woocommerce_tabs'.

    I just went in and changed the class to have the underscore and my tabs are working now. The content is a little out of place I'm going to do a quick css fix cause I am good with css, but if you let your theme developers know, it seems a lot of themes are using the old class for the tabbed content, so when it is not targeting it properly. Should be an easy fix for most people, I do not have time to point to all files, but here is where you can find the base file for the tabbed content container:

    line 287 : wp-content/plugins/woocommerce/templates/single-product/tabs/tabs.php

    Hope this helps, I am usually the one looking these issues up not posting the fixes.

  10. bolivares
    Member
    Posted 1 year ago #

    Thanks a bunch for all of the help!!!!! So shouldn't I be changing everything to match the current version instead of moving backwards?

  11. lms528
    Member
    Posted 1 year ago #

    I went through and updated everything in my child theme that used the old ID, so I can still update my main theme and woocommerce plugin and it the tabs won't go screwy again. If you don't have a child theme, then yes you would want to update your theme to be accurate with new version of woocommerce, hopefully theme devs will get this fixed soon.

  12. Teresa Rosche Ott
    Member
    Posted 1 year ago #

    Thanks to the previous posters on this thread for quickly pointing me in the right direction; I haven't used WooCommerce much and appreciated the head start.

    A client updated her site yesterday and introduced the glitch with the misnamed class. I am surprised that the issue is two months old and a fix hasn't been released yet.

    I thought about fixing it via her theme's CSS, but didn't want to introduce lingering classes/markup if a later WooCommerce update changed things, so I edited the tabs.php file mentioned above. Instead of just changing the class name, however, I added the woocommerce_tabs class so that the element would have both. Seems to have done the trick without necessitating a whole lot of CSS tweaks.

    Hope this helps someone.

  13. hamutalwz
    Member
    Posted 11 months ago #

    I had the same problem and not because of the tabs class but because I activated the W3 Total Cache plugin.
    not sure exactly what it did but something in the settings of this plugin interferes with the tabs behavior.

  14. capcaunu
    Member
    Posted 5 months ago #

    I have NO idea why Woocommerce got so popular. Their developers just want to confuse the heck out of people, so they pay for support. You have to pay to get access to the forum. My client already uses it, so I have no choice but to deal with their shit, but I will be sure to warn everybody about this awful product in the future.

Topic Closed

This topic has been closed to new replies.

About this Topic