WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
Shopping Cart Empty (10 posts)

  1. nkpromotions
    Member
    Posted 1 year ago #

    In testing the site http://www.sistersnetworking.com I add an item to the shopping cart, get the message that it was successfully added. But when I go to check the shopping cart it says that my cart is empty.

    I checked and all extensions are up to date.

    I can't find the woocommerce > system status page that woo support tells me to look at (but it's been 2+ weeks now, could it really be the system status?)

    Any ideas on where I can start? WooCommerce Support took four days to answer my first question. I can't wait another 4 days for them to answer my follow up.

    Thanks.

    http://wordpress.org/extend/plugins/woocommerce/

  2. benshakespeare
    Member
    Posted 1 year ago #

    I'm having exactly the same problem, my system status appears to be fine. I do need to up the WP Memory Limit, but this problem's more pressing and the instructions are highly confusing!

    Whenever I add an item to my cart, it's not there. The same happens whether I add it directly from the products page or directly from that item's page. The only thing

  3. lipsk
    Member
    Posted 1 year ago #

    Frustrating isn't it? I've checked everything said on this post http://wordpress.org/support/topic/plugin-woocommerce-check-out-not-worknig but nothing I tried worked and no matter how much products I click to buy, when I open the shopping cart page, the cart gets empty.

  4. royho
    Member
    Posted 1 year ago #

    There could be many things that could cause this issue to happen and you will need to determine which one is causing it. Off the top of my head, a caching plugin could cause this. The other one is your sessions save path is not set correctly (more common). If you're unsure, ask your host to double check your sessions save path and that your site has write permissions to it.

  5. nkpromotions
    Member
    Posted 1 year ago #

    Mine is fixed.

    It turned out that the host provider needed to set up a path in the root folder to allow the shopping cart to save the session.

    I found it in the system status menu in the dashboard under woothemes.

    I hope that helps someone else.

  6. lipsk
    Member
    Posted 1 year ago #

    That's why it is frustrating.

    1 - No caching plugin on WordPress. It's a fresh install, it's only WP and Woocommerce. The caching problem could be caused by server caching?

    2 - The host garantees that session path is writable and is set correctly. Also "system status" page is all green saying that session path directory is writeable. Is there any more settings that I can check about the session?

    3 - Pages are all set correctly. They were created by the plugin install and I haven't changed anything on them. All of them had a shortcode, except "Store".

    4 - WP memory is set to 96M on wp-config.php. The php memory on php.ini is 128Mb

    5 - Force SSL is unchecked.

    6 - I've filled the paypal account e-mail and set PayPal gateway as the main gateway. Than I removed this option and set the default to be "by check".

    7 - No ajax errors on firebug console.

    8 - I've tested it logged as admin and logged out of wp-admin.

    Is there any other setting to check?

    Thank you for the help! :-)

  7. benshakespeare
    Member
    Posted 1 year ago #

    Like above, I'd checked everything.

    Contacted my host (ipage) who were able to sort it for me. No idea how though. Contacting host may be your only option?

  8. lipsk
    Member
    Posted 1 year ago #

    I'll have to change the host then, since they couldn't identify the problem.

  9. lipsk
    Member
    Posted 1 year ago #

    Well, just to register it: The problem on my host was on the directive
    "session.auto_start". They deactivated it and the cart started working.

    If you're using apache, and have the right options, you can enable session.auto_start with a .htaccess file containing this line:
    php_flag session.auto_start 1

  10. andersonenvy
    Member
    Posted 1 year ago #

    I can confirm that nkpromotions solution worked for me.

    Simply call the host provider and tell them to set up a path in the root folder to allow the shopping cart to save the session.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic