WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
[resolved] Fatal error when going to cart or checkout (9 posts)

  1. awesomeadam
    Member
    Posted 1 year ago #

    Just loaded woocommerce and posted a test product get the following error when trying to view cart or checkout?

    Fatal error: Call to a member function is_visible() on a non-object in /home/digital/public_html/studio/att/wp-content/plugins/woocommerce/templates/content-product.php on line 22

    I have deactivated all plugins and tried to find a solution online. Test site is here:
    http://studio.digitaledge.com.au/att/shop/

    http://wordpress.org/extend/plugins/woocommerce/

  2. royho
    Member
    Posted 1 year ago #

    Try this. Go to settings->permalinks and click on save twice. re-test.

  3. awesomeadam
    Member
    Posted 1 year ago #

    Hi Royho,

    Thanks for your suggestion. Unfortunately it did not work. Do you have any other suggestions?

    thanks
    Adam

  4. royho
    Member
    Posted 1 year ago #

    Well one issue I am seeing is when add to cart is pressed, your cart is not updated until page refresh. I am not sure that is the wanted behavior. Try using 2011 theme and see if you're still having this issue.

  5. awesomeadam
    Member
    Posted 1 year ago #

    excuse my ignorance, what is the 2011 theme?

  6. royho
    Member
    Posted 1 year ago #

    The default WordPress theme. You might need to go to your permalinks and save it after you switch themes.

  7. awesomeadam
    Member
    Posted 1 year ago #

    yep, it works with both 2011 and 2010 theme. Annoyingly it must be the Elegant Themes theme. Shame I liked that theme. Wish I knew what it was that was breaking it?

  8. royho
    Member
    Posted 1 year ago #

    Well Elegant themes are not really made for e-commerce although it says it is compatible. But still there is no excuse of it giving this error.

  9. awesomeadam
    Member
    Posted 1 year ago #

    Changed cart page template to "full width" and it works????
    Not ideal, but it works, I will keep looking into it.

    Thanks for your prompt and useful advice Royho, it certainly made troubleshooting a lot quicker and simpler for me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic