WordPress.org

Ready to get started?Download WordPress

Forums

Post Tiles
Plugin won't display more than 6 images (14 posts)

  1. clareneruda
    Member
    Posted 1 year ago #

    Hi there. I'm having a bit of trouble using the post tiles plugin on this page of my website: http://www.pastichemagazine.com/zine/

    Only 6 tiles show up when I specify a category, despite my being being able to display as many tiles as I wish when only the [post-tiles] tag is used.

    Similar to another user on here, I did at one point find that tags had been added to the plugin on-page. However removing them hasn't made a difference.

    Any help would be much appreciated!

    Thanks
    Clare

    http://wordpress.org/extend/plugins/post-tiles/

  2. clareneruda
    Member
    Posted 1 year ago #

    Above post should have read, I did at one point find that < strong > tags had been added to the plugin on-page. However removing them hasn't made a difference.

  3. clareneruda
    Member
    Posted 1 year ago #

    Hi, can anyone help me with this please?

  4. Jimmyhansen
    Member
    Posted 1 year ago #

    I can't answer your question, sorry lol.

    Mine won't display any more than 4 before pagination kicks in.

    Is there a way to turn pagination off and just have long columns of tile posts?

  5. clareneruda
    Member
    Posted 1 year ago #

    You should be able to using the posts='number' attribute, which I am doing. But for some reason it's not working on my site.

    Anyone else out there?

  6. ethanhackett
    Member
    Plugin Author

    Posted 1 year ago #

    I'm looking at your page and something odd is also effecting the pagination. If you look at the HTML on the page you'll see a BR tag after each anchor. I'm not sure where those are coming from. The Post-Tiles plugin shouldn't generate them so I'm wondering if there is another plugin or theme function.php file are effecting them.

    Try turning off all your plugins and see if it goes away. Then turn them back on one by one to see when they break. If that doesn't work try switching to the default wordpress theme for a second to see if that resolves it.

    Try that and let me know what you discover.

  7. ethanhackett
    Member
    Plugin Author

    Posted 1 year ago #

    For the posts='' are you putting multiple numbers in the posts='' block? The posts='' part of the shortcode is for the total count of posts not a list of the posts. I've seen people do a few times.

    Would you feel comfortable temporarily setting me up in the wordpress so I could look at it? so I can look at the short code and test a few things? If so my email is contact@ethanhackett.com.

  8. clareneruda
    Member
    Posted 1 year ago #

    This is the code I'm using: [post-tiles posts='50' categories='13']

  9. clareneruda
    Member
    Posted 1 year ago #

    I've tried it with different numbers in the posts="" block, both larger and smaller, and it hasn't made a difference. The only thing which does make a difference is deleting the categories="" block. Then, the number of posts displayed is equal to the posts="" parameter. Unfortunately, doing this wouldn't be appropriate for the site.

  10. clareneruda
    Member
    Posted 1 year ago #

    Have set you up as an editor class user on the site. Thanks for helping Ethan, it's much appreciated.

  11. ethanhackett
    Member
    Plugin Author

    Posted 1 year ago #

    I logged in yesterday and tried multiple things. I switch up the categories, tried various combinations of posts and categories. I checked to make sure the category IDs were correct. I switch it from single quotes to double and still nothing. I'm thinking that it might be a conflict with one of the plugins or perhaps the theme.

    The next test I would do would be to disable all your plugins temporarily and see if that fixes it. If not switch to the default them for a minute and see if that fixes it. I realize this is a pain but we've covered the basic issues and it's like searching for a needle in a haystack.

  12. alfredoparisi
    Member
    Posted 1 year ago #

    Hi Clareneruda, I would to hide the text in the box as you've done in your site, so I can show only the title.
    Can you help me?
    Thanks

  13. basicfm
    Member
    Posted 1 year ago #

    Hi,

    I just started building a new site and I am running into a similar issue. Tiles work like a dream on our http://basic.fm site but on this new site pagination kicks in at 4 tiles regardless of settings. It's here http://dominicsmith.info it uses the Hatch theme. I have checked for plug in conflicts etc.

    I appreciate this is a needle in a haystck, but I thought it might be useful to join in and see if a pattern starts emerging. Let me know if you want a log in to have a look into it.

  14. basicfm
    Member
    Posted 1 year ago #

    Ah, OK I figured it out.

    I don't know if it will help anyone else by pointing out where I was going wrong. It is is worth a try.

    I made 2 errors.

    Firstly I had the shortcode in the wrong order I was placing the post number after the categories i.e I was writing [post-tiles categories='13' posts='50'] when I should have been writing [post-tiles posts='50' categories='13']

    Secondly, wordpress was inserting weird tags into my shortcode. make sure your shortcode is entered into the text editing area rather than the visual editing area when editing your page, also make sure you have a space between categories and posts i.e. do this [post-tiles categories='13' posts='50'] not this [post-tiles categories='13'posts='50']

    Hope that helps.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic