WordPress.org

Ready to get started?Download WordPress

Forums

Plugin won't appear in plugin manager (14 posts)

  1. gossegotha
    Member
    Posted 6 years ago #

    I downloaded, extracted, then uploaded the xmasb-quotes plugin directory to my wp-content/plugins/ directory. I'm running WP 2.3.1, which is perfectly compatible with xmasb-quotes according to the compatibility list. I used cpanel to confirm that I have all permissions for all uploaded xmasb files. I then deleted the xmasb directory from my server, then re-uploaded it, then re-checked WP-admin's plugin manager, and still the xmasb plugin doesn't show up in the list of plugins available for activation. What gives?!?!

  2. MichaelH
    Member
    Posted 6 years ago #

    Just downloaded that plugin to my PC. Used cPanel to upload the xmasb-quotes.1.1.1.zip into my wp-content/plugins folder. Then in cPanel clicked on the file name and Extracted the contents. Went into Admin->Plugins and activated the plugin in WordPress version 2.3.2.

    Please review:
    Installing Plugins
    Changing File Permissions

  3. Roy
    Member
    Posted 6 years ago #

    Be sure you don't have the plugin in a 'double' folder, such as wp-content/plugins/pluginname/pluginname/plugin.php
    This happens when you make a folder to download the plugin to and then extract and a new folder is created doing that.

  4. homeycomb
    Member
    Posted 6 years ago #

  5. XmasB
    Member
    Posted 6 years ago #

    Hi, gossegotha.

    Have you solved this? I have not heard any reports of problems of this kind with this plugin.

    Please check if the plugin is uploaded properly (into wp-plugins/xmasbquotes/).

  6. gossegotha
    Member
    Posted 6 years ago #

    Hi guys,

    I deleted the /xmasb-quotes folder from wp-content/plugins/, used cpanel to upload the zip, then extract into wp-content/plugins/xmasb-quotes/--I made sure it didn't have a double folder--and still no luck. Then I thought, well, the creator said to make sure it's in wp-plugins/xmasbquotes/, so I took wp-content/plugins/xmasb-quotes/ and renamed it wp-content/wp-plugins/xmasbquotes/. Signed out and back into wp-admin, still no luck!!

  7. ClaytonJames
    Member
    Posted 6 years ago #

    If this is you:

    http://madeinhead.org/anism/

    That plugin is not in your plugin folder as I write this.

  8. gossegotha
    Member
    Posted 6 years ago #

    I just noticed it missing in the original filepath intended. It's back as of this writing. Try http://madeinhead.org/wordpress/wp-content/plugins/xmasb-quotes/

    And yet, it doesn't show up in the admin plugins page. (Yet.)

  9. ClaytonJames
    Member
    Posted 6 years ago #

    Delete the .zip folder from the plugins directory, refresh your plugins page in the admin panel and see if it shows up for you.

  10. gossegotha
    Member
    Posted 6 years ago #

    Deleted the .zip folder from wp-content/plugins/, refreshed the WP admin plugins page, nothing yet.

  11. ClaytonJames
    Member
    Posted 6 years ago #

    Unless there is something in the read-me that would help, it appears that it is now installed correctly. I'm sorry I could not assist.

    On a side note;

    You may want to do some reading on "Options -Indexes" for your .htaccss file. It will prevent people from browsing your site folders as we have today while trying to help out. Generally speaking, you may not want everyone to be able to view the contents of your directories. I hope you sort out the plugin.

    Best wishes.

  12. gossegotha
    Member
    Posted 6 years ago #

    Thanks all; tonight I realized that I must have been looking in the wrong /wp-content/plugins/ directory, since the one I'd been uploading into didn't have Akismet or Hello Dolly, the default WP plugins that were showing up in my plugins manager. So, sure enough, I found another /wp-content/plugins/ directory on my server, uploaded to there, unzipped there, and found the plugins in my plugins manager. Case solved; I hope this helps someone else avoid the same mistakes. Thanks again to all!

  13. lfahlberg
    Member
    Posted 5 years ago #

    No matter what I put in or take out of the /wp-content/plugins/ directory, nothing changes in the plugins manager list. Is it possible that my host has its own plugins directory? My blog is on my site which is hosted by dreamhost.

  14. lfahlberg
    Member
    Posted 5 years ago #

    Actually - after an hour of looking and looking, but immediately after posting the above message - I indeed found another /wp-content/plugins directory in a folder in the root called "blog" with wierd entries from my actual blog folder. I deleted this folder and now the plugins manager works!
    So all your struggles gossegotha showed me the way. Thank-you all.

Topic Closed

This topic has been closed to new replies.

About this Topic