WordPress.org

Ready to get started?Download WordPress

Forums

WinerLinks
[resolved] Options don't work (9 posts)

  1. Joss Winn
    Member
    Posted 3 years ago #

    I was using the version from GIT and have now upgraded to the wordpress repository version 0.2

    The options don't work. Winerlinks display permanently on posts and pages, despite my switching the options to otherwise.

    Only enable/disable works.

  2. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 3 years ago #

    Odd, I'm running into that issue on my production website as well. I'll take a look and update this thread shortly.

  3. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 3 years ago #

    Sorry about that. A set of parens was dropped and the logic for enabling/disabling was screwy. v0.2.1 should fix that, as well as add the stylesheet needed for the showy-hidey mode (which wasn't added the first time when I did the GitHub move). Let me know if you run into any further problems, or have ideas!

  4. Joss Winn
    Member
    Posted 3 years ago #

    Thanks, that's better. There's still a problem with the 'hidey mode'. It works sometimes. See this post as an example:

    http://joss.blogs.lincoln.ac.uk/2010/10/06/students-becoming-more-than-students/

    It works the first paragraph but the # is visible permanently on others.
    I wonder if it's conflicting with another plugin that uses javascript?

  5. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 3 years ago #

    I think it has to do with the markup of that particular post. I checked out a couple other posts you've published and it seems to work fine on those. You might want to revisit your markup (looking especially at how you've done blockquotes). If there are no issues with the markup in the admin, then I'll look further at how WinerLinks handles when there's multiple types of markup on the page.

    Thanks,

    Daniel

  6. Joss Winn
    Member
    Posted 3 years ago #

    I've noticed that the 'Rate this' link at the end of each post always shows the #

    It would be nice if lists had their own URI i.e. http://joss.blogs.lincoln.ac.uk/2010/09/29/questions-for-open-education/

    On paragraph 2 on this post, the # never appears:

    http://joss.blogs.lincoln.ac.uk/2010/10/06/dougald-hine-to-speak-about-technology-institutions-and-education/

    It may have something to do with the sentence finishing at the far right of the margin. I see that para 3 pushes para 4 down to display the #

    My markup is nothing unusual. I use the visual editor 99% of the time.

    I don't mind deactivating plugins if you think it might be a conflict.

    Here's the markup from the HTML editor for this post:
    http://joss.blogs.lincoln.ac.uk/2010/10/06/dougald-hine-to-speak-about-technology-institutions-and-education/

    Dougald Hine, co-founder of The School of Everything, has been invited by the <a href="http://www.lincoln.ac.uk/cerd">Centre for Educational Research and Development</a> to talk about his experience in setting up and running The School of Everything. He will be speaking at 3pm on October 13th, MB1010.
    
    <a href="http://feandskills.becta.org.uk/download.cfm?resID=41855&download_url=/content_files/learningandskills/resources/Articles/becta_school_of_everything_brochure%20.pdf"><img class="size-medium wp-image-2511 alignleft" title="School of Everything" src="http://joss.blogs.lincoln.ac.uk/files/2010/10/Selection_001-210x300.png" alt="" width="210" height="300" /></a>The <a href="http://schoolofeverything.com/about">School of Everything</a> is an award winning 'free school' for the 21st century, using the Internet to connect people who want to teach with people who want to learn. It's aim is to allow people to design their own education. In 2010, School of Everything was chosen by Becta and the Department for Business, Innovation and Skills as its new platform for adult informal learning in the UK.
    
    <a href="http://dougald.co.uk/">Douglad</a> will be speaking informally about how the School of Everything came about and how he sees it connecting to the wider relationship between technology, institutions and education.
    
    I am particularly interested in talk to Dougald about our idea for a <a href="http://joss.blogs.lincoln.ac.uk/2010/09/03/a-co-operatively-run-social-science-centre/">Social Science Centre</a> and hope that we can learn from his efforts to engage people in creating their own education. On a different note, I'm also interested in talking to him about his work on <a href="http://www.dark-mountain.net/">The Dark Mountain Project</a> and the role of education in crafting new stories for the future.
  7. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 3 years ago #

    One way to solve the problem of the RateThis functionality having a WinerLink might be to add the WinerLinks earlier in the post rendering process. I'll add it as a task for v0.3

    Where would you put the WinerLink if the plugin added them to lists?

    I see WinerLinks in all of the proper places for the second post. Did you figure out what the issue was?

    Thanks,

    Daniel

  8. Joss Winn
    Member
    Posted 3 years ago #

    Hi Daniel,

    I've not made any changes but I see that when I increase and decrease the size of the text on the page, the # for the second paragraph on that post, becomes available/unavailable. So the issue seems to depend on the font size of the browser and the placement of the last character. At 100% zoom with 16px times font using Chrome, the # is not available for the second paragraph but when I zoom out and decrease the size of the font, it is available. Likewise, if I zoom in and increase the font size, the # is available. I think this comes down to that paragraph ending at the end of the right-side margin (the word 'UK.') and there is nowhere for the # mark to appear. When I zoom in/out, I create room for the # and it works.

    If adding a permalink to a list, I would add it to the end of the list, after the last character.

    cheers.

  9. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 3 years ago #

    Oh, I see now. I was able to reproduce by zooming in a lot. I suspect this isn't a issue with WinerLinks but rather how Chrome is interpreting your theme and rescaling your main content area. The problem also presents itself with the third paragraph.

    I've added WinerLinks for lists as a feature request.

    Cheers,

    Daniel

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic