WordPress.org

Ready to get started?Download WordPress

Forums

Widgets on Pages
[resolved] Setting width of widgets on a page (11 posts)

  1. dizajn123
    Member
    Posted 1 year ago #

    Hi, i have problem setting width of widgets which are inserted via "widgets on pages" plugin. Here is a screenshot depicting my problem.

    http://img266.imageshack.us/img266/3518/examplej.jpg

    When i set WP to display recent posts all is cool, but when i set it to land on a page, with the widgets inserted via the plugin, widgets are not displayed in full widht of the page area. I`m not much of a PHP expert, so any help would be so nice. Thanks so much, cheers :)

    P.s. I`m using atahualpa theme on this blog

    http://wordpress.org/extend/plugins/widgets-on-pages/

  2. toddhalfpenny
    Member
    Plugin Author

    Posted 1 year ago #

    Hey there dizajn123,

    I'm not so sure (because I can only read English) which part of the page is the issue.

    Do you have a live link I can take a look at?

    Thanks,
    Todd

  3. dizajn123
    Member
    Posted 1 year ago #

    Ok, great! http://www.poreklo.rs/početna
    Thanks a lot man!

  4. toddhalfpenny
    Member
    Plugin Author

    Posted 1 year ago #

    Hi again,

    Can you let me know which piece of the page is meant to be full width?
    Perhaps a screen shot with the bit highlighted?

    Thanks

  5. dizajn123
    Member
    Posted 1 year ago #

    http://img266.imageshack.us/img266/3518/examplej.jpg

    Yes, here is the screenshot, i`ve marked it with a red arrow on left side of a pic, so i would like to "stretch to full width of a center column" these first 3 widgets on a homepage (Fa lite and slide deck widgets)Thanks for your time :)

  6. dizajn123
    Member
    Posted 1 year ago #

    Hi there, actually this might be much better example. This is how it should look...
    http://img593.imageshack.us/img593/4092/screenshot2lv.jpg
    I dont know what is the problem, but this slider has a full width, when i insert it on a landing page without WOP. When i put it on a page via WOP plugin, i cant get full width, and it looks like this:
    http://img840.imageshack.us/img840/66/screenshot3ra.jpg

    (I`ve highlighted the undesired gaps in fluo green)

    Thank You, I hope I haven` bored you too much :)

  7. toddhalfpenny
    Member
    Plugin Author

    Posted 1 year ago #

    Hey again,

    Thanks for the images, they were really helpful.

    The solution should be a very simple one. Can you add the following to the end of your theme's style.css?

    .widgets_on_page ul {padding: 0;}

    Let me know how you get on.

    Todd

  8. dizajn123
    Member
    Posted 1 year ago #

    Hello, first thing first: THANK YOU very much for your time.
    I`ve tried adding the code to style.css, but sadly with no success.
    Also, i`ve tried to reset all theme options, and again no results.
    Must be a CSS related problem, but I have no ideas at this time.
    Also, i tried adding !important after widgets_on_page ul {padding: 0;}
    but with no sucsess :(
    I don`t know what else to try.
    Ill keep digging, and ill keep you posted :)

  9. toddhalfpenny
    Member
    Plugin Author

    Posted 1 year ago #

    That's really odd... it works just fine when I add it via the web developer toolbar.

    Perhaps add it to the end of the wop.css (in the Widgets on Pages plugin folder)... or use the "inspect element" browser tool to find out which piece of CSS is causing this?

  10. dizajn123
    Member
    Posted 1 year ago #

    I did like You said, and everything looks very good now.
    Thank You very much, You are awesome!

  11. toddhalfpenny
    Member
    Plugin Author

    Posted 1 year ago #

    Great to hear!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic