WordPress.org

Ready to get started?Download WordPress

Forums

Widget Settings Importer/Exporter
[resolved] Import doesnt work (15 posts)

  1. logikdev
    Member
    Posted 2 years ago #

    I can successfully obtain a JSON file when using the export feature. Once i try to upload this file to my other site, the process just doesnt start. I select the file, and then nothing happens. Clicking on the "Show Widget Settings" button just underneath only displays the "Select all" and "un-Select All" buttons, with nothing to be selected.

    http://wordpress.org/extend/plugins/widget-settings-importexport/

  2. martinbeasnunez
    Member
    Posted 2 years ago #

    idem
    (same problem)

  3. Kevin Langley
    Member
    Plugin Author

    Posted 2 years ago #

    Are you sure your settings were successfully exported and the file isn't blank, right?

  4. Kevin Langley
    Member
    Plugin Author

    Posted 2 years ago #

    There is the possibility that the version I just released might fix this issue (Althought, I'm not positive as I have not been able to reproduce).

    Please test and let me know if you're still having issues.

  5. JochenT
    Member
    Posted 2 years ago #

    If you use any plugin like 'Speed Trap' which outputs something at the end of the page, you will get this error, too.

  6. Kevin Langley
    Member
    Plugin Author

    Posted 2 years ago #

    @JochenT, did you try the version I released today?

  7. JochenT
    Member
    Posted 2 years ago #

    With the today's release I could download the export file properly.

    I am testing on two servers, on which one failed with the download dialog with the old version. Nevertheless, the plugin 'Speed Trap' adds his Javascript to the export file. Of course the import fails, if this is not removed manually before.

  8. Nanette Kalisvaart
    Member
    Posted 1 year ago #

    Hi,

    You have set this issue to 'resolved' but I have this problem now and can't get it to work.

    I'm using version 0.6.

    Hope you can help me.

  9. Nanette Kalisvaart
    Member
    Posted 1 year ago #

    I'm using version 1.0 now, but still no-go. How can I tell if the file is perhaps empty?

  10. Kevin Langley
    Member
    Plugin Author

    Posted 1 year ago #

    You could open the file in a simple text editor to ensure that it is not blank.

    What issue are experiencing?

    There are multiple issues listed in this comment thread. If it displays nothing, I would check the php error log and also check the permissions you have applied to your uploads folder. If it is the issue that is being presented from the plugin Speed Trap that JochenT is referring to, that is an issue with that plugin that needs to be fixed by the author. Nothing I can do for that.

    With a little more info, I might be able to help.

  11. Nanette Kalisvaart
    Member
    Posted 1 year ago #

    Hi Kevin,

    Thanks for getting back so quickly.
    I have now opened the file and it is not blank.

    Sorry I wasn't clear.
    The issue is that when I want to import it, "I select the file, and then nothing happens. Clicking on the "Show Widget Settings" button just underneath only displays the "Select all" and "un-Select All" buttons, with nothing to be selected."

    I don't have 'Speed Trap' installed.

    I'm not that able in WP (yet) that I instantly know what you mean bij checking 'error logs' and 'permissions'; I will have to dig into that. But it's nighttime now and (almost) time for bed overhere (Netherlands).
    I will get back with you.

  12. Nanette Kalisvaart
    Member
    Posted 1 year ago #

    Hi Kevin,

    Me again.
    I went through the (very interesting learning) process of creating an error-log-file and adjusting the wp-config.php accordingly.

    The error-log says:

    [16-Dec-2012 07:24:18] PHP Warning: file_get_contents() [function.file-get-contents]: Filename cannot be empty in /var/www/vhosts/vrouwenkamer.nl/httpdocs/wp-content/plugins/widget-settings-importexport/widget-data.php on line 403

    (And I've set permissions to the wp-content/uploads-file to be sure to rwx-rwx-rwx.)

    Any idea what to do next, because my *.json-file is not empty?

  13. gwa777
    Member
    Posted 1 year ago #

    I installed the plugin directly from my plugins "Add Plugin" page. Once installed, here is the IMMEDIATE error message that pops up within the WP admin area. This is from a fresh install of WP (up-to-date version), it is the only plugin installed so far:

    "Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected T_FUNCTION in /home/icustom/public_html/wp-content/plugins/widget-settings-importexport/widget-data.php on line 49"

    I desperately need to get this working. Can you please help and define what you think I need to do to resolve this issue?.

    Thank you! :)

  14. Kevin Langley
    Member
    Plugin Author

    Posted 1 year ago #

    gwa777,

    Please next time open a new issue as this issue has since been set as resolved and opening new issues keep a good track of the issues instead of just adding multiple onto the same thread.

    The plugin actually only supports PHP 5.3+ which is why you are receiving the error. PHP 5.2 does not support anonymous functions which is what is being used on line 49 of widget-data.php.

    If you have the ability to upgrade your version of PHP to 5.3 or higher, do so. Otherwise I would just download version 1.0 of the plugin, as that version will support PHP 5.2.

  15. Kevin Langley
    Member
    Plugin Author

    Posted 1 year ago #

    NanetteKalisvaart,

    I apologize as I did not see your reply here until now, but I think the issue is related to not having correct permissions on the uploads or blogs.dir directory.

    If you're using a WP Multisite, update the permissions to wp-content/blogs.dir, otherwise if it is a normal WP install, update the permissions to the wp-content/uploads folder to have write permissions.

    Let me know if that fixes it.

    I am actually going to release a new version within a few days that shouldn't be using file_get_contents but instead uses wp_remote_get which has better error handling for things like this. Keep an eye out for version 1.2

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic