WordPress.org

Ready to get started?Download WordPress

Forums

Widget Logic
[resolved] Problem after upgrading to 0.53 (7 posts)

  1. mr.cool
    Member
    Posted 1 year ago #

    Hello,

    After the update from 0.52 to 0.53 I get an error message on my blog (line 2xxx).

    WordPress: 3.4.1

    I have deactivate the plugin. When I activate it again I get the message:
    Fatal error: Can't use function return value in write context in /home/www/cwcity/hosting/m/r/mrcool/htdocs/grg/wp-content/plugins/widget-logic/widget_logic.php on line 264

    Sven

    http://wordpress.org/extend/plugins/widget-logic/

  2. mssbee
    Member
    Posted 1 year ago #

    Same fatal error message for me, running latest WordPress. Unable to activate plug-in. Rolling back to previous version, please fix as this is a go to plugin for me, I love it!

  3. orionis23
    Member
    Posted 1 year ago #

    Also here... after update to 0.53 plugin won't reactivate, gives fatal error shown in above post.

  4. dfumagalli
    Member
    Posted 1 year ago #

    Same.

    First the plug in totally made my WP go blank so I had to rename it via FTP.

    Now, whatever full reinstall I do, I get:

    Plugin cannot be enabled because it generates a fatal error.

    Fatal error: Can't use function return value in write context in /(my wp path)/wp-content/plugins/widget-logic/widget_logic.php on line 264

    Using WP 3.4.0 italian locale.

  5. Lee
    Member
    Posted 1 year ago #

    Same here.

    Remember you can forcefully deactivate the plugin by deleting it from /wp-content/plugins/widget-logic. Deleting the plugin files will not delete its settings.

    After deletion, re-install the plugin. Do not reactivate it until the developer releases version 0.54. Point of re-installing it is that you'll know when the new release is out because WP will tell you.

  6. alanft
    Member
    Plugin Author

    Posted 1 year ago #

    apologies - I accidentally made 0.53 the stable version. That was an error. I've tried to fix that, the repository should point back to 0.52 soon

  7. psbook
    Member
    Posted 1 year ago #

    [14-Jul-2012 14:59:19] PHP Fatal error: Can't use function return value in write context in / [... snip ...] /content/wp-content/plugins/widget-logic/widget_logic.php on line 264

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.