WordPress.org

Ready to get started?Download WordPress

Forums

Widget Logic
Not display correctly (9 posts)

  1. JustBlog
    Member
    Posted 2 years ago #

    The current version of 0.52 still not displaying correctly.

    I put the logic as is_home() but it still display in post and other pages.

    Reverting to 0.48 and everything is good.

    http://wordpress.org/extend/plugins/widget-logic/

  2. RichardWPG
    Member
    Posted 2 years ago #

    What version is your WordPress?

  3. JustBlog
    Member
    Posted 2 years ago #

    I'm using 3.3.2

  4. alanft
    Member
    Plugin Author

    Posted 2 years ago #

    Curious. Try changing the value of the "Load logic" point on the widget options page, to see if that makes any difference.

    Do you use the wp_reset_query fix option? I'm very much aware that this function needs to work differently since 0.50, but have had little feedback about that.

  5. JustBlog
    Member
    Posted 2 years ago #

    How to change the value?

    I don't use wp_reset_query fix option. Do I need to?

    Before I do anything and in case it messes up, may I know how can I revert to the old version? How can I download the previous version?

    Thanks!

  6. alanft
    Member
    Plugin Author

    Posted 2 years ago #

    http://wordpress.org/extend/plugins/widget-logic/developers/ for older versions (this works for all plugins I think)

    and the value is changed on the widget options page - check the screenshots

    http://wordpress.org/extend/plugins/widget-logic/screenshots/

    if it worked before 0.5 then chances are changing the load logic point to 'during page header' will sort you out. Further explanation:

    http://wordpress.org/extend/plugins/widget-logic/installation/

  7. draivika
    Member
    Posted 2 years ago #

    Hi,
    I am having a similar issue where logic suddenly stopped working for my sidebar. Simple query like is_single or is_page has no effect. Was working previously but just noticed it not working recently so i have no idea if it happened after an upgrade.

    Tried all Widget Logic options to no avail.

  8. alanft
    Member
    Plugin Author

    Posted 2 years ago #

    @draivika, on another recent post you mentioned a widget logic you found that worked for you that was a compound of is_single && something else. Do you mean specifically that is_single by itself stopped working under some circumstances?

  9. draivika
    Member
    Posted 2 years ago #

    @alanft The other post referred to a different site which is working fine. I actually use Widget logic on many other sites without an issue, it's just recently that I noticed these sidebars disappearing and the logic doesn't seem to work any more. I am now trying to see if my theme is causing a conflict.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.